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This document is a quick reference guide to the options available on the 
simulator bugger/debugger (MDB). Using the simulator and MDB will 
help you understand problems customers can encounter, which will help 
you identify and solve future problems more quickly. Use this document 
to familiarize yourself with the options available on the MDB interface. 

Notational Conventions 

HDM-xxx-O 
December 20, 1994 

While you read this document, keep in mind the following notational 
conventions: 

• Buttons are shown the way they appear in windows: ~. 

• Settings are shown the way they appear in windows: ~ or I Selected I. 

• The arrow symbol (-» indicates that you should hold down the 
MENU mouse button while moving the mouse pointer to an 
adjoining menu item. 

• Courier type indicates a command you can enter. 

• courier bold type indicates commands you should enter. 

• Helvetica type indicates references to text in the MDB interface 
windows. 

• Helvetica bold type indicates menu entries you should choose from 
the interface; for example, File -> Load -> Bug refers to three 
adjoining menus (refer to illustration at left) . 
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Interface Components 

Figure 1 shows the MDB interface base window. The sections following 
the figure describe, in clockwise order, the components of the interface 
called out in the illustration. 

Base Window Title 
Simulator 

Vers'on Number Workstation 

1 
I 

1 ! r-
Control Points 

Breakpoin 
Status 
Fields 

/ 
t 

-
Breakpoin 

List Are 
t 
a 
""-

Current 
Bugfile 
Display -

® MSIM Simulator Bugger/Debugger (MOB 1.0.1) SIM [stanley) (12) 

~ (View v) ~ ( Properties v) (Utilities v) (Reset v) 

~ RUN~ RUN~ RUN~ RUN 

~ RUN [22J RUN0 RUN0 RUN 

~ RUN@] RUN [EJ RUN [EJ RUN 

~ RUN~ RUN [EJ RUN@] RUN 

[§J RUN~ RUN [E] RUN~ RUN 

~ RUN~ RUN~ RUN~ RUN 

06 RUN 16 RUN 26 RUN 36 RUN 

~ RUN0 RUN [EJ RUN~ RUN 

E:YHakpl)int Ust~ Breakpoints CPUs l --- r. I All I Selected I I All I Selected I 
( Enable ) ( Run ) .. 

II 
( Disable ) ( Step ) 

Current Bug: 1. ~ 
bugcache2 ( Pause ) __ .M ___ • ______ ..J= 

usr /ms Im/m db user /bugcache2 User Bugmode 

Figure 1. MDB Interface Base Window Components 

... Copy Number 

Menu Bar 

CPU Area 

/ 

f4-

... 
Control Area 

Mode 
Indicator 

Base Window Title 

Version Number 

4 

The base window title area displays the name of the program: MSIM 
Simulator Bugger/Debugger (MDB). 

The version number area indicates which version of the software you are 
using. 
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Simulator Indicator 

Workstation 

Copy Number 

Menu Bar 

CPU Area 

HDM-xxx-O 
December 20, 1994 

The simulator indicator shows that MDB is running with the simulator 
(indicated by SIM in Figure 1). 

The workstation indicator shows the name of the workstation on which 
MDB is running (indicated by stanley in Figure 1). 

The copy number indicates the copy of MDB you are using (indicated by 
(12) in Figure 1. 

The menu bar contains six menu buttons. Use the commands that appear 
when you press these buttons to manipulate MDB. Refer to "Menu 
Button Commands" for more detailed information about the menu button 
options. 

This area shows the total number of CPUs available to the MDB control 
program. If a CPU does not have its status set to N/A, then it is available. 
If any CPU or CPUs (00 through 37) appear highlighted in a bold face 
outline (on a monochrome display) or appear pressed in (on a color 
display), they are selected. 

Cray Research Proprietary 
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Control Area 

6 

The following controls reside in the control area of the MDB interface 
base window (Figure 1 shows the location of the control area): 

Control 

I All I Selected I 
(breakpoints) 

[AiiJ Selected I 
(CPUS) 

( Enable ) 

( Disable ) 

Run ) 

( Step ) 

( Pause ) 

Current Bug: 

Description 

Determines which breakpoints are affected 
when you use the (Enable ) and 
(Disable) buttons. The selected breakpoint 
refers to a breakpoint enclosed in a box in the 
Breakpoint List scroll box of the base window. 

Determines which CPUs are affected when 
you use the (Run ) , (Step ) , 

(pause), (Enable) , and (Disable) 

buttons. If you use ~ CPUs, then all CPUs 
not marked as Nt A are affected by the 
(Run ), (Step ), and (~-Pa-u-se-~) 

buttons; and all CPUs assigned to the 
currently selected breakpoint are affected by the 
(Enable ) and (Disable) buttons. 

Enables specified breakpoints. One or more 
CPUs must be selected. 

Disables specified breakpoints. 

Runs ~ or I Selected I CPU s until a breakpoint is 
reached, until you click on (Pause ), until 
you click on (Step ) , or until the 
simulated mainframe is master cleared by 
MME. 

Runs step mode on ~ or I Selected I CPU s. The 
CPUs in step mode issue the specified number 
of instructions and then pause (unless a 
breakpoint is reached). 

Pauses ~ or I Selected I CPUs. When a CPU 
pauses, PAU appears to the right of that CPU 
in the interface. 

Displays the bugfile loaded with the 
File -> Load -> Bug command. 
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The mode indicator shows the type of mode you are currently using. 
There are two modes: auto mode and user mode. The system supplies 
default settings in automatic mode, or you can specify your own settings 
in user mode. 

Current Bugfile Display 

This display shows the bugfile currently in operation. 

Breakpoint List Area 

This area displays breakpoints you can select and manipulate. The Edit-> 

Set Breakpoint command (described later in this document) brings up the 
MDB Set Breakpoint window. Selecting the (set) button from this 
window adds the breakpoint to the breakpoint scroll box in the MDB base 
window. 

Control Points/Breakpoint Status Fields 

HDM-xxx-O 
December 20, 1994 

Breakpoint status fields are to the right of the corresponding CPU 
numbers in the MDB interface base window. The letters in the breakpoint 
status fields identify the status of each CPU regarding the currently 
selected breakpoint: 

• B indicates that the breakpoint is currently triggered. 
• D indicates that the breakpoint is currently disabled. 
• E indicates that the breakpoint is currently enabled. 
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Menu Button Commands 

This subsection describes each MDB menu button command available 
from the menu bar (refer again to Figure 1). Figure 2 (at the end of this 
document) shows all menu selections possible from the MDB interface 
base window and provides a page number to which you can refer for more 
information about each menu selection. Refer to this illustration as you 
read about each selection. 

File -> Load -> Bug 

8 

The File -> Load -> Bug command, as shown at left, enables you to load a 
bugfile. When you choose this command, the following window appears: 

19 MDB Load Bug 

Dir: @.l I!J sim/mdbauto/. 

Files; 
r----··--i~ 

I I-
I 

'--_____ ---'I~ 
Currently, there are rw auto bug files. 

To choose user bug mode and display user bug files, select Properties -> 
Bug Mode -> User and then choose the File -> Load -> Bug command. The 
MDB Load Bug window appears: 

Cray Research Proprietary 
Preliminary Information 

HDM-xxxx-O 
December 20, 1994 

) 

) 



) 

) 

HDM-xxxx-O 
December 20, 1994 

GRAY T90 Series MDB Interface Reference 

!9 MDB load Bug 

Dir: @) [Usim/mdbuserl'. 

Files: 

bug<a<hel ~~ 
1r.'-~---=ug:":"'<a-:;<h:-:Ce2;O------'1 .. 

bug<a<he3 
buglat1 
bugmem1 
bugmem2 
bugmem3 
bugshr1 
bugshr2 
bugshr3 
bugshr4 
dearbug 
dearbugm 

( Load) 

13 files found 

Choosing a bug file in the MDB Load Bug window in user bug mode and 
pressing the C§!:) button causes that bugfile to appear in one of the 
MSIM bugmaker windows. Refer to "Utilities -> Bugmaker -> Shared" 
and "Utilities -> Bugmaker -> Memory" later in this document for more 
information about the bugmaker utilities. 

The currently loaded bug file is shown in the Current Bug: field of the 
MDB base window. 
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View -> Registers 

10 

The View -> Registers command, as shown at left, opens the MDB View 
Registers Setup window, which enables you to verify or modify register 
parameters. 

!9 MDB View Registers Setup 

Format: 

Byte Half Hex 

Parcel Word 

Registers: 

Exchange VO V4 

B Regs Vl V5 

T Regs V2 V6 

Shared V3 V7 

Size: 

Small 

Medium 

large 

X-large 

CPU: 

0.. 

(procedure to be provided) 

Font: 

Small 

Medium 

large 

X-large 

( View... ) 

Clicking on the ( View... ) button displays the specified register: 

CPUO Regs 

CPU 1110 
P OOOOOOOOOOa AD 000000 000000 000000 000000 SO 000000 000000 000000 000000 
PH 000 Al 000000 000000 000000 000000 51 000000 000000 000000 000000 
XA 0000000 A2 000000 000000 000000 000000 52 000000 000000 000000 000000 
EXO 0000000 A3 000000 000000 000000 000000 53 000000 000000 000000 000000 
EXl 0000000 A4 000000 000000 000000 000000 54 000000 000000 000000 000000 
EX2 0000000 AS 000000 000000 000000 000000 55 000000 000000 000000 000000 
EX3 0000000 AS 000000 000000 000000 000000 56 000000 000000 000000 000000 
EX4 0000000 A7 000000 000000 000000 000000 57 000000 000000 000000 000000 

CN 000 Vl 000 MODE5 00 5CE TRl E5l BOM MM STAT5 00 VNU FP5 WS BMl 

1M 000000 IRP IUM IFP lOR IPR FEX IBP ICM IMC IRT lIP 110 IPC IDl IMI FNX lAM 
IF 000000 RPE HUE FPE ORE PRE EEX BPI MEC MCU RTI ICP 101 PCI Dl MIl HEX AMI 

lATO RWXC 00 RWXD 00 PB 0000000000000 lB 00000000000000 II 00000000000000 
lATl RWXC 00 RWXD 00 PB 0000000000000 lB 00000000000000 II 00000000000000 
lAT2 RWXC 00 RWXO 00 PB 0000000000000 lB 00000000000000 II 00000000000000 
lAT3 RWXC 00 RWXO 00 PB 0000000000000 lB 00000000000000 II 00000000000000 
lAT4 RWXC 00 RWXO 00 PB 0000000000000 lB 00000000000000 II 00000000000000 
lATS RWXC 00 RWXO 00 PB 0000000000000 lB 00000000000000 II 00000000000000 
lAT6 RWXC 00 RWXO 00 PB 0000000000000 lB 00000000000000 II 00000000000000 
lAT7 RWXC 00 RWXO 00 PB 0000000000000 lB 00000000000000 II 00000000000000 
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The View -> Channels command, as shown at left, opens the MDB View 

Channels Setup window, which enables you to specify or verify channel 
information. 

!9 MOB View Channels Setup 

Format: 

Byte I Half J Hex 
Parcel I Word J 

Channel Tvpe: 

I VHISP I 
I lOSP J 

Size: Font: 

Small Small 

Medium Medium 
large large 

X-large X-Large 

Channel II: ( View ... 
100. 

(procedure to be provided) 

) 

I 

Clicking on the ( View... ) button causes a window to appear that displays 
channel information you specify in the MDB View Channels Setup window. 
The following illustration shows channel information for LOSP channels: 

lOSP Channels 

ESI 0 EHI-CPU 00 01 02 03 04 05 06 07 10 11 12 13 14 15 16 17 
CI 00 IIO-CPU 00 01 02 03 04 05 06 07 10 11 12 13 14 15 16 17 

EHI -CPU 20 21 22 23 24 25 26 27 30 31 32 33 34 35 36 37 
IIO-CPU 20 21 22 23 24 25 26 27 30 31 32 33 34 35 36 37 

100 CA 00000000000 STAT 00000000000 
CL 00000000000 

101 CA 00000000000 STAT 00000000000 
CL 00000000000 

102 CA 00000000000 STAT 00000000000 
CL 00000000000 

103 CA 00000000000 STAT 00000000000 
CL 00000000000 

104 CA 00000000000 STAT 00000000000 
CL 00000000000 

105 CA 00000000000 STAT 00000000000 
CL 00000000000 

106 CA 00000000000 STAT 00000000000 
CL 00000000000 

107 CA 00000000000 STAT 00000000000 
CL 00000000000 

Cray Research Proprietary 
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iDDIIERROR PE/DISC 
Int Held Enabled 
iDDIIERROR PE/DISC 
Int Hel d Enabled 
IImiIERROR PE/DISC 
Int Held Enabled 
IIIiIERROR PE/DISC 
Int Held Enabled 
IIIiIERROR PE/DISC 
Int Hel d Enabled 
IIIiIERROR PE/DISC 
Int Held Enabled 
IIIiIERROR PE/DISC 
Int Held Enabled 
iDDIIERROR PE/DISC 
lnt Held Enabled 
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Edit -> Set Breakpoint 

Select CPUs I> 

Deselect CPUs I> 

Remove Bug 

12 

The Edit -> Set Breakpoint command, as shown at left, opens the MDB Set 
Breakpoint window, which enables you to modify breakpoint parameters. 

~ MOB Set Breakpoint 

Select CPUs: 

(Selected Breakpoint's ) 
( A II Availab Ie C P Us ) 

Deselect CPUs: 

( Exce pt Breakpoi nt's ) 
( All CPUs ) 

When any CPU hits breakpoint: 

o Hold All CPUs 

CPUs: 

I Selected I 
I All I 

Address: 

0. 

Base: 

I CPU IBA lAbs 

Mode: 

I Insert I Replace I 
( Set ) 

Follow this procedure to set a breakpoint with this window: 

1. Click on the appropriate option under Select CPUs: (or click on the 
numbered CPU indicators in the base window): 

(Selected Breakpoint's ) selects CPUs assigned to the current breakpoint, so 
you can perform operations on all the CPUs associated with that 
breakpoint. 

(AIiAYaliablecPUs ) selects all available CPUs if control point tracking is 
off. It selects only the currently assigned control points 
(corresponding to MME) if control point tracking is on. 

NOTE: If control point tracking is on, the All Available CPUs menu 
selection means all CPUs assigned to the current MME 
control point. If control point tracking is off, All Available 
CPUs means all of the physical CPUs. 
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2. Click on the appropriate option under Deselect CPUs: (or click on the 
numbered CPU indicators in the base window): 

( Except Breakpoint's ) deselects CPUs except for those CPUs with the 
current breakpoint assigned to them (use this command to choose 
only the CPUs affected by the breakpoint). 

All CPU, ) deselects all CPUs. 

3. If you want to hold all CPUs when the breakpoint is reached in any 
CPU, click on the Hold All CPUs box. To allow other CPUs to keep 
running when a particular CPU reaches a breakpoint, click on ~ or 
I Selected I CPUs. 

4. Click on I CPU IBA I to specify the address relative to the current value 
in the instruction base address and to have it recalculated after every 
exchange, or click on lEE1 (absolute) to use a fixed address in 
memory. 

5. Click on I Insert I to create a new breakpoint, or click on I Replace I to 
replace the currently selected breakpoint, including its CPU 
assignments. 

6. Click on the address: field and type the value you want. 

7. Click on ( Set ) to set a breakpoint. 

8. Click on ( Clear ) to clear set breakpoints. 

Edit -> Clear Breakpoint -> Selected Breakpoint 

The Edit -> Clear Breakpoint -> Selected Breakpoint command, as shown at 
left, enables you to clear breakpoints previously set with the Edit -> Set 

Breakpoint command. Breakpoints in the Breakpoint List: scroll box of the 
MDB base window are cleared. Unless a breakpoint has been set, this 
menu selection appears gray in the menu and is not functional. 

Set Breakpoint... Delete Breakpoint 

Select CPUs All 

Deselect CPUs 

Remoye Bug 

HDM-xxxx-o 
December 20, 1994 
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Edit -> Clear Breakpoint -> All 

-. 
Set Breakpoint. .. 

Select CPUs 

Deselect CPUs 

Remove Bug 

The Edit -> Clear Breakpoint -> All command, as shown at left, enables you 
to clear breakpoints previously set with the Edit -> Set Breakpoint 

command. Breakpoints in the Breakpoint List: scroll box of the MDB base 
window are cleared. Unless a breakpoint has been set, this menu selection 
appears gray in the menu and is not functional. 

Delete Breakpoint 

Selected Breakpoint 

I 

Edit -> Select CPUs -> Selected Breakpoint's 

The Edit -> Selected CPUs -> Select Breakpoint's command, as shown at 
left, enables you to select those CPUs assigned to the current breakpoint, 
so you can perform operations on all the CPU s associated with that 
breakpoint. .... ' . 

Select CPUs .... ' ... ,. 
Deselect CPUs 
Remoye Bug 

All Available CPUs 

Edit -> Select CPUs -> All Available CPUs 

The Edit -> Select CPUs -> All Available CPUs command, as shown at left, 
selects all available CPUs if control point tracking is off. It selects only 
the currently assigned control points (corresponding to MME) if control 
point tracking is on. 

Set Breakpoint .. r--'i~_.,---------c 
=::i>:·ar Ora.;cKij(·!r;!: o-a=o Select CPUs 

Selected Breakpoint's 

Deselect CPUs 1."~"!."""!i!!EI!I!!.!!iII!-!J 
RemoVe Bug I'; 

14 

CPUS can also be selected individually by clicking on the appropriate 
number in the CPU area of the base window (refer to Figure 1). 

NOTE: If control point tracking is on, the All Available CPUs menu 
selection means all CPUs assigned to the current MME control 
point. If control point tracking is off, All Available CPUs means 
all of the physical CPUs. 
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Edit -> Deselect CPUs -> Except Breakpoint's 

The Edit -> Deselect CPUs -> Except Breakpoint's command, as shown at 
left, deselects CPUs except for those CPUs with the current breakpoint 
assigned to them (use this command to choose only the CPUs affected by 
the breakpoint). 

=::i.:-3.' em:.;.k;l(-i!,,!i: ;:-!) ~,.--___ ---, 

Select CPUs Dese lect CPUs 

8II1II.II1II. '+.'1".'. 
Remove Bug All CPUs 

Select CPUs 

Remove Bug 

Set Breakpoi nt. .. 

Properties -> Bug Mode -> Auto 

P RegS/Breakpoints l ~ I 
Ctrlpolnts .... 

P Registers l> 

Con fig uration ... 

HDM-xxxx-O 
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The Properties -> Bug Mode -> Auto command, as shown at left, selects 
automatic bug mode. The currently operating bug mode is displayed by 
the mode indicator in the MDB interface base window (refer again to 
Figure 1). This command is not yet implemented. 
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Properties ~ Bug Mode -> User 

P Regs/Breakpoints 
Ctripoints 
P Registers 

Con fig uration ... 

The Properties -> Bugmode -> User command, as shown at left, selects user 
bug mode. The currently operating bug mode is displayed by the mode 
indicator in the MDB interface base window (refer again to Figure 1). 

After choosing user bug mode, you can display user bug files by selecting 
the File -> Load -> Bug command. The MDB Load Bug window appears: 

~. . 

19 MDB load Bug 

Dir: ® ffi sim/mdbuser/. 

Flies: 

bugcache1 ~~ 
r.lb~ug~ca-c~he~2------~1 9 

bugcache3 
buglat1 
bugmem1 
bugmem2 
bugmem3 
bugshr1 
bugshr2 
bugs,hq 
bugshr1." 

" de~'r.fiug' 
''C~e.ar1·ugm ' 

) 

13 files found 

':.:t..~ ".:.:;:~ ~~1J~ .. :--:~-(":;; . ". ','.' ,.,t:. 
\." -'C" ""1- 1.';, :" . 

. :" :\l;~":\t'" ., ';:;" ,;.: 
',. ~ Choo§mga bug file in the MDB Load Bug window (in user mode) and 

preS~lng the c:::§D button causes that bugfile to appear in one of the 
MSIM bugmaker windows. Refer to "Utilities -> Bugmaker -> Shared" 
and "Utilities -> Bugmaker -> Memory" later in this document for more 
information about the bugmaker utilities. 

\!'\ ." 
.;; 

Properties ~ P Regs/Breakpoints ~ P Registers 

Ctrlpoints 

P Registers 

Configuration ... 

16 

The Properties -> P Regs/Breakpoints -> P Registers command, as shown at 
left, enables you to display P registers. P register addresses appear to the 
right of each CPU number in the base window. 

Breakpoint List 

Triggere d Breakpoi nts 
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Properties -> P Regs/Breakpoints -> Breakpoint List 

_Mil. H 
Bug Mode t> 

Ctrlpoints 

P Registers 

Config uration ... 

The Properties -> P Regs/Breakpoints -> Breakpoint List command, as shown 
at left, displays breakpoint addresses at each selected control point. 

P Registers 

Triggere d Breakpoi nts 

Properties -> P Regs/Breakpoints -> Triggered Breakpoints 

Ctrlpoints 

P Registers 

Configuration ... 

The Properties -> P Regs/Breakpoints -> Triggered Breakpoints command, as 
shown at left, displays P register values for all CPUs that have reached a 
breakpoint. 

P Registers 

Breakpoint List 

) Properties -> Ctrlpoints -> Track 

) 

Bug Mode 

P Registers 

Configuration ... 

The Properties -> Ctrlpoints -> Track command, as shown at left, enables 
you to track control points while you manipulate CPU s and breakpoints. 

N/A appears to the right of each CPU that is not assigned to the current 
control point in MME. 

Properties -> Ctrlpoints -> Ignore 

Bug Mode 

P Registers 

Configuration ... 

HDM-xxxx-O 
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The Properties -> Ctrlpoints -> Ignore command, as shown at left, enables 
you to ignore control-point tracking. All CPUs become available for 
manipulation by MDB regardless of CPU assignments to MME control 
points. 
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Properties -> P Registers -> Absolute 

Bug Mode I> 

P RegS/Breakpoints I> 

Ctrlpoints I> 

Config uration ... 

The Properties -> P Registers -> Absolute command, as shown at left, 
displays the memory locations from program address registers (P 
registers) in absolute format. 

Properties -> P Registers -> IBA Relative 

Bug Mode I> 

P Regs/Breakpoints I> 

The Properties -> P Registers -> ISA Relative command, as shown at left, 
displays the memory locations from P registers in instruction base address 
(IBA) format. 

Ctrlpoints 1> _____ ---, 

Config uration ... 

18 Cray Research Proprietary 
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Properties -> Configuration 

Bug Mode t> 

P Regs/Breakpoints t> 

Ctrlpoints t> 

P Reg isters t> 

HDM-xxxx-O 
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The Properties -> Configuration command, as shown at left, opens the MSI M 
Configuration window, which enables you to view and edit MSIM 
configuration parameters. 

~ MSIM Configuration(VMP-T32) 

Memory Size: @) 512 KWords S~D ~yp~: 1 Memory 1 File 1 

SSD Size: @) 256 KWords OIl': :' .. ~.;.~.r.L:~:.~.~E ........................................................... . 
Control Point Tuning CPU Synchronization Instruction Buffers 

I: ~~'ff' I ~)r;::1 I Sync 1 Async 1 Auto lion 1 Off Auto 

Cache I On 1 Off 1 Lats I On 1 Off 1 
Max CPUs: @) 32 

Co m p ute Factor 

11X 110X 1100X 11000X II Auto 1 

500. 1 ~1000 

I/O Factor 

11X 110X 1100X 11000X 1 Auto 1 

_1_ 1 0 ·1000 

00 04 10 14 20 24 30 34 

01 05 11 15 21 25 31 35 

02 06 12 16 22 26 32 36 

03 07 13 17 23 27 33 37 

LOSP Loopback 

LOSP Channels -> 1100-117 1120-137 1140-157 1160-177 1 60-67 1 

100 <= @) 101 104 <= @) 105 110 <= @) 111 114 <= @) 115 

102 <= @) 103 106 <= @) 107 112 <= @) 113 116 <= @) 117 

( APply) (Re® 

NOTE: The MSIM Configuration window opens automatically when you 
start MDB. You can either use the default configuration, or you 
can configure MSIM yourself. 
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Use the following procedure to manipulate the information in this 
window: 

1. Use the MENU mouse button to select the appropriate memory size 
from the Memory Size @) button. The following window appears 
showing your options: 

Memory Size: [jj) 512 KWords 

1128 KWords 1 

256 KWords 

512 KWords 

1 MWord 

2 MWords 

4 MWords 

8 MWords 

2. Click on the appropriate setting from the SSD Type: 1 Memory I File 1 

selection area to specify the type of simulated SSD created for 
running SSD diagnostic programs. 

Click on I Memory I to use the MWS-E memory. Click on File to use a 
file on the hard disk. Triple click on the Dir: field and type the name 
of the directory you want to use. 

3. Choose the appropriate SSD size from the SSD Size @) button. The 
following window appears showing your options. 

SSD Size: iii) 256 KWords 

32 KWords 

64 KWords 

128 KWords 

256 !<Words 

512 KWords 

1 Mword 

2 Mwords 

4 MWords 

8 Mwords 

4. Control point tuning. This control is not implemented yet. 
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5. Click on the appropriate setting from the CPU Synchronization area: 

~ Information to be provided. 

~ Information to be provided. 

~ Information to be provided. 

6. Click on the appropriate setting from the Instruction Buffers area: 

c::§:] enables instruction buffers in the simulator. 

~ disables instruction buffers in the simulator. 

~ Information to be provided. 

7. Click on the appropriate setting from the Cache area: 

c::§:] enables cache in the simulator. 

~ disables cache in the simulator. 

8. Click on the appropriate setting from the Lats area: 

c::§:] enables lats in the simulator for lat testing. 

~ disables lats in the simulator for lat testing. 

9. Specify the compute factor by either entering the value you want 
into the Compute Factor field or by dragging the slider to the value 
you want. Click on the ~ , ~ , ~, 11000X I or ~ 
compute factor by which you want to multiply the value in the 
Compute Factor field. 

The compute factor specifies the number of instructions the 
simulator performs before MME and MDB are updated. The higher 
the compute factor, the higher the pass counts. The lower the 
compute factor, the more often MME and MDB are updated with 
data. 

10. Specify the 110 factor either by entering the value you want into the 
I/O Factor field or by dragging the slider to the value you want. Click 
on the ~, ~ , ~ , I 1000X I or I Auto I 110 factor by which 
you want to multiply the value in the I/O Factor field. 

The I/O factor determines the speed at which the simulator updates 
channel activity. The higher the specified number, the faster channel 
activity is updated. 
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11. Click on a LOSP Loopback selection to specify the low-speed channel 
number you want to configure:) --

1100-1171 selects LOSP channels 100 through 117. 

1120-137 1 selects LOSP channels 120 through 137. 

1"'10-157 1 selects LOSP channels 140 through 157. 

1160- 177 1 selects LOSP channels 160 through 177. 

1 60-671 selects LOSP channels 60 through 67. 

12. Specify the channel connectors by choosing the connector number 
from the @) next to each channel indicator: 

104 <= IR 
106 <= 101 107 115 1 

103 111 1171 

105 
'--

113 

13. . Choose the maximum number of CPUs from the Max CPUs @) 
button: 

Max CPUs: 

2 

4 

8 

16 

If you click on an individual CPU under Max CPUs:, you configure 
theCPU. If you deselect a CPU under Max CPUs:, you remove the 
CPU from the configuration. You can click on (Reset v) in the MDB 
base window to check the installed CPUs for the configuration you 
just created. 

14. To apply your changes to the MSIM configuration, click on the 
(Apply) button. 
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J?~ '; ':To cancel your changes and return the window to its original 
. .. settings, click on the (Reset) button. 

Utilities -> Bugmaker -> Shared 

HDM-xxxx-o 
December 20, 1994 

The Utilities -> Bugmaker -> Shared command, as shown at left, enables 
you to create shared register bugs .. User bug mode must be operating 
(refer to "Properties -> Bug Mode -> User" earlier in this document). 
When you select this command, the MSIM Bugmaker (Shared Registers) 

window appears. 

MSIM Bugmaker (Shared Registers) 

Bug Dir: usr/msim/mdbuser 
Bug File: .:.:::Ie::::.ar.::.:bu::ag.~ ___ _ 

Cluster Number: ~ 
Register Number: ~ 

Note: In the MSIM cfg window 
select Sync and Apply before 
selecting WS and DL bugs 

I Shared B I Shared T I Semaphore I Semaphore/BS I All I 
I SBlinc I Read I Write I I TiS I ':!':~.r I S(lt I I Ok·act I <j':;: I 

I Source I Result I BI2l 
WS - Wait on Semaphore 
DL - Dead Lock 

Intermittent Percentage: 
_0_00 100 

I Pick I Drop I Select cpu/cpus to bug: 

Max CPUs: @) 1 
User Defined Bugged Bits Format: r---.---r-....--.-....,.-...--.---. 
I Byte I Parce I I Halfword I Word I 
User Defined Bugged Bits: 
000 000 000 000 000 000 000 165 

~ (Apply&Save) (Delete) (Reset) 

Follow this procedure to manipulate the information in this window to 
create a shared register bug: (complete procedure to be provided) 

1. To apply your changes to the bugmaker window, click on the 
~ button. 

2. The ( Apply & Save) button adds a bug file to the MOB Load Bug 

window. 

3. The (Delete) removes a bug file from the MOB Load Bug window. 

4. To cancel your changes and return the window to its original 
settings, click on the (Reset) button. 
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24 

The Utilities -> Bugmaker -> Memory coihmand;-as'shown at left, enables 
you to create memory bugs. User bug mode must be operating (refer to 
"Properties -> Bug Mode -> User" earlier in this document. When you 
select this command, the MSIM Bugmaker (Memory) window appears. 

MSIM Bugmaker (Memory) 
. , 

Bug Dir: usr/msim/mdbuser, 
Bug File: bugcache2 

Starting Address: 
DmaBug ~00=2~60~0~0 ____ _ 

I Load I Store I I On I Off I Block length: 001 

I Register I Address Iinst Fetch I Exchange 11/0 I Cache I I hit I miss I 

I A Reg I B Reg I S Reg I T Reg I V even I V odd I Cache Mem I All Ports I None I 

Register Number: ~ 

I Pick I Drop I 
lat Bug 

Ion I off I 
Intermittent Percentage: 
_0_00 100 

Slllect cpu/cpus to bug: 
Bugged Address Bits: Force Mbe >" : Max CPUs: ~ 4 

0000000 Ion I Off I ,.............-..:..."..---...--....---.---.-y--.... 
User.Defined Bugged Bits Format 

I Byte I Parce I I Halfword I Word I 

User Defined Bugged Bits: 
000 000 170 000 000 000 000 000 

~ (APply Be Save ) (Delete) ( Reset) 

Follow this procedure to manipulate the information in this window to 
create a memory bug: (complete procedure to be provided) 

1. To apply your changes to the bugmaker window, click on the 
~ button. 

2. The (Apply & Save) button adds a bug file to the MOB Load Bug 
window. 

3. The (Delete) removes a bug file from the MOB Load Bug window. 

4. To cancel your changes and return the window to its original 
settings, click on the ( Reset) button. 
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Reset -> Client 

Bugmode 

GRAY T90 Series MOB Interface Reference 

. r"' The Beset,>,Glient command, as shown at left, resets the client portion of 
the-rMDB appli~ation. 

.:;' 

.:.,-

Reset -> Server 

Client 

OMi. 

Bugmode 

The Reset ~> Server command, as shown at Ieft,"resets the server portion of 
the MDB application. 

Reset -> Bugmode ... 
Client 

Server 

·"Ii'M" 

HDM-xxxx-O 
December 20, 1994 

The Reset -> Bugmode command, as shown at left, resets bug mode if you 
fmd an error from. which your session cannot re~over. Any CPUs and 
breakpoints you selected or bugs you l<?ade~~are not lost. 
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See Page 10 

See Page 11 

Clear Breakpoi nt [> __ --

Select CPUs [> 

Deselect CPUs [> 

Remove Bug 

HDM-xxx-O 
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See Page 15 
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MSIM Sim~latQt&uggerIDebugger(MDB 0.0.0) - SIM [stanleYJ'.,'41 Jl·· ,;,:,,::: 
• ! -

e File'il) e View v) (~·c!it.~) e Properties 'il) e Utilities 'il) 

See Page 12 

r--'- .------
. . • l.\i ~ . :;~ ~ 

Delete'Bre~~polnt" 'i '--'-; 

selectel·8re~~pofllt=.~·: "!'.\!!'SSee Pa~e 13 

Breakpoints CPUs 

I All I Selected J I All I selected I' 
e Enable } ,. e Run ) 

C::::=D:::=:i:==sa7b::=le==::)," e Step ) 
. 1 r:t:;l 

_~o_u~_:-'<.:_nt_B_U_9_: __ ; C~:~p~a=us=e:':.~= .. =." =-.. ----.. ) q' 

Auto Bugmode 

t·· 

. t 

See Page 25 

See Page 25 

See Page 25 

Shared .. . 

Memory .. . 

A u,to·.... 'Se?'"Page1tr (not currently available) 
~ ~""i ~t1j.;;! f)t!,~"'; ._~ 5~_ 

U~r:. ' -See Page-115 
" . ',e. 

~ 

See Page 23 

See Page 24 

_All ..... _ . 
, 
1 

See Page 14 
l:." ~b'-' ;:.~"..;; __ • .,...., ______ --'-_--. 

; 

o-[FQ Select C'PUs , .-. 
i 1 J"-; . ... .. '~. -

Se lect~~~akpoLnt:'£:f.;;:.It.:;';j:)t~e Page y ._ .. _ .'1.- Bug Mode ... [> . 

1..,,<' P "Reg istE!rs 1!~ 

.:-B-r-eakp-oi flt List .. 

-r,,- i 9g8 re d B re·a-k p otn ts 

.;0 

A II Avai lab Ie C ~ee Pagaj,4-.-.-. ~ P Regs/Breakpoi nts [> -1111-----.--... : ..... " .....;I' • "'r'i--'""",~' ---, 
~k-~ 

·V 

Exce pt..Breakpoi nt's 
_ .. ! 1 

AYI CPUs-' 

I ~ 
I 
...... .. . --~ .. ~ · ... 0·- ,--.. ~'i" ': Ctrl poi nts 

-f 
, P Reg isters 

!il 
............. -.. '---~-

[> -I1---------1~1 

[> -: ..... -----, 

See Pag~ 15 

''SeEfPage 15 
,- -'~ Configuration ... 

;....~~-----~ 

Figure 2. Quick Menu Guide 
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See Page 18 

27 



) 

Reader Comment Form 

Title: CRAY T90 Series Number: HDM-xxx-O 
MDB Interface Reference 

Your feedback on this publication will help us provide better documentation in the future. 
Please take a moment to answer the few questions below. 

For what purpose did you primarily use this document? 

___ Troubleshooting 
___ Tutorial or introduction 
__ -<Reference information 
___ Classroom use 
___ Other - please explain _____________________ ~ 

~. 1 

.~ . >. 

Using a scale from 1 (poor) to 10 (excellent), please rate this document on the following 
criteria and explain your ratings: . 
___ ",Accuracy ______________ ---________ ~ 

____ ... ·Otganization _________________________ _ 

--...;._-<Re~dability ---' _____ -'--':' . ..;.. !'..;.' ---'_---' _______ ~ _______ ~ 
,.' 

__ ~Physical qualities (binding, printing~' pagelasout)· _' _~ ______ ~ __ 

Amount of diagrams and photosc-s ./!- ...:;,SO".N<' 
--~ . ' ~"'!"~-~)""'" +; .. ;'--~----'----------

___ Quality of diagrams and photos.'''''',·,..;,;:.-.:.·l:.;.,. ...•. ...."''',;",,~,;., ... ~''''':::; .... :::: . .;..;:::..,,.'""",' ... ;.;;,.;'...,.;' .... ; -'--______ ~ __ _ 

Completeness (Check one) 
. .~ ~ ... 

___ Too much information _____ ---'~-'-------,.----___ -_--

___ Too little information ______________________ _ 

___ ,Just the right amount of information 

Your comments help Hardware Publications and Training improve the quality and usefulness 
of your publications. Please use the space provided below to share your comments with us. 
When possible, please give specific page and paragraph references. We will respond to your 
comments in writing within 8 hours. 

NAME _________________ _ 

JOB TITLE, _______________ ~ 
FIRM ___________________ __ 

c· =II1II, 0 ~ AD DR ESS, ______________ __ 
~ESEA~CH, INC, 

CITY _______ STATE ___ ---'ZIP ___ _ 
DATE. ___________________ __ 

[or attach your business card] 






