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Description of this Document 

This document is a reference to the user interface for the Logic Monitor 
Environment (LME) application used to control the logic monitors on 
CRAYT90 series CP, SR, and 10 modules. This document describes the 
components of the LME base window and all menu button commands. 
Figure 3 shows all available menu button commands and lists the pages on 
which the commands are described. 

This document is one component of the LME documentation set, which 
includes the following documents: 

CRAY T90 Series LME User Guide, publication number HDM-xxx-O. 

This document provides a general procedure of how to use LME. 

CRAY T90 Series LME Interface Reference, publication number HDM-xxx-O . 

. This document describes the LME user interface. It describes the 
LME base window and all available menu button commands. 

Notational Conventions 

HDM-xxx-O 
December 9,1994 

This document uses the following notational conventions: 

• Buttons are shown the way they appear in a window; for example, 
( Halt). 

• Settings are shown the way they appear in a window; for example, 
1256 x 32 I. 

• The -> symbol indicates holding the MENU mouse button down and 
moving the mouse pointer to the next menu item. 

• Courier type indicates a command you can enter. 

• Courier bold type indicates commands you should enter. 

• Helvetica type indicates references to the LME interface windows. 

• Helvetica bold type indicates menu entries you should choose from 
the LME interface; for example, the text "choose View -> Parameter 
Set" indicates you should choose the Parameter Set entry from the 
( View <l) menu button. 

Cray Research Proprietary 
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Interface Components 

eterSet Param 
and D 
Buffer 

ata 
Area 

ge Messa 
Area 

Figure 1 shows the LME interface, located in the base window. The 
paragraphs following the figure describe the components of the interface. 

B W" d Titl ase In ow I 
el 

'" " N b erslon um 
erl r S" I t Imu a oror FEI Ch el ann 

r Workstation or 

® Logic Monitor Environment (LME-T90 1.0.2) - SIM [techsun1] (76) 

~(Viewv)~ (Utilities v) Cf.l(.;~";;i;) .,;) (Reset v) ~ 
CPU Modules 

t ~ ~ ~ ~ 
I/O Modules Shared Modules 

~ ~ 
Parameter Sets: (lD/Buffer/Type/Description) CDntml: 
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System Type: T4 I-

Figure 1. LME Interface Components 

Channel Number 

Copy Number 

Menu Bar 

Module Area 

Controls 

Configuration 
Information 

Base Window Title 

Version Number 

The base window title displays the name of the program: Logic Monitor 
Environment. 

The version number indicates the version of LME you are using. 

Simulator or FEI Channel 

4 

The simulator or front-end interface (PEl) channel indicator shows LME 
is running with the simulator (indicated by 81M) or an PEl channel 
(indicated by FEI GHN 0 for channel 0, FEI GHN 1 for channel 1, or FEI 
GHN 2 for channel 2). 
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Workstation Name or Channel Number 

Copy Number 

Menu Bar 

Module Area 

Controls 

HDM-xxx-O 
December 9, 1994 

The workstation or channel number indicator lists the name of the 
workstation or the channel number on which LME is running. 

The copy number indicates the copy of LME you are using. To set the 
copy number, start LME with the - copy option. If you start LME with 
the default copy number of 0, the LME base window does not display a 
copy number. For more information about starting LME with the - copy 

option, refer to the CRAY T90 Series LME User Guide, publication 
number HDM-xxx-O. 

The menu bar contains six menu buttons: ~,( View v), ~, ( Utilities v), 

(Module v), and (Reset v). Use the commands in these menu buttons to 
perform LME functions. Refer to "Menu Buttons Commands" later in this 
document for more information about the menu button commands. 

NOTE: The (Module v) button is only active after you select a module by 
clicking on an assigned parameter set in the module area. 

The module area is where you assign the parameter sets to modules. To 
assign the current parameter set and data buffer to a module, click on the 
module. The parameter set and data buffer appear next to the module. 

The following controls are available for controlling a monitoring session: 

Control Description 

Specifies that the control buttons will affect all 
modules. 

Specifies that the control buttons will affect only the 
selected modules. 

Cray Research Proprietary 
Preliminary Information 
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Control 

( update) 

( Go v) 

Halt) 

Description 

Updates the parameter set changes without starting a 
monitoring session. Use this button to update the 
snapshot display utility parameters and to set external 
scope points. 

Starts a new monitoring session. Two options are 
available: 

The Go -> One-shot option starts the monitoring 
process and reads and displays the logic monitor data 
only when a trigger occurs. LME displays the 
one-shot icon (Jill) next to all active modules. 

The Go -> Continuous option starts the monitoring 
process and reads and displays the logic monitor data 
every half second (provides a continuous display of 
logic monitor data). LME displays the continuous 
icon (~) next to all active modules. 

Stops the current monitoring session. 

Configuration Information 

6 

The configuration information indicates the type of hardware available to 
LME. The System Configuration Environment (SCE) provides this 
information. 

LME displays the following configuration information: 

Information 

System Type: T1 
System Type: T 4 
System Type: T16 

System Type: T32 

Description 

Tester (1 CPU) 
CRAY T94 mainframe 
CRAY T916 mainframe 
CRAY T932 mainframe 

Cray Research Proprietary 
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The message area displays ***WARNING: MME Environment 0 Running!*** 

when MME environment 0 is running. This message appears because 
MME environment 0 can perform logic monitor, loop controller, and 
master clear maintenance channel functions that disrupt LME. 

Do not run MME environment 0 in automatic or manual modes when you 
are using LME. Do not issue any logic monitor, loop controller, and 
master clear maintenance channel functions from MME environment 0 
compose mode when you are using LME. 

Parameter Set and Data Buffer Selection Area 

The parameter set and data buffer area is where you select the parameter 
set and data buffer you want to assign to a module. There are four data 
buffers CA, S, C, and D) available for each parameter set. Choose 
C Create Param Set) to create a new parameter set in the Parameter Sets scroll 
box. Click on (Delete Param set) to delete the current parameter set selected in 
the Parameter Sets scroll box. 

Menu Button Commands 

HDM-xxx-O 
December 9, 1994 

This subsection describes each LME menu button command. Figure 3 on 
page 33 shows all available menu button commands and lists the pages in 
this document where the commands are described. 

Cray Research Proprietary 
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File -> Load -> Parameter Set 

·.""ml*fi 
Save Syste m Snaps hot .. 

Delete H(·.jIJie Data ... 

Layout ... 
Print 'c!-I--_ ..... 
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The File -> Load -> Parameter Set command, as shown at the left, enables 
you to load a parameter set you previously saved with the File -> Save -> 
Parameter Set command. This enables you to reuse parameter sets. This 
command displays the LME: Load Parameter Set window: 

19 lM E: load Parameter Set 

Dir: ® usr/lme/psetJ. 
Files: 

all 
ca. pri me. port 
cLtest 
cj.sanity 
cj.ssh 
cp.hang 
dml 
first 
loplnt 
iosnap 
mem.sain 

'---_______ --'r:I:J 

'M.MM •••• _.M ........ M •• ' 

<kilt! ) 

20 files found 

Perform the following procedure to manipulate this window: 

1. Change the directory, if necessary, by choosing a directory from the 
Dir @) or by entering the directory in the Dir field. The following 
directories are available in the Dir @) : 

Directory Description 

Release 

User 

Alpha 

Files from the current diagnostic release 

Files you have saved or modified 

Prereleased files that are being tested and have 
not been released 

2. In the Files scroll box, click on the file you want to load. 

3. Click on ( Load ). LME loads the specified parameter set. 

Gray Research Proprietary 
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File -> Load -> System Snapshot 

Layout .. 
Print ".., ..... __ --rI 
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The File -> Load -> System Snapshot command, as shown at the left, 
enables you to load a system snapshot you previously saved with the File 

-> Save -> System Snapshot command. This enables you to reload all 
parameter set data, parameter set assignment data, module logic monitor 
data, and CPU instruction buffer data you were using when you saved the 
system snapshot. LME displays the LME: Load System Snapshot window: 

1. 

19 lME: load System Snapshot 

Diy: @) usr!lme!snap!. 
Files: 

eires 
darrin 
hgsnap 
mpet 
ssh 

~------------~= 

5 files found 

Change the directory, if necessary, by choosing a directory from the 
Dir @) or by entering the directory in the Dir field. The following 
directories are available in the Dir @) : 

Directory 

Release 

User 

Alpha 

Description 

Files from the current diagnostic release 

Files you have saved or modified 

Prereleased ftles that are being tested and have 
not been released 

2. In the Files scroll box, click on the file you want to load. 

3. Click on ( load ). LME loads the specified parameter set. 

Cray Research Proprietary 
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File -> Load -> Module Data 

This command is not implemented yet. 

NOTE: The File -> Load -> System Snapshot command also loads module 
data. 

File -> Load -> Layout 

~~ 
Parameter Set. .. 

Save System Snapshot .. 

Delet r~(·'ill!" Data. .. 

I tI'~"~1 !!!!!!.J 
Print ~ 

10 

The File -> Load -> Layout command, as shown at the left, enables you to 
load a layout previously saved with the File -> Save -> Layout command. 
This causes LME to display the same windows in the same locations with 
the same data types you were using when you used the File -> Save -> 
Layout command. This command displays the Load/Save Layout window: 

!9 load/Save layout 

load 0 ir: usr /Iayout/. 
l.oad !:ihlS: 

[--l~ 
I 

1 ____________ JCl 
---.-. 

L(·a(l ) 

Save Dir: _____ _ 
Save File: _____ _ 

save) 

Perform the following procedure to manipulate this window: 

1. Change the directory, if necessary, by changing the directory in the 
Load Dir: field. The Load Dir field defaults to the usr/lme/layout 
directory, which is where layouts are normally saved. 

2. In the Files scroll box, click on the file you want to load. 

3. Click on ( Load ). LME loads the specified parameter set. 

Cray Research Proprietary 
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File -> Save -> Parameter Set 

4'''''Ii'M. 
Delete. System Snapshot .. 

Print Layout. .. 
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The File -> Save -> Parameter Set command, as shown at the left, enables 
you to save the current parameter set. Then, you can reload the parameter 
set later with the File -> Load -> Parameter Set command to reuse the 
parameter set. This command displays the LME: Save Parameter Set 

window: 

!:9 LME: Save Parameter Set 

Dir: ~ usr/lme/pset/. 
Files: 

all 
ca. pri me. port 
eLtest 
ej.sanity 
cj.ssh 
ep.hang 
dml 
first 
iopint 
iosnap 

~--------------~= 

Name: ____________ _ 

( save) 

20 files found 

Perform the following procedure to manipulate this window: 

1. Change the directory in which LME saves the file, if necessary, by 
choosing a directory from the Dir @) or by entering the directory in 
the Dir field. The following directories are available in the Dir @) : 

Directory Description 

Release Files from the current diagnostic release 

User Files you have saved or modified 

Alpha Prereleased files that are being tested and have 
not been released 

2. In the Name field, enter the filename under which you want to save 
the parameter set. 

3. Click on ( Save ); LME saves the parameter set in the specified file. 

Cray Research Proprietary 
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File -> Save -> System Snapshot 

Delet "WOO'i"M­
H<+;!a D:ml .. 

Prl nt layout .. 

12 

The File -> Save -> System Snapshot command, as shown at the left, 
enables you to save a snapshot of all the current LME data, including all 
parameter set data, parameter set assignment data, module logic monitor 
data, and CPU instruction buffer data. Then, you can use the File -> Load 

-> System Snapshot command to reload the data later and return LME to 
the state it was at when you saved the system snapshot. This command 
displays the LME: Save System Snapshot window: 

~ lME: Save system Snapshot 

Dir: @) usr/lme/snap/* 

Files: 

cires 
hgsnap 
mpct 
ssh 

~------------~= 
Name: ...... __________ __ 

( Save) 

4 files found 

Perform the following procedure to manipulate this window: 

1. Change the directory in which LME saves the file, if necessary, by 
choosing a directory from the Dir @) or by entering the directory in 
the Dir field. The following directories are available in the Dir @) : 

Directory Description 

Release 

User 

Alpha 

Files from the current diagnostic release 

Files you have saved or modified 

Prereleased files that are being tested and have 
not been released 

2. In the Name field, enter the filename under which you want to save 
the system snapshot. 

3. Click on ( Save ); LME saves the system snapshot in the specified 
file. 

Cray Research Proprietary 
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File -> Save -> Module Data 

This command is not implemented yet. 

NOTE: The File -> Save -> System Snapshot command also saves 
module data. 

File -> Save -> Layout 

Parameter Set ... 
System Snapshot ... 

r·h::·,;!!.:la Data ... 
Print ..... 

HDM-xxx-O 
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The File -> Save -> Layout command, as shown at the left, enables you to 
save the current window layout. Then, you can use the File -> Load -> 
Layout command to reload the layout so LME displays the same windows 
in the same locations with the same data types that were displayed when 
you saved the layout. This command display the Load/Save Layout 
window: 

!9 load/Save layout 

load D ir: usr /Iayout/. 
load File~: 1------
I 

I 
I L _____ ._HO ____ JCJ 

.-._-_ .• -._ .... 
L(·a!l ) 

Save Dir: _____ _ 
Save File: _____ _ 

save) 

Perform the following procedure to manipulate this window: 

1. In the Save Dir field, enter the directory in which you want to save 
the layout. Usually, you should enter usrjlmejlayout in this 
field. 

2. In the Save File field, enter the filename under which you want to 
save the layout. 

3. Click on ( Save ); LME saves the layout in the specified file. 

Cray Research Proprietary 
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File -> Delete 

--Load I> 

Save I> ... 
Print I> 

14 

The File -> Delete command, as shown at the left, enables you to delete 
files you no longer need. This command displays the LME: Delete File 
window: 

!9 LME: Delete File 

Dir: ~ usr/lme/~ 
Flies: 

data/ 
layout! 
pset/ 
snap/ 

~------------~= 

4 fi les fou nd 

Perform the following procedure to manipulate this window: 

1. Change the directory, if necessary, by: 

• Entering the directory in the Dir field and pressing the Return 
key,or 

• Choosing the directory from the Dir: (ill. The following user 
directories are available: 

Directory 

Ime/usr/pset/* 

Ime/usr/tst/* 
Ime/usr/data/* 

Description 

User parameter sets 
User test lists 
User data files 

2. Click on the file you want to delete. 

3. Click on ( Delete). LME deletes the file. 

Cray Research Proprietary 
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File -> Print -> Screen 

Save I> 

Delete ... 
es ... 1.-.___ Root 

Setup ... 

The File -> Print -> Screen command, as shown at the left, prints an image 
of a window or an icon. 

When you choose this command, the cursor becomes a plus symbol. 
Move the cursor to the window or icon to print, and click any mouse 
button. 

NOTE: This command does not print an image of the LME base 
window. To print an image of the LME base window, use the 
File -> Print -> Root command. 

File -> Pri nt -> Root 

Load I> 

Save I> 

Delete ... 

es 

es 

Screen 

Param-

POOO Setup ... 

The File -> Print -> Root command, as shown at the left, prints an image of 
the entire screen (root window). 

File -> Print -> Setup 

Load I> 

Save I> 

Delete ... 

Param 

es 

es 

Screen 

Root 

POOO_ 

HDM-xxx-O 
December 9, 1994 

The File -> Print -> Setup command, as shown at the left, enables you to 
edit the commands that control how LME prints data for the File -> Print -> 
Root and File -> Print -> Screen commands and how LME prints text. This 
command displays the LME: Print Setup window: 

LME: Print setup 

Print Root Command: (xwd -root I xpr -device Ijet -rv I Ip)<\ 

Print Screen Command: (xwd -frame I xpr -device Ijet -rv IIp)& 

( 

Print Text Command: .:.J:lp _____________ _ 

Save Commands To File ) 

Cray Research Proprietary 
Preliminary Information 
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Modify the commands in the Print Root Command, Print Screen Command, 

and Print Text Command fields to change how LME prints. For more ~\ 

information about the UNIX xwd, xpr, and Ip commands used in the ) 
print processes, refer to the UNIX online manual (man) pages (enter man 
xwd, man xpr, or man Ip at a UNIX command prompt). 

NOTE: LME and MME share these print commands. If you change 
commands in LME, they also change for MME. 

Use the buttons in the LME: Print Setup window to: 

• Save the current printer setup commands for later use 
( Save Commands To File ) ). 

• Load the printer setup commands you saved previously 
( Reset Commands From File ). 

• Load the default printer setup commands that the LME program 
provides ( Reset Commands From Defaults) ). 

Cray Research Proprietary 
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View -> Parameter Set 

P.3t 3 rneter Set. 

Expecte d Data ... 

Module LM Data .. . 

Test Poi nt Data .. . 

Re lease Notes ... 
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The View -> Parameter Set command, as shown at the left, displays the 
current parameter set data. Use this command to view and edit a 
parameter set. This command displays the LME: Edit Parameters window: 

LME: Edit Parameters (POOO ) 

Module Type: ( Clear parameters) 
I CPU I Shared I/O I (Raw Params) I 
Identifier: ~ Description: __________ _ 

Refer to the "Create the Parameter Sets" discussion in the CRAY T90 
Series LME User Guide, publication number HDM-xxx-O, for more 
information about how to use this window to edit a parameter set. 

NOTE: You can also view a parameter set by double-clicking on the 
parameter set in the Parameter Sets scroll box in the LME base 
window. 

Cray Research Proprietary 
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View -> Expected Data 

Parameter Set .. , 
E,<pe :ted 080 

Module lM Data .. 

Test Point Data .. , 

Release Notes .. , 

"\ 
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The View -> Expected Data command, as shown at the left, displays the 
expected data for the current parameter set. LME uses the expected data 
to make comparisons with the actual data returned from a monitoring 
session. Use this command to view and edit the expected data and the 
compare mask that LME uses to compare the expected and actual data. 
This command displays the LME: Exp, Data window: 

ft. ' 

~ lME: Exp. Data 
~;;::;;:!a;~;.~. ,&'\, (). ',} 

'-'-A';dd;::r =-H=MO=-=-==HM~f~'': ,~~\ ,'" 
000 11100 ,000 ooo;,OO{ 'Ii. 
001 000~~02. 000 ''(lO~i . 
OQ~ ';'POO ;JfQ;4\QOQ,{),05 .. 
003· ;(Ina 006 000 007 .. '.' " 

,!!. • ))1;14"':. OpO -010 000 011~' 9.. 
';: ,'005', 000 012 000 01J~ ,''1 .. ,1. 

, : OO~ ~OOO 014 000 015', . ... ". 
" ~~\, . :. 007 000.;'016 ODQ 01l' 

!. -i,. ","'" 010 "000' 020 000~921 
~. ,. ,Ul1' .... OOO~': 02~ 000 023 

,,;; J; 012:1l0p; 024 000 025 
'.1)13 ,1000 026 000 027 

( .~. 

:,'c.<\ 

l,' 014>" 000 030 000 031 
015 000 032 000 033 
016 000 034 000 035 
017 000 036 000 037 

:~ .,F'4 

,.'L~'i~rihats the LME: Exp. Data window to correspond with the 
" ,'. 'Ii, 

· ... pa'i'ameter set's recording mode. 

To change the compare mask, enter a new value in the Compare Mask field 
and press Return. 

To change expected data, click the SELECT mouse button on the data you 
want to change. Then, enter any combination of octal digits and press 
return. 

Cray Research Proprietary 
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View -> Module LM Data 

Parameter Set .. 

Expected Data ... 

Test Point Data ... 

Release Notes ... 
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The View -> Module LM Data command, as shown at the left, enables you to 
view the LM data returned from a monitoring session in a separate 
window. This command displays the LME: View Module Data window: 

!:9 LME: View Module Data 

Module: @) CPU 00 

Buffer: I Current I A I B I C I D I 

ok: ... _ ... _H._M_M .. ·_ .. "_·.·.·~·· ... ____ ··_··_·. 
rill.': 

Size: I S I MIL I XL I 
Font: I S I MIL I XL I 

( View ... ) 

Perform the following procedure to manipulate this window: 

1. From the Module: @), choose the module for which you want to view 
theLM data. 

2. Click on Buffer: 1 Current I,~, 0,~, or ~ to select which buffer of 
LM data you want to view. 

3. Click on Size: D, 0, QJ, or ~ to specify the size of the 
window to display. 

4. Click on Font: D, 0, QJ, or ~ to specify the font size of the 
data LME displays. 

5. Click on ( View ... ); LME displays the LM data for the selected 
module in a separate window: 

!:9 LME: CPU 00 Data 

Buffer: 

I Current I A I B I c I D I 
Addr --IMO- -1M1--
000 000 000 000 000 
001 001 001 001 001 
002 002 002 002 002 
003 003 003 003 003 
004 004 004 004 004 
005 005 005 005 005 
006 006 006 006 006 
007 007 007 007 007 

Cray Research Proprietary 
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View -> Test Point Data 

Parameter Set .. . 

Expected Data .. . 

Mod u Ie lM Data ... 

Release Notes ... 

20 

The View -> Test Point Data command, as shown at the left, displays the 
test-point data returned from a monitoring session. This command 
displays the LME: Test Point Data window: 

~ LME: Test Point Data 

Module: ® CPU 00 '0' character 9....--
( Clear cursors) 

Buffer: ® A '1' character _, _ 

Output select:: ,_ 

~ 
~ 

cp==> 0000 0010 0020 0030 0040 0050 0060 0070 
[UI~ UUM D]~a~S6Z D]2a~S6Z D]~a~S6Z D]~a~56Z D]~a~56Z D]~~56Z D]~a~S6Z D]~a~56Z 
AR 00 200 00110011 00110011 00110011 00110011 00110011 00110011 00110011 00110011 
CK 00 322 01010101 01010101 01010101 01010101 01010101 01010101 01010101 01010101 
IC 00 343 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 

This window displays the recorded values for the chips on which you 
recorded test points. Select the module and data buffer you want to view 
from the corresponding menus. You can select which chips you want to 
view by clicking on the chips in the Output Select box. Click on ~ to 
select all the chips on which you recorded test points. Click on ~ to 
deselect all the chips. 

To increase readability, you may want to change the characters used to 
indicate the 0 and 1 states of the test points. Enter the new characters in 
the appropriate fields. You can also highlight the rows and columns of 
data to increase readability of the table, as shown in Figure 2. Click the 
SELECT mouse button to highlight a row of data. Click the EXTEND 
mouse button to highlight a column of data. Click on ( Clear cursors) to clear . 
these cursors. Press the MENU button to access a menu that enables you 
to change the type font size. 

NOTE: If a dash appears in the last data position, this indicates that the 
hardware delayed 1 clock period before recording the test-point 
data for the chip. The test-point data is shifted one position to 
correspond with the data from the other test points. 

If you click in the data area, you can navigate the test-point dump data by 
using the keyboard. Use the left arrow key to move the data to the left. 
Use the right arrow key to move the data to the right. Use the Home key 
to move to the beginning of the data. Use the End key to move to the end 
of the data. 
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Module: @) CPU 00 

Buffer: @) A 

Output select: 

~ 
~ 
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LME: Test Point Data 

'0' character _0_ 
'1' character _, _ ( Clear cursors) 

Ie 00 343 00000000 00000000 00000000 00000000 00000000 000 0000 00000000 00000000 

Figure 2. Highlighted Rows and Columns in the Test-Point Data 

View -> Release Notes 

Parameter Set .. 

Ex peete d Data ... 

Module LM Data .. . 

Test Point Data .. . 

4"'iP""; 

The View -> Release Notes command, as shown at the left, displays the 
LME release notes in a separate window. Use this window to read about 
any changes to LME for the current offline diagnostic release. This 
command displays the Release Notes window: 

Release Notes 

Edit -> Create Parameter Set 

1=-1 e 3te P 31 3 nll~tet Set 

Delete Parameter Set 

Ass i9 n Mod u lees) I> 

Deassign Module(s) I> 

Copy Parameter Set 

HDM-xxx-O 
December 9,1994 

The Edit -> Create Parameter Set command, as shown at the left, creates a 
new parameter set in the Parameter Sets scroll box. 
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Edit -> Delete Parameter Set 

Create Parameter Set 
Delete P3t 3tneter Set 

Assign Module(s) I> 

Deassign Module(s) I> 

Copy Parameter Set 

The Edit -> Delete Parameter Set command, as shown at the left, deletes the 
selected parameter set. 

Edit -> Assign Module(s) -> All 

The Edit -> Assign Module(s) -> All command, as shown at the left, assigns 
the selected parameter set to all modules. 

Edit -> Assign Module(s) -> Available 

The Edit -> Assign Module(s) -> Available command, as shown at the left, 
assigns the selected parameter set to any modules that are not already 
assigned parameter sets. 

Edit -> Deassign Module(s) -> All 

Delete Parameter Set 

Assign Module(s)" SI 

COpy Parameter se'r-P"""I~ 

The Edit -> Deassign Module(s) -> All command, as shown at the left, 
deassigns the parameter sets from all modules. 

Edit -> Deassign Module(s) -> Selected 

Create Parameter Set 
Delete Parameter Set 

~ 
SI 

Copy Parameter set-P"""I~ 
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The Edit -> Deassign Module(s) -> Selected command, as shown at the left, 
deassigns the parameter sets assigned to the modules you have selected. 
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Edit -> Copy Parameter Set 

Create Parameter Set 

Delete Parameter Set 

Assign Module(s) I> 

Deassign Module(s) I> 

The Edit -> Copy Parameter Set command, as shown at the left, makes a 
copy of the selected parameter set and places the copy in the Parameter 

Sets scroll box. 

Edit -> Copy LM Data 

HDM-xxx-O 
December 9, 1994 

This command is not implemented yet. 
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Utilities -> Snapshot Display 

dit v 

Breakpoint control ... 

Instruction Buffer Dump ... 

Data Com pare ... 

Configuration ... 
Command Buffer ... 

24 

The Utilities -> Snapshot Display command, as shown at the left, displays 
the snapshot display utility. The snapshot display utility enables you to 
quickly see the values of the test points, the instruction parcel, and the P 
register. You can take one snapshot to see the current values, or you can 
take a continuous snapshot to watch the values change. This command 
displays the LME: Snapshot Display window: 

!9 LME: Snapshot Displav 

AR 00 (200) 0 IC 00 (343) 0 
CK 00 (322) 0 

I nstr. Pares I 000000 

P Register OOOOOOOOOOa 

View: I Testpoints I ~ 
Module: ~ CPU 00 

(start Snap) (Single snap) 

From the Module: @), choose the module for which you want a snapshot. 
For a CPU, you can specify that you want to view the test points, the P 
register, and the instruction parcel. For shared and 10 modules, the 
window displays the test points. The snapshot display utility uses the 
parameter set assigned to the selected module to specify which test points 
should be captured and displayed. 

Click on (start Snap) to start a continuous snapshot; the button changes to 
(Stop snap) , which you can click on to stop a continuous snapshot. Click on 
( Single snap) to take one snapshot of the current values. 

NOTE: If you want to change the parameters used by the snapshot 
display utility, change the parameter set for the module and click 
on ( Update) • 
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Utilities -> Breakpoint Control 

dit v 

Snapshot Display ... 

Instruction Buffer Dump ... 

Data Com pare ... 

Configuration ... 
Command Buffer ... 

HDM-xxx-O 
December 9, 1994 

The Utilities -> Breakpoint Control command, as shown at the left, displays 
the breakpoint control utility. The breakpoint control utility enables you 
to stop CPU execution when a specific current instruction parcel value, P 
register value, or trigger occurs. This utility displays the instruction parcel 
and P register values when the breakpoint occurs. This command 
displays the LME: Breakpoint Control window: 

!Q lME: Breakpoint Control 

CPU: ~ 00 

Break On: 

I nstr. Paree I 

P Register 

Trigger 

( Set Breakpoi nt) ( Clear Breakpoi nt) ~ 

Current Breakpoint: IP=OOOOOO 
(Monitor Disabled) 

STATUS: 
??? 

Instr. Parcel: 000000 
P Register: OOOOOOOOOOa 

(Continue) (Single-Step) (Clear & Continue) 

NOTE: The breakpoint monitor function, Monitor settings, and ® icon 
were included in the Systems Test and Checkout (STCO) 
version of LME to handle breakpoint functionality problems for 
early CP modules. These problems will be corrected in future 
modules shipping to the field, so the field version of LME will 
automatically handle breakpoint monitoring; therefore, these 
options are not described in the following procedure. 

Perform the following procedure to set a breakpoint: 

1. From the CPU: ~,choose the CPU for which you want to set the 
breakpoint. 

2. Set the condition on which you want the CPU to stop: 

• Click on Break On: Iinstr. Parcel I to stop execution on a specific 
current instruction parcel value; enter the value in the Instr. 
Parcel field. 

Cray Research Proprietary 
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• Click on Break On: I P Register I to stop execution on a specific P 
register value; enter the value in the P Register field. 

• Click on Break On: I Trigger I to stop execution when the triggers 
occur. The parameter set assigned to the CPU defines the 
triggering conditions. 

3. Click on (Set Breakpoint) to set the breakpoint for the selected CPU. 
The Current Breakpoint information displays the breakpoint you have 
set for the CPU. LME displays a hollow stop sign icon (0) next to 
a CPU to indicate that a breakpoint is set for the CPU. 

You can click on (Clear Breakpoint) to clear a breakpoint you have set for 
a CPU. You can click on (Reset) to reset the information in the LME: 

Breakpoint Control window. 

When a breakpoint occurs, CPU execution stops, and the LME: Breakpoint 

Control window displays the current instruction parcel and P register 
values. The STATUS information displays BREAK, and LME changes the 
hollow stop sign icon to a filled stop sign icon (.) to indicate that a 
breakpoint has occurred. 

Click on (Continue) to continue CPU execution and leave the breakpoint set. 
Click on (Single-Step) to have the CPU execute the next instruction. Click on 
( Clear & Continue) to clear the current breakpoint and continue CPU execution. 
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Utilities -> Instruction Buffer Dump 

dit'V 

Snapshot Display ... 

Breakpoi nt Control ... 

In.-;tructl0n 8urt~r DIJrnp 

Data Com pare ... 

Config uration ... 

Command Buffer ... 

HDM-xxx-O 
December 9, 1994 

!9 

CPU: 

The Utilities -> Instruction Buffer Dump command, as shown at the left, 
displays the instruction buffer dump utility. The instruction buffer dump 
utility extracts the instruction buffers from mainframe memory and 
displays their contents. This command displays the LME: Instruction Buffer 
Dump window: 

lME: Instruction Buffer Dump 

(Zl 01 View Buffer: 1 0 11 12 13 ~15 16 17 II i~"t·) I 
Dump 

P-reg (Expected): 00000006000 IBA:. I t-1 t.1;: C trifo,·)illt ml~ I ( ) 

Address Expected (Memory) Actual (IB) Difference 

CPU never dumped. 

Perform the following procedure to use the instruction buffer dump utility: 

1. From the CPU: II) , choose the CPU for which you want to dump the 
instruction buffers. 

2. In the P-reg (Expected) field, enter the address of the data with which 
you want to compare the instruction buffer data. 

3. In the IBA: field, enter the base value to use for relative addressing. 

4. Click on ( Dump) to dump the instruction buffers for the selected 
CPU. 

5. Click on the View Buffer setting for the instruction buffer you want to 
VIew. 
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NOTE: You can change the window size and font size by pressing the 
MENU mouse button in this window: 

~ lME: Instruction Buffer Dump 

CPU: ~ 03 View Buffer: I 0 11 12 I 3 14 Is 16 I 7 II Al,t·) I 
P-reg (EKpected): 00000006000 18A: .. .1 t·lt.1t; C ;:rir.'·);'lt lB,' I ( 

Address 
00000006000 
00000006001 
00000006002 
00000006003 
00000006004 
00000006005 
00000006006 
00000006001 
00000006010 
00000006011 
00000006012 
00000006013 
00000006014 
00000006015 
00000006016 
00000006017 

EKpected (Memory) Actual (18) 
000000 000000 000000 000000 00 000000 000000 000000 000000 
000000 000000 000000 000000 01 000000 000000 000000 000000 
000000 000000 000000 000000 02 000000 000000 000000 000000 
000000 000000 000000 000000 03 000000 000000 000000 000000 
000000 000000 000000 000000 04 000000 000000 000000 000000 
000000 000000 000000 000000 no; nnnnnn nnnnni 000000 000000 
000000 000000 000000 000000 C Window Size 1» If 00000 000000 
000000 000000 000000 000000 000000 000000 
000000 000000 000000 000000 Window Font I> 000000 000000 
000000 000000 000000 000000 000000 000000 
000000 000000 000000 000000 12 000000 000000 000000 000000 
000000 000000 000000 000000 13 000000 000000 000000 000000 
000000 000000 000000 000000 14 000000 000000 000000 000000 
000000 000000 000000 000000 15 000000 000000 000000 000000 
000000 000000 000000 000000 16 000000 000000 000000 000000 
000000 000000 000000 000000 17 000000 000000 000000 000000 

Cray Research Proprietary 
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Difference 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
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Utilities -> Data Compare 

dit v 

Snapshot Display ... 
Breakpoint Control ... 
Instruction Buffer Dump ... 

[I-It-l Cr)lflp-Irl; 

Configuration ... 
Command Buffer ... 

HDM-xxx-O 
December 9, 1994 

The Utilities -> Data Compare command, as shown at the left, compares 
data from monitoring sessions and parameter set data. This enables you to 
compare results from different monitoring sessions or compare the 
parameter sets used to generate the data. This command displays the LME: 

Compare LM Data window: 

!9 LME: Compare LM Data 

EXPECTED: I Module Data I Module: ® CPU 00 

I Param Set Data l Buffer: ® A 

ACTUAL: I Module Data 1 Module: ® CPU 00 

I Param Set Data I Buffer: ® B 

I View D iffere nces 0 n Iy I Compare Mask: 
177777 1 77777. 

Addr Expected Actual Difference 
--HIIIo-- --Hlll1-- --HIIIO-- --Hlll1-- --HIIIO-- --Hlll1--

00000 000 000 000 000 200 200 200 200 200 200 200 200 
00001 001 001 001 001 201 201 201 201 200 200 200 200 
00002 002 002 002 002 202 202 202 202 200 200 200 200 
00003 003 003 003 003 203 203 203 203 200 200 200 200 
00004 004 004 004 004 204 204 204 204 200 200 200 200 
00005 DOS ODS ODS ODS 205 205 205 205 200 200 200 200 
00006 006 006 006 006 206 206 206 206 200 200 200 200 
00007 007 007 007 007 207 207 207 207 200 200 200 200 
00010 010 01 0 01 0 010 210 210 210 210 200 200 200 200 
00011 011 011 011 011 211 211 211 211 200 200 200 200 
00012 012 012 012 012 212 212 212 212 200 200 200 200 
00013 01 3 01 3 013 013 213 213 213 213 200 200 200 200 
00014 014 014 014 014 214 214 214 214 200 200 200 200 
00015 015 015 015 015 21 5 215 21 5 215 200 200 200 200 
00016 016 016 016 016 216 216 216 216 200 200 200 200 
00017 017 017 017 017 217 217 217 217 200 200 200 200 

Perform the following procedure to manipulate this window: 

1. Specify the expected data by performing one of the following 
options: 

• Click on EXPECTED: I Module Data I to select a logic monitor data 
buffer for a module. From the Module: @), choose the module 
you want to use. From the Buffer: @), choose the LM data 
buffer you want to use. 

• Click on EXPECTED: I Param set Data I to select a parameter set. From 
the Param Set: @), choose the parameter set you want to use. 
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2. Specify the actual data by performing one of the following options: 

• Click on ACTUAL: I Module Data I to select a logic monitor data 
buffer for a module. From the Module: @), choose the module 
you want to use. From the Buffer: ~,choose the LM data 
buffer you want to use. 

• Click on ACTUAL: I ParamSetData I to select a parameter set. From 
the Param Set: @), choose the parameter set you want to use. 

3. Enter a mask value in the Compare Mask field to indicate which bit 
positions you want to compare in order to generate difference values 
(02 = compare bit position; 12 = do not compare bit position). 

LME displays the expected, actual, and difference data. You can click on 
I View Differences Only I to view only the data that contains differences between the 
actual and expected data. 

Utilities -> Configuration 

dit v ."un" .. 
Snapshot Display ... 

Breakpoint Control... 

Instruction Buffer Dump ... 

Data Compare ... 

Command Buffer ... 

The Utilities -> Configuration command, as shown at the left, displays the 
System Configuration Environment (SCE), which you use to configure the 
mainframe. For more information about SCE, refer to the System 
Configuration Environment document, publication number HDM-xxx-O. 

Utilities -> Command Buffer 

dit 17 

Snapshot Display ... 

Breakpol nt Control ... 

Instruction Buffer Dump ... 

Data Compare ... 

Config uration ... 

30 

The Utilities -> Command Buffer command, as shown at the left, starts the 
Command Buffer Parser (CBP) with the CRAYT90 series CBP runtime 
module. For more information about the CRAY T90 series CBP runtime 
module, refer to the CRAY T90 Series CBP Runtime Module document, 
publication number HDM-xxx-O. 

Cray Research Proprietary 
Preliminary Information 

HDM-xxx-O 
December 9, 1994 

j 



) 

) 

GRAY T90 Series LME Interface Reference 

Module -> View Data Buffers 

""0'''1 
Copy Current Buffer to Expected 

The Module -> View Data Buffers command, as shown at the left, enables 
you to view the logic monitor data buffers for the selected module. These 
buffers contain the results from monitoring sessions. You can view the 
data stored in the current buffer or any of the four available buffers (A, B, 
C, and D). This command displays a data window: 

~ lM E: CPU 00 Data 

Buffer: 

I Current I A I B I C I D I 
Addr --HMO-- --HM1--
000 000 000 000 000 
001 001 001 001 001 
002 002 002 002 002 
003 003 003 003 003 
004 004 004 004 004 
005 DOS ODS ODS ODS 
006 006 006 006 006 
007 007 007 007 007 
010 010 010 010 010 
011 011 011 011 011 
012 012 012 012 012 
013 013 013 013 013 
014 014 014 014 014 
015 015 015 015 015 
016 016 016 016 016 
017 017 017 017 017 

You can view a different data buffer by clicking on the corresponding 
Buffer setting. 

NOTE: The (Module v) button is only active after you click on an assigned 
parameter set in the module area. 

Module -> Copy Current Buffer to Expected 

View Data Buffers ... 

• .. "i6 .. ' ...... 

Reset -> Channel 

"""I@ 
Server 

The Module -> Copy Current Buffer to Expected command, as shown at the 
left, copies the current buffer of logic monitor data to the expected data 
buffer for the parameter set assigned to the selected module. Use this 
command to use the results of one monitoring session as the expected data 
for another monitoring session. 

NOTE: The (Module v) button is only active after you click on an assigned 
parameter set in the module area. 

The Reset -> Channel command, as shown at the left, resets the FY driver. 

,) Configuration 

HDM-xxx-O 
December 9,1994 
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Reset -> Server 

Channel 
Set "er 

Con fig uration 

The Reset -> Server command, as shown at the left, resets the LME server. 
This stops any active monitoring sessions. 

Reset -> Configuration 

Channel 
Server 

32 

The Reset -> Configuration command, as shown at the left, causes SeE to 
reapply the configuration. 

NOTE: This command does not work if any partitions have an OS 
owner. For more information about partition ownership, refer to 
the System Configuration Environment document, publication 
number HDM-xxx-O 
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Server See page 32 
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Assign Module(s) 
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Figure 3. Menu Quick Reference 
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