
) 

CRAY T90 SERIES MME INTERFACE REFERENCE 

Description of this Document ............................ vii 

Notational Conventions ................................. V111 

ENVIRONMENT 0 1 

Interface Components 1 

Automatic or Manual Mode .......................... . 1 Pb Base Window Title .............................. . 

1--($ Version Number ................................ . 

2 

2 

2 

HDM-xxx-O 
December 21, 1994 

,~S' tor or FEI Channel ........................ . Do . 0 r Channel Number ................... . 2 

2 

Control Bu.tton~ .... " : . . . ~ ~ J . . .. .~. ~ 3 

ConfiguratIOn InformatIone .. ~ .VI/tvAl· ... .f.IOft J 
Status Information ............. '. . . .. .. . rj::::-'" I V 
Modes ............................... " .. . z,;;;. . . 4, 

Compose Mode .................................... 5 

Base Window Title. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5 

Version Number . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5 

Simulator or FEI Channel ......................... 5 

Workstation or Channel Number . . . . . . . . . . . . . . . . . . . . 6 

Copy Number. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6 

Menu Bar ...................................... 6 

Sequence Editing Buttons ......................... 6 

Total Pass and Error Counts . . . . . . . . . . . . . . . . . . . . . . . . 7 

Control Buttons ................................. 7 

Configuration Information . . . . . . . . . . . . . . . . . . . . . . . . . 8 

Status Information ............................... 8 

Modes......................................... 9 

Cray Research Proprietary iii 
Preliminary Information 



GRAY T90 Series MME Interface Reference 

• .:.,~~: ".:"1 . , 
_:f.t :".' 

", ~ 

'- .. -~: '1.. 
:;-

iv 

Sequence Scroll Box ............................. 9 

Menu Button Commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10-) 

File -> Load -> Sequence ........................... 10 

File -> Load -> Data ............................... 11 

File -> Save -> Sequence ............................ 13 

File -> Save -> Data ............................... 14 

File -> Delete ..................................... 15 

File -> Print -> Root ............................... 16 

File -> Print -> Screen .............................. 16 

File -> Print -> Setup ............................... 16 

File -> Dump ............................. . ..... . 

View -> Memory ..................... ~.,.!~ ••.• :: ••.••.• 
"'vl.' '1: .. , . . " • 

Changing Memory ......... c~ "; •• :'., f';;.~" .. ': ........ . 

Using the Keyboard ~c~ylehltor : .... : ~ ............ . 
• I~ "\ .~:'\' --'? \'., '.... ~. ~ 

VIew -> Buffer ... '.~''" .'-c.·· ••• ' •• ", ;' : ............. :: •••••••••••• 

... ;~~fli:!o; ;:':>:'::)':::/:: :: :': : : :: : : : : : : : : : : : : 
'. ,., ,.View -::>Ndt~':;~',,: .. :' ................................ . 

17 

19 

24 

26 

34 

35 

35 

36 

36 

36 

36 

37 

37 

38 

) 

., ...• 

", J. <'- .. : ~ • 

Progerties ""->'Environment -> ENVI .................. . 
:" ,'" '" ,", ",' ,;~)~\.' 

'.,' ":'Pt6pe'fiies -> Environment -> ENV2 .................. . 
-: ., ; .. 
-~ s·· 

Properties -> Partition ............................. . 

Properties -> Resource Allocation .................... . 

Specifying which CPU Writes and Reads Memory ..... . 

Setting the Debug Level that MME Uses ............ . 

Properties -> Enable Auto Apply ...................... 38 

Properties -> Disable Auto Apply ..................... 39 

Utilities -> Pattern ................................. 39 

Utilities -> Find ................................... 39 

Utilities -> Configuration ............................ 41 

Utilities -> Logic Monitor ........................... 42 

Reset -> Channel .................................. 42 

Reset -> Server .................................... 42 

Reset -> Configuration .............................. 42 

Gray Research Proprietary 
Preliminary Information 

HDM-xxx-O 
December 21, 1994 



) 

HDM-xxx-O 
December 21, 1994 

GRAY T90 Series MME Interface Reference 

ENVIRONMENTS 1 AND 2 45 

Interface Components .................................. 45 

Base Window Title . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46 

Version Number . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46 

Simulator or FEI Channel ............................ 46 

Workstation Name or Channel Number. . . ... .. .. . .. . .. .. 46 

Copy Number. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46 

Menu Bar ......................................... 46 

CPU Selection, Control Point, and Status Area . . . . . . . . . . . . 46 

Controls .......................................... 51 

Configuration Information . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52 

Sections Scroll Box ................................. 52 

Status Information .................................. 53 

Control Points Scroll Box ............................ 54 

Menu Button Commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55 

File -> Load -> Data ............................... 55 

File -> Load -> Control Point ........................ 57 

File -> Load -> Test List ............................ 59 

File -> Load -> Layout ............................. 59 

File -> Save -> Data ............................... 60 

File -> Save -> Control Point ........................ 61 

File -> Save -> Test List ............................ 62 

File -> Save -> Layout .............................. 62 

File -> Delete ..................................... 63 

File -> Print -> Root ............................... 64 

File -> Print -> Screen .............................. 64 

File -> Print -> Setup ............................... 64 

File -> Dump ..................................... 65 

View -> Memory .................................. 67 

Changing Memory . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73 

Using the Keyboard Accelerator. . . . . . . . . . . . . . . . . . . . 75 

View -> Standard Locations .......................... 84 

View -> Error Log ................................. 85 

Memory Error Information ........................ 85 

Cray Research Proprietary v 
Preliminary Information 



GRAY T90 Series MME Interface Reference 

Register Parity Error Infonnation ................... 86 

Shared Register Error Infonnation .................. 86-~') 

vi 

LAT Error Infonnation . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87 

View -> Memory Map .............................. 87 

View -> Runtime Infonnation -> Current ............... 87 

View -> Runtime Infonnation -> Controller (Environment 2 
Only) ............................................ 89 

View -> Listing -> Current .......................... 90 

View -> Listing -> Controller ........................ 92 

View -> Listing -> Other ............................ 92 

View -> Notes ..................................... 94 

Edit -> Delete Control Point -> Selected ................ 94 

Edit -> Delete Control Point -> All .................... 94 

Edit -> Assign CPU(s) .............................. 94 

Edit -> Deassign CPU(s) ............................ 94 

Properties -> Environment -> ENV2 (Environment 1 Only) 94 

Properties -> Environment -> ENVI (Environment 2 Only) 95 

Properties -> Environment -> ENVO ................... 95 

Properties -> Partition .............................. 95 

Properties -> Resource Allocation ..................... 96 

Changing Memory Allocation (Environment 2 Only) . . . . 96 

Changing the Auto Assignment, CPU Allocation, or CPU 
Control Options ................................. 98 

Changing the CPU to Memory Delay ................ 100 

Changing the Section Swap Interval and Enabling or 
Displaying the Maximum Pass Option ............... 101 

Changing the Error Logger Access Setting and Setting the 
Debug Level . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. 102 

Properties -> Run System (Environment 2 Only) ......... 103 

Utilities -> Clear ................................... 104 

Utilities -> Pattern ................................. 104 

Utilities -> Find ................................... 104 

Utilities -> Copy/Move ............................. 107 

Utilities -> IB Dump ............................... 107 

Utilities -> Configuration ............................ 107 

Utilities -> Logic Monitor ........................... 108 

Cray Research Proprietary 
Preliminary Information 

HDM-xxx-O 
December 21, 1994 

) 



.. -. 

) 

GRAY T90 Series MME Interface Reference 

Utilities -> Command Buffer ......................... 108 

Reset -> Channel .................................. 108 

Reset -> Server .................................... 108 

Reset -> Configuration .............................. 109 

Reset -> I/O (Quad 0) ............................... 109 

Reset -> I/O (Quad 1) 

Reset -> I/O (Quad 2) 

Reset -> I/O (Quad 3) 

109 

110 

110 

110 Reset -> Shared 

Figures 

Figure 1. 

Figure 2. 

Figure 3. 

Figure 4. 

Figure 5. 

Figure 6 . 

Figure 7. 

Figure 8. 

Figure 9. 

Tables 

Table 1. 

Table 2. 

Table 3. 

Table 4. 

Environment 0 Interface Components (Automatic or 
Manual Mode) ....... . .. . . . ..... .. .. . ... . . . . 1 

Environment 0 Interface Components 
(Compose Mode) ........... ................. 5 

Environment 0 Menu Quick Reference . . . . . . . . . . . 43 

Environments 1 and 2 Interface Components ...... 45 

Example Interrupt Flag ....................... 48 

Example Controller Status Message ............. 48 

Memory Allocation in Environment 2 ........... 97 

Environment 1 Menu Quick Reference . . . . . . . . . .. 111 

Environment 2 Menu Quick Reference. . . . . . . . . .. 112 

Interrupt Flags ............................. 48 

Controller Status Messages ................... 49 

Control Point Runtime Information Categories .... 88 

Controller Runtime Information Categories 89 

Description of this Document 
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This document is a reference to the user interface for the Mainframe 
Maintenance Environment (MME) application used to troubleshoot 
CRAY T90 series mainframes. This document describes the interfaces 
used with MME environments 0, 1, and 2. It also describes all available 
menu button commands. Figure 3, Figure 8, and Figure 9 contain 
illustrations of all menu button commands available in environments 0, 1, 
and 2, respectively. 
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This document is one component of the MME documentation set, which 
includes the following documents. -) 

CRAY T90 Series MME User Guide, publication number HDM-xxx-O. 

This document describes how to use the MME environments for 
troubleshooting. It includes information about the internal 
functionality of MME. 

CRAY T90 Series MME Interface Reference, publication number 
HDM-xxx-O. 

This document describes the interfaces used with MME environments 
0, 1, and 2. It also describes all available menu button commands. 

CRAY T90 Series MME Diagnostic Tests and Utilities, publication number 
HDM-xxx-O. 

This document provides quick-reference information for all diagnostic 
tests and utilities you can use with MME. 

Notational Conventions 

viii 

This document uses the following notational conventions: 

• The base of a number is decimal unless stated otherwise. All 
memory references are octal values. 

• Buttons are shown the way they appear in a window; for example, 
( Go ). 

• Settings are shown the way they appear in a window; for example, 
1 Compose I. 

• The -> symbol indicates holding the MENU mouse button down and 
moving the mouse pointer to the next menu item. 

• Courier type indicates a command you can enter. 

• Courier bold type indicates commands you should enter. 
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• Helvetica type indicates references to the MME interface windows. 

• Helvetica bold type indicates menu entries you should choose from 
the MME interface; for example, the text "choose View -> Memory" 
indicates you should choose the Memory entry from the (view,,) menu 
button. 
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ENVIRONMENT 0 

This section describes the interface components and menu button 
commands for MME environment O. 

Interface Components 

The MME environment 0 interface, located in the base window, controls 

A~ in environment o. Environment 0 uses two distinct graphic 
.' .. ces: one for automatic and manual modes and one for compose 

. ··ZA 
Automatic or Man~ ~I\tA 

Figure 1 s~~~l..-~nt 0 graphic user interface for 
automatic or u' ~:'ll~.p}S following the figure describe 

the components 0 tlI in~ ... , V A"a 
Version Number 1atn!!;>11 t;& 

~@)~ __________ +-__________________ ~~~~ __ ~~~:~~~:~mwt-,~ ~~umber 

~~~A 
Base Window Title 

~ (View v) (Properties v) (Utilities v) 

Tests: 

11. BS Communication 

I 2. Config uration (Bas ic) 

~==t? 
~;;;;;;;;::::::::::;;:===:====:1t-- Module and Test 

Modes 

Status 
Information 

14. I/O Error Correction I 9. M isce lIaneous 

15. logic Monitor 

(Select All Modules) (S9T(.-::tA~--) 

( Deselect All Modules) (-De';':iect Ai! Ta,;t, -) 

Test Mode: Error Mode: Dl.'bng M!)tll~: 

Automatic I Stop On Channel Error II ::.r,al)j,: Seq.s M.)(i.: 

f--M_an_u_al_-4 I Stop On Sequence Error II E"~i:·j,) St·:,. r-kde 
Compose 

Passes: 0 

Errors: 0 

/ --.-::-~<-.-

~'=====::::) 
!... H .. :cii: ) 

Inactive - I/O CPU 00 Environment ENVO - T4 - PO 16B/8S5/85 

Selection Area 

Total Pass and 
Error Counts 

Control Buttons 

Configuration 
Information 

Figure 1. Environment 0 Interface Components (Automatic or Manual Mode) 
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Base Window Title 

Version Number 

The base window title displays the name of the program: Mainframe 
Maintenance Environment. 

The version number indicates the version of MME you are using. 

Simulator or FEI Channel 

The simulator or front-end interface (FEI) channel indicator shows MME 
is running with the simulator (indicated by SIM) or an FEI channel 
(indicated by FEI CHN 0 for channel 0, FEI CHN 1 for chafipel 1, or FEI 
CHN 2 for channel 2). 

. \, : .. ,. 
Workstation or Channel Number 

Copy Number 

" i 

Menu Bar 

" '::~ 
",Y .. 

The workstation or channel:~un1ber indiCat~r.Jists'the name of the 
workstation or the'cIr~~Lrium.bef"ort,Wh:lch MME is running. 

~. ,: .!,;.W:<· .:. "~' . 

..... 

" .; .~. :" '. 

, ~; 

,'>.',' ;The c~pyril1Jrib.~rJll(tlcates the copy of MME you are using. To set the 
. :: " cqpy,;p.~mtierrstint MME with the - copy option. If you start MME with 

,~tJ?d,p:~falilt 'copy number of 0, the MME base does not display a copy 
. "nurriber. For more information about starting MME with the - copy 

'option, refer to the CRAY T90 Series MME User Guide, publication 
number HDM-xxx-O. 

The menu bar contains five menu buttons: ~,( View <;J), ( Properties <;J), 

(Utilities <;J), and (Reset <;J). For descriptions of the commands accessible from 
these menu buttons, refer to "Menu Button Commands" later in this 
section. 

Module and Test Selection Area 

2 

In the module and test selection area, you can modules to the environment ° tests. You can assign four types of modules to tests: SSs (boundary 
scan modules), SHRs (shared modules), CPUs (CPU modules), and II0s 
(input/output modules). 
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Use the following settings to select environment 0 tests: 

! ,. B5 communication! 

!2. Configuration (Basic) ! 

!3. Memory 

!4. I/O Error Correction 

! 5. logic Monitor 

!s. Exchange 

!7. Instruction Buffers 

! B. Configuration (Adv) 

!9. Miscellaneous 

Click on a setting to select a test. Use the (select A II Tests ) and 
( Deselect All Tests ) buttons to select or deselect all tests (automatic mode 
only). Use the (Select All Modules) and (Deselect All Modules) buttons to select or 
deselect all modules. 

For more information about the environment 0 tests, refer to the 
CRAY T90 Series MME Diagnostic Tests and Utilities document, 
publication number HDM-xxx-O. 

Total Pass and Error Counts 

Control Buttons 

The total pass count component (Passes) indicates the number of passes a 
test has completed. The total error count component (Errors) indicates the 
total number of errors found during the current test(s) executions. The 
pass and error counts are in decimal. 

Use the control buttons to start testing «(,-_...;;.GO~---J» and stop testing 
« Halt ). 

Configuration Information 

HDM-xxx-O 
December 21, 1994 

The configuration information component displays the current MME 
environment and configuration data (mainframe type; partition where 
MME is running; and number of sections, subsections, and banks). The 
System Configuration Environment (SCE) provides this information. 

For example, the following configuration information indicates MME is in 
environment 0 (Environment ENVO); the mainframe type is a CRAY T94 
system (T4); MME is running in partition 0 (PO); and the configuration 
consists of 16 banks (168), 8 subsections (8SS), and 8 sections (8S). 
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Status Information 

Modes 
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E nv iron me nt E NVO - T4 - PO 16B/8SS/8S 

The configuration information component displays one of the following 
mainframe types: 

Type 

TV1 (1x1) 

TV4 (1x4) 
TV4(4x4) 

T4 

T16 

T32 

Description 

A tester with 1 CPU and 1 memory module 
A tester with 1 CPU and 4 memory modules 
A tester with 4 CPUs and 4 memory modules 
A mainframe with 4 CPUs 
A mainframe with 16 CPU s 
A mainframe with 32 CPUs 

The status information component displays the current state of the MME 
program, using the following messages: 

Message 

Active 

Inactive 
I/O CPU## 
I/O Disabled 

Description 

Test(s) are running. 
No testes) are running. 
The specified CPU is the 110 CPU. 
No CPUs are set as the I/O CPU. 

The modes area contains the settings for the Test Mode, Error Mode, and 
Debug Mode: 

• Test Mode can be set to I Automatic I, I Manual I, or I Compose I to indicate 
testing in automatic, manual, or compose mode. 

• Error Mode can be set to I Stop On Channel Error I to stop testing when a 
channel error occurs and I Stop On Sequence Error I to stop testing when a 
sequence error occurs. 

• The Debug Mode settings are used in compose mode only. 
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Compose Mode 

Figure 2 shows the MME environment ° graphic user interface for 
compose mode. The paragraphs following the figure describe the 
components of this interface. 

Base Window Titlel Version Number 1 
[

Simulator or FEI Channel 

r Workstation or Channel Number 

Sequence 
Scroll Box-

ffi Mainframe Maintenance Environment (MME 1.0.2) SIM [boyd] (14) Copy Number 

~ (View 17) (Properties 17) (Utilities 17) (Reset 17) .. .-- Menu Bar 
r---------------------------------------------------,I 

SI~IlU(lnl:(l: 0 Entries [---.-.---.----.--.. -... -----.. --.-.. -.---.-----.. --.. -··-·-··-·-·--···---····-... -l~ 

! !~ 
l 
! 

!._ .... _ .. __ .. _____ . __ .. __ ._ .. __ .. _. ____ .. _ .....•............• _ ........................ _ ...... _ ... _ .. _ ... _ .. _ ........... _ ... _ ...... _ ....... __ J= 
Test Mode: Error Mode: Debug Mode: 

(Create 1» 

(T;;'T--~:) 

( "e,X·----;) 

( Module 1» 

I-- Sequence 
Editing Buttons 

Modes- ~ Automatic I Stop On Channel Error II Enable Scope Mode 

Passes: 0 

Errors: 0 

.. r-Total Pass and 
Error Counts 

I--M_a_nu_a_1 ---1 I Stop On Sequence Error II Enable Step Mode 
Compose 

(-~-'--~~.-'--'---) 

e- .. H:;1i: .. _- ) -~ Control Buttons 
Status 
Information---l Inactive - I/O CPU 00 Environment ENVO - T4 - PO 168/8SS/8S -II-- Configuration 

Information 

Figure 2. Environment ° Interface Components (Compose Mode) 

Base Window Title 

Version Number 

The base window title displays the name of the program: Mainframe 

Maintenance Environment. 

The version number indicates the version of MME you are using. 

Simulator or FEI Channel 

HDM-xxx-O 
December 21, 1994 

The simulator or PEl channel indicator shows MME is running with the 
simulator (indicated by 81M) or an PEl channel (indicated by FEI CHN 0 for 
channel 0, FEI CHN 1 for channell, or FEI CHN 2 for channel 2). 
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Workstation or Channel Number 

Copy Number 

Menu Bar 

The workstation or channel number indicator displays the name of the 
workstation or the channel number where the MME program is running. 

The copy number indicates the copy of MME you are using. To set the 
copy number, start MME with the - copy option. If you start MME with 
the default copy number of 0, the MME base does not display a copy 
number. For more information about starting MME with the - copy 

option, refer to the CRAY T90 Series MME User Guide, publication 
number HDM-xxx-O. 

The menu bar contains five menu buttons: ~,(view v), (Properties v), 

( Utilities v), and (Reset v). For descriptions of the commands accessible from 
these menu buttons, refer to "Menu Button Commands" later in this 
section. 

Sequence Editing Buttons 

6 

Use the sequence editing buttons to manipulate the placement of functions 
and utilities within a test sequence. These buttons perform the following 
functions: 

Button 

(create t» 

(copy t» 

Function 

Creates a new function or utility in the current 
sequence. The function or utility is placed in the 
Sequence scroll box. 

Choose Create -> Before to place the function before 
the selected function in the scroll box. Choose Create 
-> After to place the function after the selected 
function in the scroll box. Choose Create -> Top to 
place the function at the top of the scroll box. 
Choose Create -> Bottom to place the function at the 
bottom of the scroll box. 

Copies the selected function or utility in the 
Sequence scroll box. Choose Copy -> Selected to 
copy the selected function. The Copy -> Range 
command is not implemented yet. 
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Button Function 

( Cut 1» Cuts the selected function or utility from the current 
sequence in the Sequence scroll box. Choose Cut -> 
Selected to cut the selected function. The Cut-> 
Range command is not implemented yet. 

C Paste 1» Pastes a copied or cut function or utility into the 
current sequence in the Sequence scroll box. 

Choose Paste -> Before to paste the function before 
the selected function in the scroll box. Choose Paste 
-> After to paste the function after the selected 
function in the scroll box. Choose Paste -> Top to 
paste the function at the top of the scroll box. Choose 
Paste -> Bottom to paste the function at the bottom of 
the scroll box. 

( Clear ) Removes all functions and utilities from the 
Sequence scroll box. 

C Module 1» Sets the module used by the functions and utilities in 
the current sequence. 

Total Pass and Error Counts 

Control Buttons 

HDM-xxx-O 
December 21, 1994 

The total pass count component (Passes) indicates the number of passes a 
test has completed. The total error count component (Errors) indicates the 
total number of errors found during the current test(s) executions. The 
pass and error counts are in decimal. 

Use the control buttons to start testing (C .... __ GO_-J» and stop testing 
(c Halt». 
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Configuration Information 

Status Information 

8 

The configuration information component displays the current MME 
environment and configuration data (mainframe type; partition where 
MME is running; and number of sections, subsections, and banks). The 
System Configuration Environment (SCE) provides this information. 

For example, the following configuration information indicates MME is in 
environment 0 (Environment ENVO); the mainframe type is a CRAYT94 
system (T4); MME is running in partition 0 (PO); and the configuration 
consists of 16 banks (168), 8 subsections (8SS), and 8 sections (8S): 

Enyironment ENVO - T4 - PO 16B/8SS/8S 

The configuration information component displays one of the following 
mainframe types: 

Type 

TV1 (1x1) 

TV4 (1x4) 

TV4 (4x4) 

T4 

T16 
T32 

Description 

A tester with 1 CPU and 1 memory module 
A tester with 1 CPU and 4 memory modules 
A tester with 4 CPUs and 4 memory modules 
A mainframe with 4 CPUs 
A mainframe with 16 CPUs 
A mainframe with 32 CPUs 

The status information component displays the current state of the MME 
program, using the following messages: 

Message 

Active 

Inactive 

110 CPU ## 
110 Disabled 

Description 

Test(s) are running. 
No test(s) are running. 
The specified CPU is the 110 CPU. 
No CPUs are set as the 1/0 CPU. 
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Modes 

Sequence Scroll Box 

HDM-xxx-O 
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The modes area contains the settings for the Test Mode, Error Mode, and 
Debug Mode: 

• Test Mode can be set to I Automatic I, I Manual I, or I Compose I to indicate 
testing in automatic, manual, or compose mode. 

• Error Mode can be set to I Stop On Channel Error I to stop testing when a 
channel error occurs and I Stop On Sequence Error I to stop testing when a 
sequence error occurs. 

• Debug Mode can be set to I Enabled I to enable scope mode. Debug 

mode can also be set to I Disabled I to enable step mode, which causes 
one function or utility to execute each time you click ( Go ). 

The Sequence scroll box shows the function entries for the current 
sequence. These functions run in the order they are displayed in the scroll 
box; when you click ( Go ), function entries at the top of the scroll 
box run before entries at the bottom. 
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Menu Button Commands 

The menu buttons contain commands that manipulate MME environment 
O. This subsection describes what each command does and how to use 
each menu button command. Figure 3 on page 43 shows all available 
menu button commands for environment O. 

File -> Load -> Sequence 

10 

The File -> Load -> Sequence command, as shown at the left, loads 
previously saved sequences into the MME program (refer to "File -> Save 
-> Sequence" for more information about saving sequences). Use this 
command to load specialized sequences you have created or modified for 
your specific testing needs. This command displays the MME Load/Save 

Sequence window: 

s9 MME load/Save Sequence 

load Dir: .:::us"-'r/..:..:se""'q/c-* ___ _ 
load Files: 

config.Z 
pcip.Z 
sanity.Z 
san ity. test.Z 
tester.config.Z 
tester.config.dma.Z 

~-------~= 

Save Dir: .==us"-'-r/""se""-9 ___ _ 
Save File: ....... _____ _ 

C Save... ) 

Perform the following procedure to manipulate this window: 

1. Change the directory in the Load Dir field, if necessary, and press the 
Retumkey. 

2. Click on the sequence to load in the Load Files scroll box. 

3. Click on ( Load ... ); MME loads the specified sequence. 
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The File -> Load -> Data command, as shown at the left, loads a data set 
into the MME buffer or mainframe memory. Use this command to 
re-create a specific data set for testing without having to manually enter it 
each time. This command displays the MME Load/Save Data window: 

is> MME Load/Save Data 

Mode: I Word I Parcel I 
Load Destination: I Memory I Buffer I 

Load 0 irectory: ::@)=-=u=sr=/*.~==::::;;, 

Load Files: cfg/ =~ .. 
cmd/ 
diag/ 

~1=fi~le=.=sa~m~p-:-le~~~~~~1 1 
Load Type: Nonstandard 

Load Address: 00000000000000 

Load Length: 00000000000000 ( Load) 

Save Source: I Memory I Buffer I 
Save Directory: =us"-'-r/ ___ _ 

Save File: file.sam p Ie 

Save Address: 00000000000000 
Save Length: 00000000000000 (Saye) 

9 files found 

Perform the following procedure to manipulate this window: 

1. Select the data Mode. Click on , word' to use a word load address 
and length or' parcel' to use a parcel load address and length. The 
Load Address and Load Length fields change to the specified format. 

2. Specify the Load Destination. Click on' MemOry' to load the data into 
mainframe memory or 'Buffer' to load the data into the MME buffer. 

3. Change the directory, if necessary, by choosing a new directory from 
the Load Directory @) or by entering the directory in the Load Directory 

field. The following directories are available in the Load Directory 

@): 

Directory Description 

Release Menu to access available diagnostic program 
fIles from the current offline diagnostic release 

Cray Research Proprietary 
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Directory 

User 

Alpha 

Utility -> Release 

Utility -> Alpha 

GRAY T90 Series MME Interface Reference 

Description 

Files you have saved or modified 

Prereleased diagnostic program files that are 
being tested and have not been released 

Utility files from the current offline diagnostic 
release 

Prereleased utilities that are being tested and 
have not been released 

4. In the Load Files scroll box, click on the data file you want to load. 
The Load Type and Load Length information is updated, and the ( Load) 

button is activated. 

5. In the Load Address field, enter the address at which you want to load 
data. 

6. Click on (Load); MME loads the data at the specified address in 
mainframe memory or the MME buffer. 
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The File -> Save -> Sequence command, as shown at the left, saves a 
sequence of maintenance channel functions and utilities you have created 
or modified. Use this command to create customized sequences (refer to 
"File -> Load -> Sequence" earlier in this section for more information 
about loading sequences). This command displays the MME Load/Save 

Sequence window: 

!:9 MME load/Save Sequence 

load Dir: =VS"-,r/-,,,5~=q/,-" ___ _ 
load Files: 

config.Z 
pcip.Z 
sanity.Z 
san ity. test.Z 
tester.config.Z 
tester.config.dma.Z 

L-_______ ~= 

Save Dir: .::,:us""'rl.::.;s8:..:lq ___ _ 
Save File: ...... _____ _ 

( Save... ) 

Perform the following procedure to manipulate this window: 

1. To change the directory on the maintenance workstation (MWS) 
where the sequence is saved, specify a different directory in the Save 

Dir field, and press the Return key. 

2. In the Save File field, enter the name of the file you want to use, and 
press the Return key. 

3. Click on ( Save... ) or press the Return key; MME saves the sequence 
in the specified file. 

Gray Research Proprietary 
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14 

The File -> Save -> Data command, as shown at the left, saves a 
mainframe memory or an MME buffer data set so you can reuse it. Use 
this command to recreate a specific data set for testing. This command 
displays the MME Load/Save Data window: 

MME load/Save Data 

Mode: I Word I Parce I I 
load Destination: I Memory I Buffer I 

load Directory: :=@)=-=u=sr=/*.~====;;: 

load Files: cfg/ =~_ 
cmd/ _ 
diag/ 
layout! I 

L--_____ --'= 
toad Ty!)!.': f.'1~ir, F ;1" 

load Address: 00000000000000 

L(H~d Length: ~~:L(:_(o.~:~~:~.~i: ('·l.(.arl) 

Save Source: I Memory I Buffer I 
Save Directory: .:::;us"-'-r/ ___ _ 

Save File: ____ _ 

Save Address: 00000000000000 

Save length: 00000000000000 ~ 

Checking directory ... 8 files found 

Perform the following procedure to manipulate this window: 

1. Click on Mode: I Word I to use a word save address and length or 
Mode: I Parcel I to use a parcel save address and length. The Save 

Address and Save Length fields change to the specified format. 

2. Click on Save Source: I Memory I to save mainframe memory data, or 
click on Save Source: I Buffer I to save MME buffer data. 

3. To change the directory on the MWS where the data is saved, specify 
a different directory in the Save Dir field, and press the Return key. 

4. In the Save File field, enter the name of the file you want to use. 

5. In the Save Address field, enter the starting address of the data block 
you want to save. 

6. In the Save Length field, enter the length of the data block you want 
to save. 

7. Click on ( save); MME saves the specified data set. 
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File -> Delete 

Load I> 

Save I> 

emma 
Print I> 

Dump ... 

HDM-xxx-O 
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The File -> Delete command, as shown at the left, deletes files you no 
longer need. Use this command to delete unwanted files from the MME 
user directories stored on the MWS. This command displays the MME 
Delete File window: 

!9 MME Delete File 

~ usr/seq/. 

Files: 

Vread.ckvaz 
a1.Z 
brdwtZ 
break.Z 
cfgtmp.Z 
cft.seq.Z 
cftseq1.Z 
cicjtest.Z 
cicjtest2.Z 
config.l x4.Z 
configtest.Z 
contestZ 
dbchk.Z 
diag.Z 

~--------------~= 

81 files found 

Perform the following procedure to manipulate this window: 

1. Change the directory, if necessary, by: 

• Entering the directory in the CDir: v) field and pressing the Return 
key, or 

• Choosing the directory from the (Dir. v) button. The following 
user directories are available: 

Directory 

usrl* 
usr/cmd 
usr/tst 
usr/lst 
usrlseq 

Description 

All user directories 
User command buffers 
User test lists 
User listings 
User sequences 

2. Click on the file you want to delete. 

3. Click on ( Delete); MME deletes the file. 
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File -> Print -> Root 

Screen 
Dump .. 

Setup .. , 

The File -> Print -> Root command, as shown at the left, prints an image of 
everything contained in the root window, including the MME base 
window. 

File -> Print -> Screen 

The File -> Print -> Screen command, as shown at the left, prints an image 
of a window or an icon. 

When you choose this command, the cursor becomes a plus symbol. 
Move the cursor to the window or icon to print, and click any mouse 
button. 

NOTE: This command does not print an image of the MME base 
window. To print an image of the MME base window, use the 
File -> Print -> Root command. 

File -> Print -> Setup 

Load E> 

16 

The File -> Print -> Setup command, as shown at the left, enables you to 
edit the commands that control how MME prints data for the 
File -> Print -> Root and File -> Print -> Screen commands. This command 
displays the MME Print Setup window: 

MME Print Setup 

Print Root Command: (xwd -root I xpr -device /jet -rv lip)&, 

Print Screen Command: (xwd -frame I xpr -device Ijet -rv IIp)& 

( Save Commands To File ) 
(Reset Commands From File) 

( Reset Commands From Defaults) 

Modify the commands in the Print Root Command and Print Screen 

Command fields to change how MME prints. For more information about 
the UNIX xwd, xpr, and Ip commands used in the print processes, refer 
to the UNIX online manual (man) pages (enter man xwd, man xpr, or 
man Ip at a UNIX command prompt). . ) 
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Use the buttons in the MME Print Setup window to: 

• Save the current printer setup commands for later use 
« Save Commands To File ) ). 

• Load the printer setup commands you saved previously 
(C Reset Commands From File ». 

• Load the default printer setup commands that the MME program 
provides « Reset Commands From Defaults». 

The File -> Dump command, as shown at the left, sends a copy of MME 
buffer or mainframe memory data to a file or printer. Use this command 
to create a permanent record of the data so you can analyze it later. This 
command displays the MME Dump Setup window: 

!9 MME Dump Setup 

Mode: 

I File I Printer II Compress I 
D ir(lctory: J~:'::£.. _______ . ______ . 

File: 

Format: IYl Parcel 

So uree: I Memory I Buffer I 
Start Address: 00000000000. 

length (words): 00000000000 

End Address: 00000000000 

comments: 

( Dump) 

Perform the following procedure to manipulate the MME Dump Setup 
window: 

1. Specify the Mode. Click on ~ to output the data to a file, or click 
on I Printer I to output the data to the printer. 
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Click on I Compress I to compress the output of the File -> Dump 

command. This reduces the size of the data listing by replacing 
repeated lines with a statement similar to Last line repeated 077 (63) 

times. 

2. If data is being dumped to a file, specify the directory in the Directory 

field and the file in the File field. 

3. Choose the format in which you want the data displayed from the 
Format @). The following formats are available: 

Format 

Nibble 

Byte 

Parcel 

Halfword 

Word 

Hexadecimal 

Address 

Text 

Exchange (NI) 

Instruction 

Description 

Nibble data 
Byte data 
Parcel data 
Halfword data 
Word data 
Hexadecimal data 
Address data 
Text data 
Exchange data (not implemented) 
Instruction data 

4. Specify the Source. Click on I Memory I to dump mainframe memory 
data or I Buffer I to dump MME buffer data. 

5. Specify the data block you want to dump by completing any two of 
the following actions (the third field is automatically set using data 
from the other two fields): 

• Enter the starting address of the data block you want to dump in 
the Start Address field, and press return. 

• Enter the length (in words) of the data block in the Length 

(words) field, and press return. 

• Enter the ending address of the data block you want to dump in 
the End Address field, and press return. 

6. Click on the Comments scroll box and type any comments you want 
to include with the data. For example, you might specify that the 
data is the result of a specific test or that it was created on a specific 
date. 

7. Click on ( Dump ); MME sends the specified data to the printer or 
file. 
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View -> Memory 

Buffer ... 

Log .. 

Report. .. 

Notes ... 
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The View -> Memory command, as shown at the left, displays mainframe 
memory in a separate window. Use this command to verify the contents 
of specific mainframe memory locations or to change the data stored in 
mainframe memory. This command displays the MME View Memory Setup 

window: 

~ MME View Memorv Setup 

Refresh (msec): 1000 0 -D= 0 

Format: 

Nib b Ie Halfword Text I 
Byte Word Address I 

Parcel Hex 

Mode: 

I Memory I Exchange I Instruction I 
Source: 

Memory Buffer 

Size: ~ large 

Font: ~ Medium 

Address: .... O.~ __ _ 

( View ... ) 

Perform the following procedure to manipulate this window: 

1. Set the interval at which memory windows are updated by moving 
the Refresh (msec) slider or by entering a value in the Refresh (msec) 

field and pressing the Return key. (Setting this value too low can 
monopolize the workstation CPU and reduce system performance.) 

2. Click on a Format [~, I Hallword I, ~, ~, ~, I Address I , 
~, or ~ (hexadecimal)] to specify the format in which you 
want the data displayed. 

3. Click on a Mode (I Memory I, I E.change I, or I Instruction I) to specify the 
way you want the data displayed. 
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Memory mode (I Memory I) displays normal memory: 

19 Memory - Absolute 

00000000000 ~ooooo 000000 000000 000000 
00000000001 000000 000000 000000 000000 
00000000002 000000 000000 000000 000000 
00000000003 000000 000000 000000 000000 
00000000004 000000 000000 000000 000000 
00000000005 000000 000000 000000 000000 
00000000006 000000 000000 000000 000000 
00000000007 000000 000000 000000 000000 
00000000010 000000 000000 000000 000000 
00000000011 000000 000000 000000 000000 
00000000012 000000 000000 000000 000000 
00000000013 000000 000000 000000 000000 
00000000014 000000 000000 000000 000000 
00000000015 000000 000000 000000 000000 
00000000016 000000 000000 000000 000000 
00000000017 000000 000000 000000 000000 
00000000020 000000 000000 000000 000000 
00000000021 000000 000000 000000 000000 
00000000022 000000 000000 000000 000000 
00000000023 000000 000000 000000 000000 
00000000024 000000 000000 000000 000000 
00000000025 000000 000000 000000 000000 
00000000026 000000 000000 000000 000000 
00000000027 000000 000000 000000 000000 
00000000030 000000 000000 000000 000000 
00000000031 000000 000000 000000 000000 
00000000032 000000 000000 000000 000000 
00000000033 000000 000000 000000 000000 
00000000034 000000 000000 000000 000000 
00000000035 000000 000000 000000 000000 
00000000036 000000 000000 000000 000000 
00000000037 000000 000000 000000 000000 

Exchange mode (I Exchange I) displays exchange information: 

Memory - Absolute 

ADX OOOOOOOOO~OOOO 
P OOOOOOOOOOa AO 000000 000000 000000 000000 50 000000 000000 000000 000000 
PN 000 Al 000000 000000 000000 000000 51 000000 000000 000000 000000 
XA 0000000 A2 000000 000000 000000 000000 52 000000 000000 000000 000000 
EXO 0000000 A3 000000 000000 000000 000000 53 000000 000000 000000 000000 
EXl 0000000 A4 000000 000000 000000 000000 54 000000 000000 000000 000000 
EX2 0000000 A5 000000 000000 000000 000000 55 000000 000000 000000 000000 
EX3 0000000 A6 000000 000000 000000 000000 56 000000 000000 000000 000000 
EX4 0000000 A7 000000 000000 000000 000000 57 000000 000000 000000 000000 

CN 000 VL 000 MODES 000 BDD 5CE TRI ESL BDM MM STAT5 00 VNU FPS WS BML 

1M 000000 IRP IUM IFP lOR IPR FEX IBP ICM IMC IRT lIP 110 IPC IDL IMI FNX lAM 
IF 000000 RPE MEU FPE ORE PRE EEX BPI MEC MCU RTI Iep 101 PCI DL MIl HEX AMI 

LATa RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LATl RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT2 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT3 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT4 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT5 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT6 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT7 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 

Instruction mode (! Instruction I) decodes the memory into instructions. 
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s9 Memory - Absolute 

OOOOOOOOOOa Iilooooo ERR 
OOOOOOOOOOb 000000 ERR 
OOOOOOOOOOc 000000 ERR 
OOOOOOOOOOd 000000 ERR 
0000000001 a 000000 ERR 
0000000001b 000000 ERR 
0000000001c 000000 ERR 
0000000001d 000000 ERR 
0000000002a 000000 ERR 
0000000002b 000000 ERR 
0000000002c 000000 ERR 
0000000002d 000000 ERR 
0000000003a 000000 ERR 
0000000003b 000000 ERR 
0000000003c 000000 ERR 
0000000003d 000000 ERR 
0000000004a 000000 ERR 
0000000004b 000000 ERR 
0000000004c 000000 ERR 
0000000004d 000000 ERR 
0000000005a 000000 ERR 
0000000005b 000000 ERR 
0000000005c 000000 ERR 
0000000005d 000000 ERR 
0000000006a 000000 ERR 
0000000006b 000000 ERR 
0000000006c 000000 ERR 
0000000006d 000000 ERR 
0000000007a 000000 ERR 
0000000007b 000000 ERR 
0000000007c 000000 ERR 
0000000007d 000000 ERR 

4. Choose the size of the display window from the Size @). This affects 
only the memory and instruction mode windows. The following 
window sizes are available: 

Size 

Small 
Medium 
Large 
X-Large 

Description 

The window displays 108 words. 
The window displays 208 words. 
The window displays 408 words. 
The window displays 1008 words. 

5. Choose the font size you want to display in the window from the 
Font @). The following font sizes are available: 

Size 

Small 
Medium 
Large 

X-Large 

Description 

The font size is small. 
The font size is medium. 
The font size is large. 
The font size is extra large. 

6. Change the starting address, if necessary, by double clicking on the 
Address field and typing a new value. 

7. Click on ( View... ). MME displays a Memory - Absolute window for 
the specified memory location. 
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If you want to change the Format, Memory, Exchange, Instruction, 

Window Size, or Window Font from the Memory - Absolute window, 
press the MENU mouse button and choose the menu item: 

Memory - Absolute 

00000000000 0000000 000000 000000 000000 
a a a a a a If'-''-w..;L.----LlJ..&U1JJ..LLL....LWLLLLLL ......... I.WJ.I0 a a a 00 a a a 
000000 Format 00 000000 
000000 00 000000 
000000 00 000000 
000000 Memory (Meta-M) 00 000000 
000000 00 000000 
000000 00 000000 
000000 Instruction (Meta-I) t> 00 000000 
000000 00 000000 
000000 00 000000 
000000 Window Size 00 000000 
000000 00 000000 
000000 Window Font 00 000000 
000000 00 000000 
00000000017 000000 000000 000000 000000 
00000000020 000000 000000 000000 000000 
00000000021 000000 000000 000000 000000 
00000000022 000000 000000 000000 000000 
00000000023 000000 000000 000000 000000 
00000000024 000000 000000 000000 000000 
00000000025 000000 000000 000000 000000 
00000000026 000000 000000 000000 000000 
00000000027 000000 000000 000000 000000 
00000000030 000000 000000 000000 000000 
00000000031 000000 000000 000000 000000 
00000000032 000000 000000 000000 000000 
00000000033 000000 000000 000000 000000 
00000000034 000000 000000 000000 000000 
00000000035 000000 000000 000000 000000 
00000000036 000000 000000 000000 000000 
00000000037 000000 000000 000000 000000 

For example, the following Memory - Absolute window appears if you 
choose the Exchange (Meta-X) format menu option: 

Memorv - Absolute 

ADX ooooooooo~oooo 
P OOOOOOOOOOa AO 000000 000000 000000 000000 50 000000 000000 000000 000000 
PN 000 A1 000000 000000 000000 000000 51 000000 000000 000000 000000 
XA 0000000 A2 000000 000000 000000 000000 52 000000 000000 000000 000000 
EXO 0000000 A3 000000 000000 000000 000000 53 000000 000000 000000 000000 
EX1 0000000 A4 000000 000000 000000 000000 54 000000 000000 000000 000000 
EX2 0000000 AS 000000 000000 000000 000000 55 000000 000000 000000 000000 
EX3 0000000 AS 000000 000000 000000 000000 56 000000 000000 000000 000000 
EX4 0000000 A7 000000 000000 000000 000000 57 000000 000000 000000 000000 

CN 000 VL 000 MODE5 000 BOD 5CE TRI E5L BDM HM 5TAT5 00 VNU FP5 W5 BML 

1M 000000 IRP IUM IFP lOR IPR FEX IBP ICM IMC IRT lIP 110 IPC IDL 1M! FNX lAM 
IF 000000 RPE HEU FPE ORE PRE EEX BPI MEC MCU RTI ICP 101 PCI DL MIl NEX AMI 

LATO RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT1 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT2 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT3 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT4 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 lL 00000000000000 
LATS RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LATS RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT7 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
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You can also change the window format (Format), data type (Memory 
or Instruction), window size (Window Size), or window font (Window 

Font) from this menu. 

In this example, instead of using the MENU mouse button, you may 
also use the diamond-shaped meta key (<> or ., depending on the 
type of keyboard you have) with one of several keyboard shortcuts. 
The following key combinations are shortcuts to the menu options: 

Key Sequence Function 

Meta-a 

Meta-n 

Meta-b 

Meta-p 

Meta-h 

Meta-w 

Meta-e 

Meta-t 

Meta-i 

Meta-x 

Meta-m 

Switches the display to address format 

Switches the display to nibble format 

Switches the display to byte format 

Switches the display to parcel format 

Switches the display to halfword format 

Switches the display to word format 

Switches the display to hexadecimal 
format 

Switches the display to text format 

Switches the display to instruction mode 

Switches the display to exchange mode 

Switches the display to memory mode 
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Perform the following procedure from the Memory - Absolute window to 
change data stored in mainframe memory: 

1. Use the arrow keys to move the cursor to the location in memory 
you want to change, or click on the location. In this example, parcel 
00000000005b was selected: 

lSi Memory - Absolute 

00000000000 000000 000000 000000 000000 
00000000001 000000 000000 000000 000000 
00000000002 000000 000000 000000 000000 
00000000003 000000 000000 000000 000000 
00000000004 000000 000000 000000 000000 
00000000005 000000 mooooo 000000 000000 
00000000006 000000 000000 000000 000000 
00000000007 000000 000000 000000 000000 
00000000010 000000 000000 000000 000000 
00000000011 000000 000000 000000 000000 
00000000012 000000 000000 000000 000000 
00000000013 000000 000000 000000 000000 
00000000014 000000 000000 000000 000000 
00000000015 000000 000000 000000 000000 
00000000016 000000 000000 000000 000000 
00000000017 000000 000000 000000 000000 
00000000020 000000 000000 000000 000000 
00000000021 000000 000000 000000 000000 
00000000022 000000 000000 000000 000000 
00000000023 000000 000000 000000 000000 
00000000024 000000 000000 000000 000000 
00000000025 000000 000000 000000 000000 
00000000026 000000 000000 000000 000000 
00000000027 000000 000000 000000 000000 
00000000030 000000 000000 000000 000000 
00000000031 000000 000000 000000 000000 
00000000032 000000 000000 000000 000000 
00000000033 000000 000000 000000 000000 
00000000034 000000 000000 000000 000000 
00000000035 000000 000000 000000 000000 
00000000036 000000 000000 000000 000000 
00000000037 000000 000000 000000 000000 
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2. Type the new value you want to place in the memory location. The 
entire word is highlighted, which enables you to change it. Use the 
arrow keys to move through the highlighted word. 

In the following example, 000217 was typed at memory location 
00000000005b: 

00000000000 
00000000001 
00000000002 
00000000003 
00000000004 
00000000005 
00000000006 
00000000007 
00000000010 
00000000011 
00000000012 
00000000013 
00000000014 
00000000015 
00000000016 
00000000017 
00000000020 
00000000021 
00000000022 
00000000023 
00000000024 
00000000025 
00000000026 
00000000027 
00000000030 
00000000031 
00000000032 
00000000033 
00000000034 
00000000035 
00000000036 
00000000037 

Memory - Absolute 

000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000217 o 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
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3. Press and release the Return key to update memory. This example 
shows memory location 00000000005b changed from 000000 to 
000217: 

~ Memory - Absolute 

00000000000 000000 000000 000000 000000 
00000000001 000000 000000 000000 000000 
00000000002 000000 000000 000000 000000 
00000000003 000000 000000 000000 000000 
00000000004 000000 000000 000000 000000 
00000000005 000000 000217 ~OOOOO 000000 
00000000006 000000 000000 000000 000000 
00000000007 000000 000000 000000 000000 
00000000010 000000 000000 000000 000000 
00000000011 000000 000000 000000 000000 
00000000012 000000 000000 000000 000000 
00000000013 000000 000000 000000 000000 
00000000014 000000 000000 000000 000000 
00000000015 000000 000000 000000 000000 
00000000016 000000 000000 000000 000000 
00000000017 000000 000000 000000 000000 
00000000020 000000 000000 000000 000000 
00000000021 000000 000000 000000 000000 
00000000022 000000 000000 000000 000000 
00000000023 000000 000000 000000 000000 
00000000024 000000 000000 000000 000000 
00000000025 000000 000000 000000 000000 
00000000026 000000 000000 000000 000000 
00000000027 000000 000000 000000 000000 
00000000030 000000 000000 000000 000000 
00000000031 000000 000000 000000 000000 
00000000032 000000 000000 000000 000000 
00000000033 000000 000000 000000 000000 
00000000034 000000 000000 000000 000000 
00000000035 000000 000000 000000 000000 
00000000036 000000 000000 000000 000000 
00000000037 000000 000000 000000 000000 

4. Repeat Steps 1 through 3 to change all desired memory locations. 

Using the Keyboard Accelerator 

26 

The keyboard accelerator offers another way to change memory and 
includes several other features. To access the keyboard accelerator, move 
the cursor inside a memory (or buffer) window and press the spacebar. 
The MME Keyboard Accelerator window appears: 

MME Keyboard Accelerator 

IIjOmmandS: Dump Enter Co Halt Load Save 8-7 RETURN 
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Dump Command 

HDM-xxx-O 
December 21, 1994 

The first command in the MME Keyboard Accelerator window is the Dump 
command. The Dump command dumps data to a file or the printer. When 
you type the letter D in the MME Keyboard Accelerator window, the window 
changes to: 

MME Keyboard Accelerator 

IIAddress: [0-7]· - SPACE when c~mplete 
IIDump Buffer to Printer Parcel _ I 

NOTE: By default, the Dump command dumps buffer data to the printer. 
To change this, press the backspace key several times to delete 
the default selections. Then, type the menu options you want. 

Enter the starting address of the data block you want to dump and press 
the spacebar; for example, if you wanted to dump the data block starting at 
100, you would enter 100: 

MME Keyboard Accelerator 

II length: [0-7]* - RETURN when ready 
IIDump Buffer to Printer Parcel 100'. I 

Then, enter the length of the data block you want to dump; for example, if 
you wanted to dump a block of 20008 parcels, you would enter 2000: 

MME Keyboard Accelerator 

Illength: [0-7]* - RETURN when ready 
IIDump Buffer to Printer Parcel 100 20001 

Finally, press the Return key to dump the data. The window displays the 
main menu again: 

MME Keyboard Accelerator 

Iliommands: Dump Enter Co Halt Load Save 0-7 RETURN 
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The second command in the MME Keyboard Accelerator window is the Enter~-~) 
command. The Enter command puts data into memory. When you type 
the letter E in the MME Keyboard Accelerator window, the window changes 
to: 

MME Keyboard Accelerator 

Enter:.eXchange. Auto. address [O-7]*[a-d] 
Enter • 

This window gives you three command options: 

• Type the letter X in the Enter menu to enter exchange data; this option 
is not implemented yet: 

!9 MME Keyboard Accelerator 

Not implemented.- RETURN when ready 
Enter eXchange • 

• Type the letter A in the Enter menu to start the automatic increment 
mode. Automatic increment mode enables you to enter data into) 
consecutive memory locations without having to manually enter each 
memory address. 

For example, if you wanted to enter data in consecutive memory 
locations starting at address 102, you would perform the following 
steps: 

1. Enter the address at which you want to enter the data and press 
return. For this example, you would enter 102: 

MME Keyboard Accelerator 

Data: RETURN wh~n complete. ESC to cancel 
Enter Auto 102 • I 

2. Enter the first data word and press return. For this example, 
you would enter 17777 177777: 

MME Keyboard Accelerator 

Data: RETURN when complet~~ ESC to cancel 
Enter Auto 102 17777 17777. 
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The window advances to the next memory location: 

jQ MME Keyboard Accelerator 

II Data: RETURN wh~n complete, ESC to cancel 
IIEnter Auto 103 • 

3. Enter the next data word and press return. Repeat this process 
to enter all of your data. When you have finished entering 
data, press the ESC key and automatic increment mode halts. 
The MME Keyboard Accelerator window returns to the main 
menu: 

jQ MME Keyboard Accelerator 

lIiommands: Dump Enter Co Hal t Load Save 0-7 RETURN 

• Type a number-letter combination in the Enter menu to enter a parcel 
address which indicates the memory address you want to change. 
For example, if you wanted to change parcel 1000b, you would enter 
1000b: 

jQ MME Keyboard Accelerator 

IIAddress: [~;7]*[a-d] - SPACE when complete 
IIEnter 1000b. 

Then, enter the data you want to write to memory; for example, if 
you wanted to enter 177777 177777 177777 177777, you would 
enter 177777 177777 177777 177777: 

jQ MME Keyboard Accelerator 

RETURN when ready 
Enter 1000b 177777 177777 177777 1777771 
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Press return to write the data to memory: 

!:9 Memory - Absolute 

1

1100000001000 000000 177777 177777 177777 
00000001001 077777 000000 000000 000000 
00000001002 000000 000000 000000 000000 

The window displays the main menu again: 

MME Keyboard Accelerator 

II£ommands: Dump Enter Co Halt Load Save 0-7 RETURN I 
!~ I 

The third command in the MME Keyboard Accelerator window is the Go 
command. The Go command runs the selected test sequences. When you 
type the letter G in the MME Keyboard Accelerator window, the window 
changes to: 

IRETURN when ready 
.Go I 

MME Keyboard Accelerator 

Press return to start the selected test sequences. The window displays the 
main menu again: 

!:9 MME Keyboard Accelerator 

II~ommands: Dump Enter Co Halt Load Save 0-7 RETURN 
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Halt Command 

Load Command 

HDM-xxx-O 
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The fourth command in the MME Keyboard Accelerator window is the Halt 
command. The Halt command halts the current running test sequences. 
When you type the letter H in the MME Keyboard Accelerator window, the 
window changes to: 

IRETURN when ready 
.Halt I 

MME Keyboard Accelerator 

Press return to halt the test sequences. The window displays the main 
menu again: 

~ MME Keyboard Accelerator 

IliommandS: Dump Ente r Go Halt Load Save 0-7 RETURN I 

The fifth command in the MME Keyboard Accelerator window is the Load 
command. The Load command loads a data set or sequence. When you 
type the letter L in the MME Keyboard Accelerator window, the window 
changes to: 

~ MME Keyboard Accelerator 

I load : Data. Sequence 
.load I 

This window gives you two options: 

• Type the letter D in the Load menu to load a data set; this command is 
not implemented yet. 

• Type the letter S in the Load menu to load a sequence; this command 
is not implemented yet. 
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The sixth command in the MME Keyboard Accelerator window is the Save 

command. The Save command saves a data set or sequence. When you 
type the letter S in the MME Keyboard Accelerator window, the window 
changes to: 

MME Keyboard Accelerator 

Isave: Data. Sequence 
Save I 

This window gives you two options: 

• Type the letter D in the Save menu to save the current data set; this 
command is not implemented yet. 

• Type the letter S in the Save menu to save the current sequence; this 
command is not implemented yet. 

Two options are available when you type a number in the MME Keyboard 

Accelerator window: you can display memory starting at the number, or 
you can convert the number from octal to parcel format or from parcel 
format to octal. 

• To display a specific memory location, type the location in the MME 

Keyboard Accelerator window and press the Return key. For example, 
to view memory location 5000, enter 5000: 

!9 MME Keyboard Accelerator 

[O-!l*[a-dJ. RETURN to change display. SPACE to convert 
5000. 

The Memory - Absolute window displays memory at location 5000: 

!9 Memory - Absolute 

00000005000 mOOOOO 000000 000000 000000 
00000005001 000000 000000 000000 000000 
00000005002 000000 000000 000000 000000 
00000005003 000000 000000 000000 000000 
00000005004 000000 000000 000000 000000 
00000005005 000000 000000 000000 000000 
00000005006 000000 000000 000000 000000 
00000005007 000000 000000 000000 000000 
00000005010 000000 000000 000000 000000 
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Return 
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The window displays the main menu again: 

MME Keyboard Accelerator 

Iliommands: Dump Enter Go Halt Load Save 0-7 RETURN 

• To convert a number from octal to parcel format or from parcel 
format to octal, type the number and press the spacebar. For 
example, to convert octal value 5000 to parcel format, enter 5000 and 
press the spacebar: 

sQ MME Keyboard Accelerator 

[O-?l*[a-dl. RETURN to change display. SPACE to convert 
5000. 

The parcel format equivalent is displayed: 

IRETURN when done 
.5000 = 01200al 

MME Keyboard Accelerator 

Press the Return key, and the window displays the main menu again: 

MME Keyboard Accelerator 

liolillands: Dump Enter Go Hal t Load Save 0-7 RETURN 

To close the MME Keyboard Accelerator window, press the Return key while 
the cursor is in the window. 
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The View -> Buffer command, as shown at the left, displays MME buffer 
data in a separate window. Use this command to verify the contents of 
specific MME buffer memory locations or to change the data stored in the 
MME buffer. This command displays the MME View Memory Setup 

window: 

~ MME View Memory setup 

Refresh (msec): 1000 [) -c:J= [) 
Format: 

Nibble Halfword Text I 
Byte Word A d dress I 

Parcel Hex 

Mode: 

I Memory I Exchange I Instruction I 
Source: 

Memory Buffer 

Size: ® Large 

Font: ® Medium 

Address: "",o.~ __ _ 

( View... ) 

This is the same window that appears when you choose View -> Memory, 
except I Buffer I is set as the Source, indicating MME will display MME 
buffer memory in a window. For more information about manipulating 
the MME View Memory Setup window, changing data stored in memory, and 
using the keyboard accelerator; refer to "View -> Memory" earlier in this 
section. 

NOTE: When you are viewing MME buffer data, the window header 
displays Buffer instead of Memory - Absolute: 

~ Buffer 

[)OOOOOOOOOO mOOOOO 000000 000000 000000 
00000000001 000000 000000 000000 000000 
00000000002 000000 000000 000000 000000 
00000000003 000000 000000 000000 000000 
00000000004 000000 000000 000000 000000 
00000000605 000000 000000 000000 000000 
00000000006 000000 000000 000000 000000 
00000000007 000000 000000 000000 000000 
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View-> Log 

Memory ... 
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-Report .. 
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Log .. 
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Notes ... 
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The View-> Log command, as shown at the left, displays the MME Log 

window: 

MME Log 
nR"-u~nn~i7ng~D~~C~h~ip~te~s~t--'p~a~tt~e7.rn~-'00~D'""Bln~r-------------------------,~ 

Write CPU = O. Read CPU = a 
Runni ng O~ Chi p test - Patte rn = OOD BITS 
Write CPU· 1. Read CPU· 1 

Runni ng O~ Chi P test - Pattern = 000 BITS 
Write CPU = 2. Read CPU = 2 

Running O~ Chip test - Pattern· 000 BI~ 
Write CPU = 3. Read CPU = 3 

Runni ng OHA Chi P test - Pattern = EVEN BITS 
Write CPU - O. Read CPU· a 
Runni ng OHA Chi P test - Pattern = EVEN BITS 
Wri te CPU = 1. Read CPU = 1 

Runni ng OHA chi p test - Patte rn = EVEN BITS 
Write CPU = 2. Read CPU = 2 

Runni ng OHA Chi P test - Patte rn = EVEN BITS 
Write CPU· 3. Read CPU· 3 

Runni ng OHA Chi P test - Pattern = WADOR 
Wri te CPU = O. Read CPU = a 
Runni ng D~ Chi P test - Patte rn = WAODR 
Write CPU = 1. Read CPU = 1 

Use this command to view any errors that occur while a test is running. 

The View -> Report command, as shown at the left, displays the error 
report information in the MME Report Display window. Use this command 
to view the error report generated by the memory or instruction buffer 
tests. This command displays the MME Report Display window: 

!9 MME Report Dlsplav 

View: I Differences Only I ( Clear Re port) 

Offset Expected (+000000) Actual (+000000) Difference (+000000) 

No Report Data Available. 
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This window displays the Expected, Actual, and Difference values for the 
contents of memory where differences are detected. These values are 
offset into the MME buffer, indicated by the value in parentheses. 

Use the I Differences Only 1 setting and (Clear Report) button in this window to: 

• Display only the addresses where differences occurred (I Differences Only I). 
• Clear the MME Report Display window of data (Clear Report). 

The View -> Notes command, as shown at the left, displays the MME 
release notes in a separate window. Use this window to read about any 
changes to MME for the current offline diagnostic release. 

Properties -> Environment -> ENV1 

'" Utilities" 

partition 

Resource Allocation ...... _ .. 

Enable Auto Apply 

The Properties -> Environment -> ENV1 command, as shown at the left, 
switches MME to environment 1. Use this command to switch to 
single-control-point testing. Refer to the "Environments 1 and 2" section 
later in this document for more information about environment 1. 

Properties -> Environment -> ENV2 

~- Utilities' 

EMV'; 
Partition ENVl .. 
Resource Allocation ... Confi-

= 
Enable Auto Apply Memc -.. - -

The Properties -> Environment -> ENV2 command, as shown at the left, 
switches MME to environment 2. Use this command to switch to 
multiple-control-point testing. Refer to the "Environments 1 and 2" 
section later in this document for more information about environment 2. 

Properties -> Partition 

36 

The Properties -> Partition command, as shown at the left, selects the 
logical partition in which MME will run. Use this command to select the 
partition you want to troubleshoot. MME scans the current configuration 
for available partitions and allows you to select only partitions that allow 
maintenance or concurrent maintenance. MME displays the available 
partitions in a menu attached to the Properties -> Partition menu command. 
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Properties -> Resource Allocation 

Environment 

Partition 

Enable Auto Apply 

I> 

I> 

The Properties -> Resource Allocation command, as shown at the left, 
changes the way MME performs. Use this command to specify which 
CPU is used to write and read memory and which debug level MME uses. 
This command displays the MME Resource Allocation window; choose the 
category you want to modify from the Category ffi . 

Specifying which CPU Writes and Reads Memory 

HDM-xxx-O 
December 21, 1994 

To specify which CPU writes to and reads from mainframe memory, 
choose CPU Allocation/Control from the Category: ffi. The MME Resource 

Allocation window changes to: 

!9 MME Resource Allocation 

Catagorv: ffi CPU Allocation/Control 

CPU Mode: 

11/0 CPU I 

~'<:I; ___ -

Click on the CPU you want to write to and read from memory. 
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Setting the Debug Level that MME Uses 

To specify which debug level MME uses, choose Miscellaneous from the 
Category: @). The MME Resource Allocation window changes to: 

19 MME Resource Allocation 

Catagorv: ~ CPU Allocation/Control 

,\uto ,"ssionment: I Di:;abid I Enab!.:,j I 
CPU Mode: 

11/0 CPU I 

The debug level specifies the amount of output that MME returns to the 
standard output window from which you started MME. Set the value to 0, 
1, or 2, where ° causes MME to display the least information and 2 causes 
MME to display the most information. Enter the number in the Debug 
Level field and press return, or click on the arrows to change the number in 
the field. 

Properties -> Enable Auto Apply 

'\J _"#''' H Uti 

Environment t> 

Partition t> 

Resource Allocation ... 

38 

The Properties -> Enable Auto Apply command, as shown at the left, enables 
automatic application of function or utility changes in compose mode. 

When the automatic apply function is enabled, you do not need to click on 
~ in the MME Compose Sequence Entry window to apply any changes 
you make to a function or utility. Instead, move the cursor to the MME 
base window or to the menu bar in the MME Compose Sequence Entry 
window to automatically apply the changes. 
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Properties -> Disable Auto Apply 

'" _Will- Uti 

Environment t> 

Partition t> 

Resource Allocation ... 

Utilities -> Pattern 

Utilities -> Find 

IIWUirest 

Pati:~:·!·!1 ... 
.n 

Configuration .. . 

Logic Monitor .. . 
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The Properties -> Disable Auto Apply command, as shown at the left, 
disables automatic application of function or utility changes in compose 
mode. 

When the automatic apply function is disabled, you must click on ~ in 
the MME Compose Sequence Entry window to apply any changes you make 
to a function or utility. 

This feature has not been implemented yet. 

The Utilities -> Find command, as shown at the left, searches MME buffer 
memory for a data pattern. Use this command to locate all occurrences of 
a data pattern within a block of memory. This command displays the MME 
Find Utility window: 

19 MME Find Utility 

Source: 

I Buffer I 
Search Boundary: 

I Byte I Parce I I Halfword I Word I 
Pattern/Mask Size: 

I Word I 
Pattern/Mask Format: 

I Byte I Parce I I Halfword I Word I 
Pattern: 
000000 000000 000000 000000. 

Mask: 
177777 177777 177777 1 77777 

Address: 00000000000000 

Length: 00000000000000 

Limit 00000000000000 

C Start ) (C.)<1tir;;:;;;) 
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The left side of the window contains the settings that specify the pattern to 
search for and the memory block to search. The right side contains a f_) 
scroll box that displays the memory locations that have the matching data 
pattern. The scroll box displays up to 256 entries; if more than 256 
matches are found, the message 256 matches, additional occurrences known 

to exist is displayed in the lower-left comer of the window. To view the 
additional occurrences, click on the (Continue) button. 

Perform the following procedure to manipulate this window. 

NOTE: Source defaults to I Buffer I because the Utilities -> Find command in 
environment ° searches MME buffer memory. 

1. Specify the Search Boundary you want to use. The search boundary 
indicates the stride used for checking memory. 

Click on I Byte I to check memory in byte increments, click on I Parcel I to 
check memory in parcel increments, click on I Halfword 1 to check 
memory in halfword increments, or click on I Word I to check memory 
in word increments. 

2. Specify the Pattern/Mask Size. The size indicates the size of the data 
pattern that is searched for and the mask that is used. 

The settings available depend on the Search Boundary setting. Click 
on I Byte I, I Parcel I, 1 Halfword I, or I Word I to select the pattern and mask size. 

3. Specify the Pattern/Mask Format. The format indicates the type of 
data pattern that is searched for and mask that is used. 

The settings available depend on the Pattern/Mask Size setting. Click 
on 1 Byte I, I Partel I, 1 Halfword I, or I Word 1 to select the pattern and mask format. 

4. Specify the data pattern you want to search for in the Pattern field. 

5. Specify the mask you want to use in the Mask field. The mask 
specifies which bits to compare. If a bit in the mask is set to 0, the 
bit position is not compared; if a bit in the mask is set to 1, the bit 
position is compared. 
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6. Specify the memory block you want to search (performing any two 
of the following actions automatically updates the third field): 

• Enter the first address of the memory block in the Address field, 
and press return. 

• Enter the length of the memory block in the Length field, and 
press return. 

• Enter the last address of the memory block in the Limit field, and 
press return. 

7. Click on ( start) to start the search. The ( Start) button changes to 
(Stop ), and MME updates the MME Find Utility window. 

19 MME Find Utility 

Source: 00000000010000 000000 000000 000000 000000 = 
I Buffer I 00000000010001 000000 000000 000000 000000 ~ 00000000010002 000000 000000 000000 000000 
Search Boundary: 00000000010003 000000 000000 000000 000000 

I Byte I Parce I I Halfword I Word I 00000000010004 000000 000000 000000 000000 
00000000010005 000000 000000 000000 000000 
00000000010006 000000 000000 000000 000000 

Pattern/Mask Size: 00000000010007 000000 000000 000000 000000 

I Word I 00000000010010 000000 000000 000000 000000 
00000000010011 000000 000000 000000 000000 
00000000010012 000000 000000 000000 000000 

Pattern/Mask Format: 00000000010013 000000 000000 000000 000000 

I Byte I Parce I I Halfword I Word I 00000000010014 000000 000000 000000 000000 
00000000010015 000000 000000 000000 000000 

Pattern: 00000000010016 000000 000000 000000 000000 
00000000010017 000000 000000 000000 000000 

000000 000000 000000 000000 00000000010020 000000 000000 000000 000000 

Mask: 
00000000010021 000000 000000 000000 000000 
00000000010022 000000 000000 000000 000000 

177777 177777 177777 1 77777 00000000010023 000000 000000 000000 000000 
00000000010024 000000 000000 000000 000000 

Address: 00000000010000 00000000010025 000000 000000 000000 000000 
Le n9th: 00000000010000 00000000010026 000000 000000 000000 000000 

00000000010027 000000 000000 000000 000000 
Limit: 00000000020000. 00000000010030 000000 000000 000000 000000 

00000000010031 000000 000000 000000 000000 
( Stop ) ( Continue ) 00000000010032 000000 000000 000000 000000 

00000000010033 000000 000000 000000 000000 = 
256 matches, additional occurances known to exist 

Click on (Stop) to stop searching for the pattern; click on (continue) 

to see the next set of entries if more than 256 occurrences exist. 

Utilities -> Configuration 

1 .. 110'. H 

Find ... 

logic Monitor ... 

HDM-xxx-O 
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The Utilities -> Configuration command, as shown at the left, starts the 
System Configuration Environment (SCE). Use this application to 
configure the mainframe. For more information about SCE, refer to the 
System Configuration Environment document, publication number 
HDM-xxx-O. 
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Utilities -> Logic Monitor 

Find." 

Config uration". 

Reset -> Channel 

ChJtln€1 

Server 

Con fig uration 

Reset -> Server 

I·W 
Channel 

tiM 
Configuration 

The Utilities -> Configuration command, as shown at the left, starts the Logic 
Monitor Environment (LME). For more information about LME, refer to 
the CRAY T90 Series LME User Guide document, publication number 
HDM-xxx-O. 

The Reset -> Channel command, as shown at the left, resets the FY driver. 

The Reset -> Sever command, as shown at the left, resets the server. This 
halts any sequence(s) that MME is executing. 

Reset -> Configuration 

Server 

42 

The Reset -> Configuration command, as shown at the left, causes SeE to 
reapply the configuration. 

NOTE: This command does not work if any partitions have an as 
owner. For more information about partition ownership, refer to 
the System Configuration Environment document, publication 
number HDM-xxx-O. 

Cray Research Proprietary 
Preliminary Information 

HDM-xxx-O 
December 21, 1994 

) 

) 



... ~ 

) 

) 
./ 

) 

eRA Y T90 Series MME Interface Reference 

Seq ue nee... See page 10 

Data... See page 11 

Sequence ... 

Save Data ... 

Delete ... See page 15 

Print 

Dump ... See page 17 
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Memory ... 

( Buffer ... 

log .. 

Report ... 

Notes ... 

) 

See page 13 

See page 14 

Root See page 16 

Screen See page 16 

Setup ... See page 16 

Seepage 19 

See page 34 

See page 35 

See page 35 

See page 36 

Mainframe Maintenance Environment (MME 1.0.2) - SIM [techsunl1 (76) 

(File \7) (View \7) (properties \7) (Utilities \7) 

Test Mode: 

Automatic 

Tests: 

1. BS Com m u n ication 

2. Con fig uration (Bas ic) 

3. Memory 

4. I/O Error Correction 

5. Logic Monitor 

(select All Modules) 

(Deselect All Modules) 

Error Mode: n~~ h ug Mo~h~~ 

I Stop On Channel Error I Er;~·lbi.:, Seq:!·} ~.'l·)d.:, 

(Reset \7) 

6. Exchange 

7. Instruction Buffers 

8. Config uration (A dv) 

9. M isce Ilaneous 

". ............ n .................................................. "" 

(, S!·} 1.:--: 1: :=~ II T.:-:~ l:~: ) 
". ................................................................ '" 

( D!·}~>:,i!·}::::t ~\ll T!·}~:t:~ ) 

Passes: 0 

Errors: 0 

I Stop On Sequence Error I ~ Manual 

Compose 

/ ..................... :~ .......................... .. 
; :.;(. ) " ... "" ................................................. '" 
: l·',".ll· ) ..... . .... 

Environment 0 

F:eset v 

Channel See page 42 

Server See page 42 

(Configuration) Seepage 42 

Inactive - I/O CPU 00 Environment ENVO - T4 - PO 16B/8S5/85 

Environment 

Partition 

( Resource Allocation ... ) See page 37 

Enable Auto Apply See page 38 

ENV1 See page 36 

E NV2 See page 36 

o Maintenance See page 36 

~IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII NOTE: This entry changes to Disable Auto Apply (see page 39). 

Figure 3. Environment 0 Menu Quick Reference 
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ENVIRONMENTS 1 AND 2 

This section describes the interface components and menu button 
commands for MME environments 1 and 2. 

Interface Components 

The environment 1 and 2 interfaces share an identical interface that is 
located in the base window. Use this interface to control testing in 
environment 1 and environment 2. Figure 4 shows the common interface. 
The paragraphs that follow the figure describe the components of the 
interface. 

Base Window Titlel Version Number 1 r Simulator or FEI Channel 

r Workstation or Channel Number 

Mal nframe Mal nte nante Env Iron ment (M ME 1.0.2) - S 1M [boyd] (14) Copy Number 

~ (View v) ~ (Properties v) (Utilities v) 

~ --------------- --------------- --------------- B ---------------
@D --------------- --------------- --------------- I::: 1 1---------------
~ --------------- --------------- --------------- I :::'~ 1---------------

~ ~:~~~~~~~~ ciD ~~~~~~~~~~ ~ ~~~~::~:~ ~ ~~~~~~~~~~: 
I2IJ --------------- [IJ --------------- D --------------- [2] --------------
Contyo! Pllinl:~: S.~l:tions: Co nlyo!: 

=:O_in_ts ....... ~~'1 
; r f~';-!')":~;l -j 

-_._-_._---_.j= . 

• I ,'ll I S':l(Kted I 
'--'T>'-~) 

Information Auto CPU - I/o CPU 00 E nv iron me nt E NV 1 - T4 - PO 16B/8SS/8S 

Sections Scroll Box 

Figure 4. Environments 1 and 2 Interface Components 

HDM-xxx-O 
December 21, 1994 
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Environments 1 and 2 

Base Window Title 

Version Number 

GRAY T90 Series MME Interface Reference 

The base window title displays the name of the program: Mainframe 

Maintenance Environment. 

The version number indicates the version of MME you are using. 

Simulator or FEI Channel 

The simulator or front-end interface (FEI) channel indicator shows MME 
is running with the simulator (indicated by SIM) or an FEI channel 
(indicated by FEI CHN 0 for channel 0, FEI CHN 1 for channell, or FEI 

CHN 2 for channel 2). 

Workstation Name or Channel Number 

Copy Number 

Menu Bar 

The workstation or channel number indicator lists the name of the 
workstation or the channel number on which MME is running. 

The copy number indicates the copy of MME you are using. To set the 
copy number, start MME with the - copy option. If you start MME with 
the default copy number of 0, the MME base window does not display a 
copy number. For more information about starting MME with the - copy 

option, refer to the CRAY T90 Series MME User Guide, publication 
number HDM-xxx-O. 

The menu bar contains six menu buttons: ~,( View v), ~, 

( Properties v), ( utilities v), and C Reset v). For descriptions of the commands 
accessible from these menu buttons, refer to "Menu Button Commands" 
later in this section. 

CPU Selection, Control Point, and Status Area 

46 

The CPU selection, control point, and status area is where you assign 
CPU(s) to control points and where MME displays status information for 
running control points. 
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HDM-xxx-O 
December 21, 1994 

To assign CPUs to the current control point, click on any of the CPU 
settings (00 through the available number of CPUs in the mainframe). 
The CPU setting is highlighted and the control point name is displayed 
next to the CPU setting: 

[££J 00 csr. t 

MME displays several types of status information for the CPUs; to change 
the status information displayed, press the MENU mouse button in this 
area. The following menu appears: 

00 csr. t 0 --------------- --------------- I ":'J 1---------------
Active CPU Display --------------- 1:;:1 1---------------
Control Point --------------- I ::::: 1---------------
Pass Cou nt (G lobal) --------------- I :::::: 1---------------
Pass Count (Section) --------------- I :::<; 1---------------

:==:_~:=:m', 7 _________ :::::: 00 ==::=:::::= ~ :::::::=:::::: 

The entries in this menu enable you to choose which status information is 
displayed: 

Control 

Pass Count (Global) 

Pass Count (Section) 

P Register 

CIP 

Description 

Displays the control point name 

Displays the pass count for all sections 

Displays the pass count for the current section 

Displays the current P register value 

Displays the current instruction parcel (CIP) 
register value 

The number shown to the left of the control point name is the control point 
copy number when several CPUs are assigned to a control point. A plus 
(+) next to the copy number indicates the master CPU for a group of CPUs 
assigned to a multiple-CPU control point. The master CPU is the first 
CPU assigned to the control point. 
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GRAY T90 Series MME Interface Reference 

MME also automatically displays status information for executing control 
points. This information includes interrupt flags (in environments 1 and ~-~) 

2), which are indicated by IFLAG, as shown in Figure 5, and controller " 
status messages (in environment 2 only), which are indicated by CSTAT, 

as shown in Figure 6). 

, ~~ I ~~:~~~-------
~ ---------------
~ ---------------o --------------
~ ---------------o --------------- --------------- [JIJ --------------- ,,"," ---------------o --------------- --------------- 0 --------------- 0 ---------------

Figure 5. Example Interrupt Flag 

~ IMiiM'" lJ2J --------------- I :::) 1---------------
EJ--------------- 0 --------------- ---------------
~: ~~~~~~~~~~~~~~~ ~ ~~~~~~~~~~~~~~~ 

--------------- b±! ---------------
---------------~ ---------------
--------------- IJD --------------- ---------------~ ---------------o --------------- 0 --------------- 0 --------------- [ill ---------------

Figure 6. Example Controller Status Message 

Table 1 describes the interrupt flags. 

Table 1. Interrupt Flags 

Interrupt Flag Description 

AMI 

BPI 

DL 

EEX 

FPE 

ICP 

101 

MCU 

Address multiply range error interrupt 

Breakpoint interrupt 

Deadlock 

Error exit (000 issued) 

Floating-point error 

Internal CPU interrupt 

Input/output (1/0) interrupt 

MCU interrupt 

Cray Research Proprietary 
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Status Message 

CIB 

CNR 

CRE 

DMP 

HTM 

HTS 

INF 

IUC 

LEBi 

LBEI 

LBEx 

LES 

LLEi 

LLEI 

HDM-xxx-O 
December 21,1994 

Table 1. Interrupt Flags (continued) 

Interrupt Flag Description 

MEC Correctable memory error 

MEU Uncorrectable memory error 

Mil 001 ij does not equal zero or 033 instruction interrupt 

NEX Normal exit (004 issued) 

PCI Programmable-clock interrupt 

PRE Program range error 

RPE Register parity error 

RTI Real-time interrupt 

Table 2 describes the controller status messages. 

Table 2. Controller Status Messages 

Description 

The control point attempted to clear a cluster that is not in the data space. 

The control point attempted to clear a cluster that was not reserved. 

A channel reservation error occurred: at least two CPUs were in the channel 
reservation code at the same time. 

The control point dumped the CPU's registers and idled the CPU in the 
controller's idle loop. 

The control point stopped and requested all CPUs to hang. 

The control point stopped at the request of another CPU. 

The CPU exchanged to the controller with no interrupt flags. 

An interrupt on unreserved channel occurred. 

The logical base from dmpAREA is less than the starting logical base [for an 
exchange using IEXP (hDIFM)]. 

The logical base from dmpAREA is less than the starting logical base [for a 
restart CPU load (cLOAD) function]. 

The logical base from dmpAREA is less than the starting logical base [for an 
exchange using an XP table request (hXEXP)]. 

The control point stopped on a logical address translation (LAT) table fault. 

The logical limit from dmpAREA is less than the starting logical limit [for an 
exchange using IEXP (hDIFM)]. 

The logical limit from dmpAREA is less than the starting logical limit [for a 
restart CPU load (cLOAD) function]. 
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Status Message 

LLEx 

MEl 

MES 

MWS 

OK 

PEl 

PES 

REO 

RES 

SRE 

TRP 

WTS 

WTW 

XNRi 

XNRI 

XNRx 
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Table 2. Controller Status Messages (continued) 

Description 

The logical limit from dmpAREA is less than the starting logical limit [for an 
exchange using an XP table request (hXEXP)]. 

The control point stopped on an invalid memory error. 

The control point stopped on a memory error (used MRSTOP). 

MME sent a bad request. 

A normal operation occurred. 

The control point stopped on an invalid parity error. 

The control point stopped on a parity error (used MRSTOP). 

The CPU performed a dump and idle, but the mwsTOcpu request was not a 
dump request, or there was no idleSTAT and no mwsTOcpu request. 

MWS request was cleared before a register dump was completed. 

A cluster reservation error occurred: at least two CPUs were in the cluster 
reservation code at the same time. 

An invalid exchange occurred. 

The control point stopped due to a dump and wait/resume request. 

The control point is waiting due to a dump and wait/resume request. 

An exchange occurred using a cluster that was not reserved [for an exchange 
using IEXP (hDIFM)]. 

An exchange occurred using a cluster that was not reserved [for a restart CPU 
load (cLOAD) function]. 

An exchange occurred using a cluster that was not reserved [for an exchange 
using an XP table request (hXEXP)]. 
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Controls 

HDM-xxx-O 
December 21, 1994 

The controls are buttons and settings that enable you to start or stop 
running control points and reload control points. 

Button/Setting Description 

( Go ) 

( Halt I> ) 

( Reload) 

Performs the control button command on all control 
points assigned CPUs. 

Performs the control button command on the selected 
control points. 

Starts the control points. 

Stops the control points. Three options are available: 

Halt -> No Dump sets Master Clear on the 
CPU(s). This halt option is not available for 
environment 2. 

Halt -> Exchange Dump sets Master Clear on 
the CPU(s) and uses a maintenance channel feature 
to perform an exchange dump. This halt option is not 
available for environment 2. 

Halt -> Register Dump sets Master Clear on the 
CPU(s), restarts the CPU(s), builds a starting 
exchange package (SEXP) that points to dump 
memory, and dumps registers at memory location 
dmpAREA. 

For detailed information about what happens when 
you choose one of the halt options, refer to the 
CRAY T90 Series MME User Guide, publication 
number HDM-xxx-O. 

Reloads the control points. 

Resumes execution of a holding control point. This 
button appears when a control point hold request 
executes. 
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Configuration Information 

The configuration information displays the current MME environment 
(environment 1 or 2) and the current configuration data (mainframe type; 
partition where MME is running; and number of sections, subsections, and 
banks). The System Configuration Environment (SCE) provides this 
information. 

For example, the following configuration information indicates MME is in 
environment 1 (Environment ENV1); the mainframe type is a CRAYT94 
system (T4); MME is running in partition 0 (PO); and the configuration 
consists of 16 banks (168), 8 subsection (8SS), and 8 sections (8S): 

Environment ENV1 - T4 - PO 168/855/85 

The configuration information component displays the following 
mainframe types: 

Test(1x1) 
Test(1x4) 
Test(4x4) 

T4 
T16 

T32 

Description 

A tester with 1 CPU and 1 memory module 
A tester with 1 CPU and 4 memory modules 
A tester with 4 CPUs and 4 memory modules 
A mainframe with 4 CPUs 
A mainframe with 16 CPU s 
A mainframe with 32 CPU s 

Sections Scroll Box 

52 

The Sections scroll box displays the sections available to run for the 
current control point. This scroll box shows the section number; the file 
containing the section; a letter indicating the section is a single-CPU (S) or 
multiple-CPU (M) section; and numbers indicating the section can be run 
in environment 1 (1), environment 2 (2), or environments 1 and 2 (1/2). 

When you select a control point in the Control Points scroll box, the 
Sections scroll box displays the test sections. Sections that are selected to 
run when ( Go ) is clicked have a check mark (.{) next to them. To 
select or deselect a section, move the mouse pointer over the section and 
click the EXTEND mouse button. To select or deselect all sections, move 
the mouse pointer over the Sections scroll box, and press the MENU 
mouse button. The following menu appears. 
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Status Information 

HDM-xxx-O 
December 21, 1994 

Sections· 
Sections: 

~ 00 cmtO 

I 01 cmtO ( select All ) 

02 cmtO Dese lect A II 

03 cmtO • I 04 cmt04.t S 1 

= 

Choose Select All to select all sections of the test; choose Deselect All to 
deselect all sections of the test. 

To select or deselect sections for testing while control points are running, 
use the EXTEND (for single sections) or MENU (for all sections) mouse 
buttons. 

To choose the current section, move the mouse pointer over the section 
and click the SELECT mouse button; a box surrounds the section to 
indicate it is the current section, and the section is loaded into mainframe 
memory. 

The status information displays the current state of the MME program, 
using the following messages: 

Message 

Auto CPU 

I/OCPU## 

1/0 Disabled 

Description 

Enables automatic assignment of control points. 
When a control point is loaded, MME 
assigns a system-selected CPU to it. For 
more information about changing this option, 
refer to the "Properties -> Resource Allocation" 
description later in this section. 

The CPU specified by ## is the 1/0 CPU. 

No CPU is set as the 1/0 CPU. 
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Control Points Scroll Box 

54 

The Control Points scroll box shows the current control point loaded in 
MME. If you press the MENU mouse button in this scroll box, the 
following menu appears: 

Control Points: 

I" 00 cmt.t rel Control Points: 
Select All 

Deselect All 

( View By !» 

Choose Select All to select all control points. Choose Deselect All to 
deselect all control points. Choose View By -> Filename to see the control 
point indicated by its filename: 

Control Points: 

II;::,,;:. :::;0;:0 =c=;mt::. t;:::=r::e~1/;:;di~a~9 .:;:cp;01;:;/;cm:;-]1 ~ 

I u-__________________ ~= 

. Choose View By -> Location to see the control point listed by its location 
in mainframe memory: 

Control Points: 

..,.1" __ 0_0 _cm_t_. t __ --"O-'-'oo_oo_o_oo_oo_oo_o_o --,I ~ 

I 
'-----------------------'= 
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Menu Button Commands 

The menu buttons contain commands you use to manipulate MME 
environments 1 and 2. This subsection describes what each command 
does and how to use each menu button command. Figure 8 on page 111 
and Figure 9 on page 112 show all available menu button commands for 
environments 1 and 2, respectively. 

File -> Load -> Data 

.'1, 
Control Point ... 

Save 

La;;·)l!t ... 

The File -> Load -> Data command, as shown at the left, loads a data set 
into mainframe memory. Use it to re-create a specific data set for testing 
without having to manually enter it each time. This command displays the 

Delete... _________. MME Load/Save Data window: 
Print I> IT "-
Dump ... 

~~~~~~~~~ ~~~~ 
--------- l1: ' TJ...., 7 

oQIJ 
MME Load/Save Data 

Save File: ____ _ 

Save Address: 00000000000000 

Save Length: 00000000000000 @D 

78 files found 

Perform the following procedure to manipulate this window: 

1. Select the data Mode. Click on I Word I to use a word load address 
and length or I Parcel I to use a parcel load address and length. The 
Load Address and Load Length fields change to the specified format. 

2. Specify the Load Base. Click on I Absolute I to load the data at a fixed 
location in memory or I Relative I to load the data relative to the base 

HDM-xxx-O 
December 21,1994 

location in memory of the current control point section. 
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3. Change the directory, if necessary, by choosing a directory from the 
Load Directory @) or by entering the directory in the Load Directory 
field. The following directories are available in the Load 
Directory @) : 

Directory 

Release 

User 

Alpha 

Utility -> Release 

Utility -> Alpha 

Description 

Diagnostic program files from the current 
offline diagnostic release 

Files you have saved or modified 

Prereleased diagnostic program files that are 
being tested and have not been released 

Utility files from the current offline diagnostic 
release " '" 

Prereleaseq, ~tilities ili~t are being tested and 
have net been released 

\, ' . .?:: ,~ 

4. In the Load Files scioli'b¢x;,cli~k on"ih~'data.'file you want to load. 
The Load Ty~~~try'display~'~lja, type 'bf data is contained in the 
file. The ·~o~d Kength field dl~plays the length of the chosen data file . 

.... t, .~~\"\:Jt. ~i."" .":> ~ .. ~\. ;.~."~~ ;Ii: 

5 .,,.tiithe Load Addfes's field; enter the address at which the data should 
'-"'1\'~. ~ ... :':( - "'. '; :._', .... , " .. 't .. , -~>}. 

'be loadeci.' Jb.~:J'L<)a:a) button activates. 
p . ;;'.c. .;{ ,/)' .;{; ... ";. .. : '!~ 

"6" (!lick'f>~(~oad); MME loads the data at the specified address. 
<:i "'h ~3~" 
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File -> Load -> Control Point 

HDM-xxx-O 
December 21, 1994 

The File -> Load -> Control Point command, as shown at the left, loads a 
control point to use for testing. Use it to access control points from the 
current offline diagnostic release, to access prerelease versions of the 
control points, and to access user-created or modified control points. This 
command displays the MME Load Control Point window: 

MME Load Control Point 

Dir: @) rel/diag.ep02/. 

Files: 

asb.t/ 
asf.t/ 
btv.t/ 
btv.t.old/ 
eaeh.t/ 
ect.tI 
ect.t.old/ 
emp.t/ 
emtt/ 
emt.t.old/ 
csr.t/ 
ctt.t/ 
eft.t/ 
epU/ 
fbt.t/ 
fbt.t.old/ 
fpb.t/ 

= 

~ 

= 

N,<\m .... : 

Revision: 
1)(\tI~: 

Timf~: 

TYPf~: 

BaSf~: 

Silf~: 

limi(: 

----_._---_. __ ._. __ . 
._--_._--_._-_. __ . __ .,-

Mode: Insert Single 

Insert Multiple 

Replace Single 

Replace All 

Copies: .1-. ___ f3 

34 files fou n d 

This window displays the control points you can load under MME. The 
directory path displayed to the right of the Dir @) indicates the current 
directory. All control points are divided into sections, which are files 
contained in subdirectories of the current directory. The Files scroll box 
displays the subdirectories that hold the control point sections. When you 
load a control point, the Sections scroll box displays the sections. 

Perform the following procedure to manipulate this window: 

1. Change the directory, if necessary, by choosing a directory from the 
Dir @) or by entering the directory in the Dir field. The following 
directories are available in Dir @) : 

Directory Description 

Release 

User 

Diagnostic program files from the current 
release 

Files you have saved or modified 
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Directory 

Alpha 

Utility -> Release 

Utility -> Alpha 

GRAY T90 Series MME Interface Reference 

Description 

Prereleased diagnostic program files that are 
being tested and have not been released 

Utility files from the current release 

Prereleased utilities that are being tested and 
have not been released 

NOTE: A.t extension indicates a control point assembled in Triton 
mode. A.c extension indicates a control point assembled in C90 
mode. 

2. Click on the control point you want to load. The following 
description information is updated: 

Field 

Name 

Revision 

Date 

Time 

Type 

Base 

Size 

Limit 

Description 

Name of the control point 

Revision level of the control point 

Date the control point was assembled 

Time the control point was assembled 

Diagnostic, Utility, or Loop indicator 

Address where the control point is loaded 

Octal size of the control point code that is 
loaded into memory 

Last available address for the control point 

3. Change any or all of the Base, Size, and Limit values, if necessary. 
When you change any two of these values, this window updates the 
third automatically. 

• Base indicates the address in memory where the control point is 
loaded. Normally, this should be zero. 

• Size indicates the size of the control point. Normally, this 
should be the default value. 

• Limit indicates the maximum address for the control point. 
Normally, this should be the default value. 
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4. Change the Mode setting to specify how MME loads the control 
point. Click on one of the following settings: 

Setting 

I Insert Single 

I Insert Multiple I 

I Replace Single I 

Description 

Loads a new control point. 

If a control point is already loaded in 
environment 1, an error message appears that 
indicates no memory is available because 
usually only one control point can be loaded at 
a time in environment 1. 

If a control point is already loaded in 
environment 2, the new control point is also 
loaded if enough memory is available. 

Loads multiple copies of the control point you 
specify. This option is for environment 2 only. 
In the Copies field, specify the number of 
copies to load. 

Replaces a loaded control point with the control 
point you specify; use this option to replace a 
control point that is already loaded. 

I Replace All Replaces all loaded control points with the 
control point you specify This option is for 
environment 2 only. 

5. Click on ( load ); MME loads the specified control point. 

NOTE: The ( Info... ) button displays the information file for the control 
point. This file indicates the available sections and the memory 
requirements for the control point. 

File -> Load -> Test List 

This feature has not been implemented yet. 

File -> Load -> Layout 

HDM-xxx-O 
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This feature has not been implemented yet. 
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File -> Save -> Data 

__ Control Point .. , 

Delete .. 

Print [>~--""''''l'' 

--------- [} 
n...Du .. m~p .... ,..a-_________ f1 

60 

The File -> Save -> Data command, as shown at the left, saves a data set so 
you can reuse it. Use it to re-create a specific data set for testing. This 
command displays the MME Load/Save Data window: 

MME Load/Save Data 

Mode: I Word I Parcel I 
Load Base: I A bsol ute I Re latiYe I 

Load Directory: @) usr/data/. 

Load Files: 
bg 
bg1 
bg2 
bob 

~ 
I L--_____ .....J'= 

Loall r\lP!~: r.'i,·!r, i: ,io? 

Load Address: 00000000000000 

l(I«<I Length: ~5:.~~~~i:N'(~(.:~~~~. "-l.(.ad) 

Save Base: I Absolute I RelatiYe I 
Save Directory: =u5=r!.;::.:da=ta==--__ 

Save File: ____ _ 

Saye Address: 00000000000000 
Save Length: 00000000000000 ( Saye ) 

78 files fou n d 

Perform the following procedure to manipulate this window: 

1. Select the data Mode. Click on I Word I to use a word save address 
and length or I Parcel I to use a parcel save address and length. The 
Save Address and Save Length fields change to the specified format. 

2. Specify the Save Base. Click on I Absolute I to save the data from an 
absolute memory location (based on a starting address of 0), or click 
on I Relative I to save the data relative to the base address of the current 
control point section. 

3. Specify a different directory in the Save Directory field, if necessary. 

4. Specify the name of the file in the Save File field. 

5. Specify the starting address of the data block you want to save in the 
Save Address field. 

6. Specify the length of the data block you want to save in the Save 
Length field. 

7. Click on (saye); MME saves the specified data set. 
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File -> Save -> Control Point 

Control Point .. 

Delete.. l:;'~·"it ... 

Print t> 

---------~ 
--------- 115 Dump ... 

HDM-xxx-O 
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The File -> Save -> Control Point command, as shown at the left, saves a 
control point you have modified. Use it to create customized control 
points for troubleshooting. This command displays the MME Save Control 

Point window: 

!9 MME Save Control Point 

Mode: I All Sections (User Changes Only) I 
I Current Section (Memory Image) I 

Directory: "'-'us=r/-=.d=lag"--___ _ 
File: newcl\. 

Name: fptt fo!)y: (-(-
Revision: TR14.1 

Type: Diagnostic [J :;.:<"~ {,:' !..)(.r.-

Memory MIN: 00000000100000 

Memory MAX: ~ All Available 
(:(:(:( :(:( :e:(;(:(:(;(:( :(: ----_._ .. _-_._--_. __ ... -

Sections: 
r--- = Section: 001 

00 ~ Origin: _______ . ____ ._ .... _ .. 

I ~~ I l!J l.ength: ~~~c.:~:~.:~:.~§.:~~-.~: 
03 Min Pass: 00000000001 
04 Max Pass: 37777777777 

05 
( Save) 

Perform the following procedure to manipulate this window: 

1. Specify the Mode. Click on I All sections (User Changes Only) I to save the changes 
you have made; this creates a new information file that contains the 
user changes for the control point (minimum and maximum 
memory) and all sections (minimum and maximum pass counts) and 
makes hard links to the original files for the sections. 

Click on I Current Section (Memory Image) I to save a memory image of the current 
control point section; this creates an information file that contains 
the minimum and maxim~m memory and minimum and maximum 
pass counts for the section. You may adjust the length of the 
memory image to save data outside the normal range for the section; 
this is useful for capturing diagnostic-created data (for example, a 
diagnostic-generated instruction block). 

2. In the Directory field, enter the name of the directory in which you 
want to save the control point. 
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3. In the File field, type the name of the file in which you want to save 
the control point; the Name field shows the current name of the 
control point, the Revision shows the revision of the offline 
diagnostic, and the Type field indicates the type of file. 

NOTE: To save a diagnostic as a loop so MME will not configure the 
diagnostic when loading it, click on the Save As Loop check box. 

4. In the Memory MIN field, specify the minimum amount of memory 
the control point can be assigned. If the specified amount of 
memory is not available, the control point will not load when you 
use the File -> Load -> Control Point command. 

5. In the Memory MAX field, specify the maximum amount of memory 
the control point requires, or click in the check box next to All 
Available to specify that the control point should use all available 
memory. 

6. If you are saving a loop, specify, in the Origin field, the starting 
address of the loop in mainframe memory. 

7. If you clicked on I Current Section (Memory Image) I, specify the length of the 
memory image you want to save in the Length field. 

8. If you clicked on I All Sections (User Changes Only) I, click on the section, in the 
Sections scroll box, for which you want to change the minimum and 
maximum pass counts. Repeat Steps 8 through 10 for each section 
you want to modify. 

9. In the Min Pass field, specify the minimum number of passes the 
selected section must complete before MME can load a different 
control point section. 

10. In the Max Pass field, specify the maximum number of passes the 
section should complete before MME disables testing of the section. 

11. Click on ( save); MME saves the modified control point 
information. 

File -> Save -> Test List 

This feature has not been implemented yet. 

File -> Save -> Layout 
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This feature has not been implemented yet. 
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File -> Delete 

Load l> 

Save l> 

Delete .. , 

Print l> 

·"'ii"& 

HDM-xxx-O 
December 21,1994 

The File -> Delete command, as shown at the left, deletes file(s) you no 
longer need. Use this command to delete unwanted files from the MME 
user directories stored on the maintenance workstation (MWS). This 
command displays the MME Delete File window: 

19 MME Delete File 

~ usr/diag/. 

Files: 

addrp/ 
epUmp/ 
find/ 
forcemec/ 
fpblp/ 
fpblpl/ 
fpblp2/ 
fpblp3/ 
fpmbg/ 
fpmbgl/ 
fpmbg2/ 
fpmbg3/ 
fprbg/ 
fpt3lp/ 

L-_______ -'= 

(-D~-'') 

39 files found 

Perform the following procedure to manipulate this window: 

1. Change the directory, if necessary, by: 

• Entering the directory in the ( Dir: v) field and pressing the return 
key, or 

• Choosing the directory from the C Dir: v) button. The following 
user directories are available: 

Directory 

usrl* 
usr/cmd 

usr/tst 
usrllst 

usrlseq 

Description 

All user directories 
User command buffers 
User test lists 
User listings 
User sequences 

2. Click on the file you want to delete. 

3. Click on ( Delete). MME deletes the file. 
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File -> Print -> Root 

!fml (View v) 

load t> 

Save t> 
--------
--------

Delete ... -------. 

- ... 
Screen 

Dump ... 

l~_ 
Setup ... 

The File -> Print -> Root command, as shown at the left, prints an image of 
everything contained in the root window, including the MME base 
window. 

File -> Print -> Screen 

r=;:==;:~V=ie=w=v:: The File -> Print -> Screen command, as shown at the left, prints an image 
of a window or an icon. 

Save t> 

Delete ... When you choose this command, the cursor becomes a plus symbol. 
Move the cursor to the window or icon to print, and click any mouse 
button. 

NOTE: This command does not print an image of the MME base 
window. To print an image of the MME base window, use the 
File -> Print -> Root command. 

File -> Print -> Setup 
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The File -> Print -> Setup command, as shown at the left, enables you to 
edit the commands that control how MME prints data for the 
File -> Print -> Root and File -> Print -> Screen commands. This command 
displays the MME Print Setup window: 

MME Print Setup 

Print Root Command: (xwd -root I xpr -device liet -rv IIp)o\ 
Print Screen Command: (xwd -frame I xpr -device Ijet -rv IIp)& 

( Save Commands To File ) 
( Reset Commands From File) 

( Reset Commands From Defaults ) 

Modify the commands in the Print Root Command and Print Screen 

Command fields to change how MME prints. For more information about 
the UNIX xwd, xpr, and Ip commands used in the print processes, refer 
to the UNIX online manual (man) pages (enter man xwd, man xpr, or 
man lp at a UNIX command prompt). 
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File -> Dump 

Load I> 

Save I> 

Delete ... 

Print I> 

.",",,& 

HDM-xxx-O 
December 21,1994 

Use the buttons in the MME Print Setup window to: 

• Save the current printer setup commands for later use 
«( Saye Commands To File ) ). 

• Load the printer setup commands you saved previously 
« Reset Commands From File )). 

• Load the default printer setup commands that the MME program 
provides «( Reset Commands From Defaults) ). 

The File -> Dump command, as shown at the left, sends a copy of 
mainframe data to a file or the printer. Use this command to create a 
permanent record of the data so you can analyze it later. This command 
displays the MME Dump Setup window: 

s9 MME Dump setup 

Mode: 

I File I Pri nter II Com press 

Dir(!ctoYy: i2:L ___ ._. ____ . __ .. 

Format: @) Paree I 

Base: I Absolute I Relative I 
Start Address: 00000000000. 

Length (words): 00000000000 

End Address: 00000000000 

Comments: 

( Dump) 

Perform the following procedure to manipulate this window: 

1. Specify the Mode. Click on ~ to output the data to a file, or click 
on I Printer I to output the data to the printer. 
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2. 

3. 

4. 

S. 

6. 

7. 
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Click on I Compress I to compress the output of the File -> Dump 

command. This reduces the size of the data listing by replacing 
repeated lines with a statement similar to Last line repeated 077 (63) 

times. 

If data is being dumped to a file, specify the directory in the Directory 

field and the file in the File field. 

Choose the display format of the data from the Format @). The 
following formats are available: 

Format Description 

Nibble Nibble data 
Byte Byte data 
Parcel Parcel data 
Halfward Halfword data 
Word Word data 
Hexadecimal Hexadecimal data 
Address Address data 
Text Text data 
Exchange (NI) Exchange data (not implemented) 
Instruction Instruction data 

Specify the Base. Click on I Absolute I to dump data from an absolute 
memory location (based on a starting address of 0) or I Relative I to dump 
data relative to the base address of the current control point section. 

Specify the data block you want to dump by completing any two of 
the following actions (the third field is automatically set using data 
from the other two fields): 

• In the Start Address field, enter the starting address of the data 
block to dump and press return. 

• In the Length (words) field, enter the length (in words) of the 
data block and press return. 

• In the End Address field, enter the ending address of the data 
block you want to dump and press return. 

Click in the Comments scroll box and type any comments you want 
to include with the data. For example, you might specify that the 
data is from of a specific test or that you created it on a specific date. 

Click on ( Dump ); MME sends the specified data to the printer or 
file. 
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View -> Memory 

Error log ... 

Runtime Information I> 

listing I> 

Notes ... 

HDM-xxx-O 
December 21, 1994 

The View -> Memory command, as shown at the left, displays mainframe 
memory in a separate window. Use this command to verify the contents 
of specific memory locations or to change the data stored in memory. 
This command displays the MME View Memory Setup window: 

19 MME View Memory Setup 

Refresh (msee): 1000 D ~ D 

Format: 

Nibble Halfword Text I 
Byte Word A d dress I 

Parcel Hex 

Mode: 

I Me mory I Exchange II nstruction I 
Base: 

Absolute Relative 

Drifting Anchored 

Size: @) large 

Font: @) Medium 

Address: =-O.~ __ _ 

( View... ) 

Perform the following procedure to manipulate this window: 

1. To set the interval at which memory windows are updated, move the 
Refresh (msec) slider or enter a new value in the Refresh (msec) field. 
(Setting this value too low can monopolize the workstation CPU and 
reduce system performance.) 

2. Click on a Format [~, I Halfword I, ~, ~, ~, I Address I, 
~,or ~ (hexadecimal)] to specify the format in which you 
want to display the data. 

3. Click on a Mode (I Memory I, I Exchange I, or I Instruction I) to specify the 
way you want to display the data. 
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Memory mode (I Memory I) displays normal memory: 

19 Memory - Absolute 

00000000000 mooooo 000000 000000 000000 
00000000001 000000 000000 000000 000000 
00000000002 000000 000000 000000 000000 
00000000003 000000 000000 000000 000000 
00000000004 000000 000000 000000 000000 
00000000005 000000 000000 000000 000000 
00000000006 000000 000000 000000 000000 
00000000007 000000 000000 000000 000000 
00000000010 000000 000000 000000 000000 
00000000011 000000 000000 000000 000000 
00000000012 000000 000000 000000 000000 
00000000013 000000 000000 000000 000000 
00000000014 000000 000000 000000 000000 
00000000015 000000 000000 000000 000000 
00000000016 000000 000000 000000 000000 
00000000017 000000 000000 000000 000000 
00000000020 000000 000000 000000 000000 
00000000021 000000 000000 000000 000000 
00000000022 000000 000000 000000 000000 
00000000023 000000 000000 000000 000000 
00000000024 000000 000000 000000 000000 
00000000025 000000 000000 000000 000000 
00000000026 000000 000000 000000 000000 
00000000027 000000 000000 000000 000000 
00000000030 000000 000000 000000 000000 
00000000031 000000 000000 000000 000000 
00000000032 000000 000000 000000 000000 
00000000033 000000 000000 000000 000000 
00000000034 000000 000000 000000 000000 
00000000035 000000 000000 000000 000000 
00000000036 000000 000000 000000 000000 
00000000037 000000 000000 000000 000000 

Exchange mode (I E«hange I) displays exchange information: 

Memory - Absolute 

ADX ooooooooomoooo 
P OOOOOOOOOOa AD 000000 000000 000000 000000 SO 000000 000000 000000 000000 
PN 000 Al 000000 000000 000000 000000 51 000000 000000 000000 000000 
XA 0000000 A2 000000 000000 000000 000000 52 000000 000000 000000 000000 
EXO 0000000 A3 000000 000000 000000 000000 S3 000000 000000 000000 000000 
EX1 0000000 A4 000000 000000 000000 000000 54 000000 000000 000000 000000 
EX2 0000000 AS 000000 000000 000000 000000 S5 000000 000000 000000 000000 
EX3 0000000 AS 000000 000000 000000 000000 S6 000000 000000 000000 000000 
EX4 0000000 A7 000000 000000 000000 000000 57 000000 000000 000000 000000 

CN 000 VL 000 MODES 000 BOD SCE TRI ESL BDM HM STATS 00 VNU FPS WS BML 

1M 000000 IRP IUM IFP lOR IPR FEX IBP ICM IMC IRT lIP 110 IPC IDL 1M! FNX lAM 
IF 000000 RPE MEU FPE ORE PRE EEX BPI MEC MCU RTI ICP 101 PCI DL MIl NEX AMI 

LATO RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LATl RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT2 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT3 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT4 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT5 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT6 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT7 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
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Instruction mode (I Instruction I) decodes the memory into instructions: 

!9 Memorv - Absolute 

OOOOOOOOOOa 1iI00000 ERR 
OOOOOOOOOOb 000000 ERR 
OOOOOOOOOOc 000000 ERR 
OOOOOOOOOOd 000000 ERR 
0000000001a 000000 ERR 
0000000001b 000000 ERR 
0000000001c 000000 ERR 
0000000001d 000000 ERR 
0000000002a 000000 ERR 
0000000002b 000000 ERR 
0000000002c 000000 ERR 
0000000002d 000000 ERR 
0000000003a 000000 ERR 
0000000003b 000000 ERR 
0000000003c 000000 ERR 
000OOOOO03d 000000 ERR 
0000000004a 000000 ERR 
0000000004b 000000 ERR 
0000000004c 000000 ERR 
0000000004d 000000 ERR 
OOOOOOOOOSa 000000 ERR 
ooooooooosb 000000 ERR 
OOOOOOOOOSc 000000 ERR 
ooooooOOOsd 000000 ERR 
0000000006a 000000 ERR 
0000000006b 000000 ERR 
0000000006c 000000 ERR 
0000000006d 000000 ERR 
0000000007a 000000 ERR 
0000000007b 000000 ERR 
0000000007c 000000 ERR 
0000000007d 000000 ERR 

4. Specify a Base. Click on I Absolute I to display absolute memory 
addresses, based on a starting address of o. This is the setting you 
will normally use in environment 1 because only one control point is 
loaded. 

Click on I Relative I to display memory addresses that are relative to 
the base address of the current control point. The window displays 
different areas of memory depending on the base address of the 
current control point. This setting is useful for looking at the 
contents of multiple control points in environment 2. 

Click on I Drifting I to display memory locations for the current 
control point as you change control points. The window "drifts" to 
the base address for the current control point as you change control 
points. 

Click on I Anchored I to always display memory for the control point 
that was current when the memory window was fIrst displayed. The 
window becomes "anchored" to the base address for one control 
point and always displays memory for that control point. 
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5. Choose the size of the display window from the Size @). This affects 
only the memory and instruction mode windows.-') 

The following window sizes are available: 

Size 

Small 
Medium 
Large 

X-Large 

Description 

The window displays 108 words. 
The window displays 208 words. 
The window displays 408 words. 
The window displays 1008 words. 

6. Choose the font size you want to display in the window from the 
Font@). 

The following font sizes are available: 

Size 

Small 
Medium 

Large 
X-Large 

Description 

The font size is small. 
The font size is medium. 
The font size is large. 
The font size is extra large. 

7. Change the starting address, if necessary, by double clicking on the 
Address field and typing a new value. 

8. Click on ( View... ). MME displays a window for the specified 
memory location. 

If you want to change the Format, Memory, Exchange, Instruction, 

Window Size, or Window Font from the Memory - Absolute window, 
press the MENU mouse button and choose the menu item. 
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Memory - Absolute 

00000000000 mooooo 000000 000000 000000 
000000 tPJLllll----1JlllllJ.llill-LLlJ.W.11.U..1.-.J..IJ..JJ..jO 0 0 000000 
000000 Format 1> 00 000000 
000000 00 000000 
000000 00 000000 
000000 Memory (M eta-M) 00 000000 
000000 00 000000 
000000 00 000000 
000000 Instruction (Meta-I) 1> 00 000000 
000000 00 000000 
000000 00 000000 
000000 Window Size 1> 00 000000 
000000 00 000000 
000000 Window Font 1> 00 000000 
000000 00 000000 
00000000017 000000 000000 000000 000000 
00000000020 000000 000000 000000 000000 
00000000021 000000 000000 000000 000000 
00000000022 000000 000000 000000 000000 
00000000023 000000 000000 000000 000000 
00000000024 000000 000000 000000 000000 
00000000025 000000 000000 000000 000000 
00000000026 000000 000000 000000 000000 
00000000027 000000 000000 000000 000000 
00000000030 000000 000000 000000 000000 
00000000031 000000 000000 000000 000000 
00000000032 000000 000000 000000 000000 
00000000033 000000 000000 000000 000000 
00000000034 000000 000000 000000 000000 
00000000035 000000 000000 000000 000000 
00000000036 000000 000000 000000 000000 
00000000037 000000 000000 000000 000000 

For example, the following window appears if you choose the 
Exchange (Meta-X) format menu option: 

Memory - Absolute 

ADX ooooooooo~oooo 
P OOOOOOOOOOa AO 000000 000000 000000 000000 50 000000 000000 000000 000000 
PN 000 A1 000000 000000 000000 000000 S1 000000 000000 000000 000000 
XA 0000000 A2 000000 000000 000000 000000 S2 000000 000000 000000 000000 
EXO 0000000 A3 000000 000000 000000 000000 S3 000000 000000 000000 000000 
EX1 0000000 A4 000000 000000 000000 000000 S4 000000 000000 000000 000000 
EX2 0000000 AS 000000 000000 000000 000000 55 000000 000000 000000 000000 
EX3 0000000 A6 000000 000000 000000 000000 56 000000 000000 000000 000000 
EX4 0000000 A7 000000 000000 000000 000000 57 000000 000000 000000 000000 

CN 000 VL 000 MODES 000 BOO SCE TRI ESL BOM HM 5TATS 00 VNU FPS WS BML 

1M 000000 IRP IUM IFP lOR IPR FEX IBP ICH IMC IRT lIP 110 IPC IOL IMI FNX lAM 
IF 000000 RPE HEU FPE ORE PRE EEX BPI MEC MCU RT! ICP 101 PCI DL HII NEX AMI 

LATa RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT1 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT2 RWXC 00 RWXO 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT3 RWXC 00 RWXO 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT4 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LATS RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT6 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 
LAT7 RWXC 00 RWXD 00 PB 0000000000000 LB 00000000000000 LL 00000000000000 

You can also change the window format (Format), data type (Memory 

or Instruction), window size (Window Size), or window font (Window 

Font) from this menu. 
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In this example, instead of using the MENU mouse button, you may 
also use the diamond-shaped meta key (0 or ., depending on the 
type of keyboard you have) with one of several keyboard shortcuts. 
The following key combinations are shortcuts to the menu options: 

Key Sequence Function 

Meta-a 

Meta-n 

Meta-b 

Meta-p 

Meta-h 

Meta-w 

Meta-e 

Meta-t 

Meta-i 

Meta-x 

Meta-m 

Switches the display to address format 

Switches the display to nibble format 

Switches the display to byte format 

Switches the display to parcel format. 

Switches the display to halfword format 

Switches the display to word format 

Switches the display to hexadecimal 
format 

Switches the display to text format 

Switches the display to instruction mode 

Switches the display to exchange mode 

Switches the display to memory mode 
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Changing Memory 
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Perform the following procedure from a memory window to change data 
stored in mainframe memory: 

1. Use the arrow keys to move the cursor to the location in memory 
you want to change, or click on the location. In this example, parcel 
00000000005b was selected: 

~ Memory - Absolute 

00000000000 000000 000000 000000 000000 
00000000001 000000 000000 000000 000000 
00000000002 000000 000000 000000 000000 
00000000003 000000 000000 000000 000000 
00000000004 000000 000000 000000 000000 
00000000005 000000 mOOOOO 000000 000000 
00000000006 000000 000000 000000 000000 
00000000007 000000 000000 000000 000000 
00000000010 000000 000000 000000 000000 
00000000011 000000 000000 000000 000000 
00000000012 000000 000000 000000 000000 
00000000013 000000 000000 000000 000000 
00000000014 000000 000000 000000 000000 
00000000015 000000 000000 000000 000000 
00000000016 000000 000000 000000 000000 
00000000017 000000 000000 000000 000000 
00000000020 000000 000000 000000 000000 
00000000021 000000 000000 000000 000000 
00000000022 000000 000000 000000 000000 
00000000023 000000 000000 000000 000000 
00000000024 000000 000000 000000 000000 
00000000025 000000 000000 000000 000000 
00000000026 000000 000000 000000 000000 
00000000027 000000 000000 000000 000000 
00000000030 000000 000000 000000 000000 
00000000031 000000 000000 000000 000000 
00000000032 000000 000000 000000 000000 
00000000033 000000 000000 000000 000000 
00000000034 000000 000000 000000 000000 
00000000035 000000 000000 000000 000000 
00000000036 000000 000000 000000 000000 
00000000037 000000 000000 000000 000000 
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2. Type the new value you want to place in the memory location. The 
entire word is highlighted, which enables you to change it. You can -~')' 

move through the highlighted word with the arrow keys. ' 

In the following example, 000217 was typed at memory location 
00000000005b: 

00000000000 
00000000001 
00000000002 
00000000003 
00000000004 
00000000005 
00000000006 
00000000007 
00000000010 
00000000011 
00000000012 
00000000013 
00000000014 
00000000015 
00000000016 
00000000017 
00000000020 
00000000021 
00000000022 
00000000023 
00000000024 
00000000025 
00000000026 
00000000027 
00000000030 
00000000031 
00000000032 
00000000033 
00000000034 
00000000035 
00000000036 
00000000037 

Memory - Absolute 

000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 

o 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
000000 000000 000000 000000 
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3. Press and release the return key, which updates memory. In this 
example, memory location 00000000005b changed from 000000 to 
000217, as shown: 

Memory - Absolute 

00000000000 000000 000000 000000 000000 
00000000001 000000 000000 000000 000000 
00000000002 000000 000000 000000 000000 
00000000003 000000 000000 000000 000000 
00000000004 000000 000000 000000 000000 
00000000005 000000 000217 mOOOOO 000000 
00000000006 000000 000000 000000 000000 
00000000007 000000 000000 000000 000000 
00000000010 000000 000000 000000 000000 
00000000011 000000 000000 000000 000000 
00000000012 000000 000000 000000 000000 
00000000013 000000 000000 000000 000000 
00000000014 000000 000000 000000 000000 
00000000015 000000 000000 000000 000000 
00000000016 000000 000000 000000 000000 
00000000017 000000 000000 000000 000000 
00000000020 000000 000000 000000 000000 
00000000021 000000 000000 000000 000000 
00000000022 000000 000000 000000 000000 
00000000023 000000 000000 000000 000000 
00000000024 000000 000000 000000 000000 
00000000025 000000 000000 000000 000000 
00000000026 000000 000000 000000 000000 
00000000027 000000 000000 000000 000000 
00000000030 000000 000000 000000 000000 
00000000031 000000 000000 000000 000000 
00000000032 000000 000000 000000 000000 
00000000033 000000 000000 000000 000000 
00000000034 000000 000000 000000 000000 
00000000035 000000 000000 000000 000000 
00000000036 000000 000000 000000 000000 
00000000037 000000 000000 000000 000000 

4. Repeat Steps 1 through 3 to change all desired memory locations. 

Using the Keyboard Accelerator 

HDM-xxx-O 
December 21, 1994 

The keyboard accelerator offers another way to change memory and 
includes several other features. To access the keyboard accelerator, move 
the cursor inside a memory window and press the spacebar. The MME 

Keyboard Accelerator window appears: 

s9 MME Kevboard Accelerator 

Iliommands: Dump Enter Co Halt Load Save D-7 RETURN 
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--'" 
The fIrst command in the MME Keyboard Accelerator window is the Dump ) 

command. The Dump command dumps data to a fIle or printer. When you 
type the letter D in the MME Keyboard Accelerator window, the window 
changes to: 

MME Keyboard Accelerator 
Address: [0-7]* - SPACE.when complete 
Dump to Printer Parcel _ I 

NOTE: By default, the Dump command dumps parcel data to the printer. 
To change this, press the backspace key several times to delete 
the default selections. Then, type the menu options you want. 

Enter the starting address of the data block you want to dump and press 
the spacebar; for example, if you wanted to dump the data block starting at 
100, you would enter 100: 

MME Keyboard Accelerator 
Length: [0-7] * - RETURN whe,tl ready 
Dump to Printer Parcel 100_ 

Then, enter the length of the data block you want to dump; for example, if 
you wanted to dump a block of 20008 parcels, you would enter 2000: 

19 MME Keyboard Accelerator 
Length: [0-7]* - RETURN when r~!dy 
Dumo to Printer Parcel 100 2000. I 

Finally, press the return key to dump the data. The window displays the 
main menu again: 

19 MME Keyboard Accelerator 

II*om~ands: Dump Enter Co Halt Load Save 0-7 RETURN I 
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Enter Command 

HDM-xxx-O 
December 21, 1994 

The second command in the MM E Keyboard Accelerator window is the Enter 

command. The Enter command puts data into memory. When you type 
the letter E in the MME Keyboard Accelerator window, the window changes 
to: 

MME Keyboard Accelerator 

Enter:.eXchange. Auto. address [0-7] * [a-d] 
Enter. 

This window gives you three command options: 

• Type the letter X in the Enter menu to enter exchange data; this option 
is not implemented yet: 

!S) MME Keyboard Accelerator 

Not implemented.- RETURN when ready 
Enter eXchange. 

• Type the letter A in the Enter menu to start the automatic increment 
mode. Automatic increment mode enables you to enter data into 
consecutive memory locations without having to manually enter each 
memory address. 

For example, if you wanted to enter data in consecutive memory 
locations starting at address 102, you would perform the following 
steps: 

1. Enter the address at which you want to enter the data and press 
return. For this example, you would enter 102: 

MME Keyboard Accelerator 

Data: RETURN wh!n complete. ESC to cancel 
Enter Auto 102 • 

2. Enter the first data word and press return. For this example, 
you would enter 17777 177777: 

MME Keyboard Accelerator 

Data: RETURN when comp 1 et~" ESC to cancel 
Enter Auto 102 17777 17777 • 
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The window advances to the next memory location: 

!9 MME Keyboard Accelerator 

Data: RETURN wh~n complete. ESC to cancel 
Enter Auto 103 • I 

3. Enter the next data word and press return. Repeat this process 
to enter all of your data. When you have fmished entering 
data, press the ESC key and automatic increment mode halts. 
The MME Keyboard Accelerator window returns to the main 
menu: 

!9 MME Keyboard Accelerator 

IjOmmands: Dump Enter Co Halt Load Save 0-7 RETURN 

• Type a number-letter combination in the Enter menu to enter a parcel 
address which indicates the memory address you want to change. 
For example, if you wanted to change parcel 1000b, you would enter 
1000b: 

!9 MME Keyboard Accelerator 

IIAddress: [~;7l*[a-dl - SPACE when complete 
II Ente r 1000b. 

Then, enter the data you want to write to memory; for example, if 
you wanted to enter 177777 177777 177777 177777, you would 
enter 177777 177777 177777 177777: 

!9 MME Keyboard Accelerator 

RETURN when ready 
Enter 1000b 177777 177777 177777 1777771 
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Press return to write the data to memory: 

!.9 Memory - Absolute 

00000001000 000000 177777 177777 177777 
00000001001 077777 000000 000000 000000 
00000001002 000000 000000 000000 000000 

The window displays the main menu again: 

MME Keyboard Accelerator 

liomnands: Dump Enter Go Halt Load Save 0-7 RETURN 

The third command in the MME Keyboard Accelerator window is the Go 

command. The Go command runs the assigned control point(s). When 
you type the letter G in the MME Keyboard Accelerator window, the window 
changes to: 

IRETURN when ready 
.Go Selected. 

MME Keyboard Accelerator 

NOTE: By default, the Go command runs the selected control point(s). 
To run all control points, press the backspace key to move 
backward through the menu selections. Then, type the menu 
options you want. 

Press return to start the control point(s). The window displays the main 
menu again: 

MME Keyboard Accelerator 

liomnands: Dump Enter Go Halt Load Save 0-7 RETURN I 
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The fourth command in the MME Keyboard Accelerator window is the Halt 
command. The Halt command halts the current running control point(s). 
When you type the letter H in the MME Keyboard Accelerator window, the 
window changes to: 

!9 MME Keyboard Accelerator 

RETURN when ready 
Halt Selected XchanQe Duma' 

NOTE: By default, the Halt command halts the selected control point(s) 
and performs an exchange dump. To halt all control points, 
perform a register dump, or halt with no dump; press the 
backspace key to move backward through the menu selections. 
Then, type the menu options you want. 

Press return to halt the control point(s). The window displays the main 
menu again: 

!9 MME Keyboard Accelerator 

liommandS: Dump Enter Co Halt Load Save 0-7 RETURN 

The fifth command in the MME Keyboard Accelerator window is the Load 
command. The Load command loads a control point or data set. When 
you type the letter L in the MME Keyboard Accelerator window, the window 
changes to: 

MME Keyboard Accelerator 

ILoad: COntrol point. Data 
Load • 
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This window gives you two options: loading a control point and loading a 
data set. 

• Type the letter C in the Load menu to load a control point. 

MME Keyboard Accelerator 

File: RETURN when r~ady (rel/diag.cpOl) 
Load Control Doint _ I 

Then. enter the name of the control point from the current offline 
diagnostic release that you want to load. For example. if you want to 
load ash.t, enter the following: 

!9 MME Keyboard Accelerator 

File: RETURN when readYcirel/diag.cP01) 
Load Control point asb.t_ 

Finally. press return to load the control point. The window displays 
the main menu again: 

MME Keyboard Accelerator 

IIjommands: Dump Enter Co Halt Load Save 0-7 RETURN 

• Type the letter D in the Load menu to load a data set; this command is 
not implemented yet. 

The sixth command in the MME Keyboard Accelerator window is the Save 

command. The Save command saves a control point or data set. When 
you type the letter S in the MME Keyboard Accelerator window. the window 
changes to: 

MME Keyboard Accelerator 

Isave: Control point. Data 
Save I 
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This window gives you two options: saving a control point and saving a 
data set. 

• Type the letter C in the Save menu to save a control point. 

!9 MME Keyboard Accelerator 

File: RETURN when r~ady (usr) 
Save Control Doint _ 

Then, enter a filename to save the control point. For example, to 
save the control point as mycp, enter mycp: 

!9 MME Keyboard Accelerator 

File: RETURN when ready.(usr) 
Save Control Doint mvco_ 

Finally, press return to save the control point. The window displays 
the main menu again: 

!9 MME Keyboard Accelerator 

lIiommandS: Dump Enter CO Halt Load Save 0-7 RETURN 

• Type the letter D in the Save menu to save a data set; this command is 
not implemented yet. 
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Two options are available when you type a number in the MME Keyboard 
Accelerator window: you can display memory starting at the number, or 
you can convert the number from octal to parcel format or from parcel 
format to octal. 

• To display a specific memory location, type the location in the MME 
Keyboard Accelerator window and press the return key. For example, 
to view memory location 5000, enter 5000: 

19 MME Keyboard Accelerator 

[O-?l*[a-dl. RETURN to change display. SPACE to convert 
5000. 

The window displays memory at location 5000: 

19 Memory - Absolute 

00000005000 ~OOOOO 000000 000000 000000 
00000005001 000000 000000 000000 000000 
00000005002 000000 000000 000000 000000 
00000005003 000000 000000 000000 000000 
00000005004 000000 000000 000000 000000 
00000005005 000000 000000 000000 000000 
00000005006 000000 000000 000000 000000 
00000005007 000000 000000 000000 000000 
00000005010 000000 000000 000000 000000 

The window displays the main menu again: 

MME Keyboard Accelerator 

Ili0mllands: Dump Enter Co Halt Load Saye 0-7 RETURN 

• To convert a number from octal to parcel format or from parcel 
format to octal, type the number and press the spacebar. For 
example, to convert octal value 5000 to parcel format, enter 5000 and 
press the spacebar: 

19 MME Keyboard Accelerator 

[O-?l*[a-dl. RETURN to change display. SPACE to convert I 
5000. 
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The window then displays the parcel format equivalent. 

IRETURN when done 
.5000 = 0120081 

MME Keyboard Accelerator 

Press the return key, and the window displays the main menu again: 

!9 MME Keyboard Accelerator 

IjOmmandS: Dump Enter Go Halt load Save 0-7 RETURN 

To close the MME Keyboard Accelerator window, press the return key while 
the cursor is in the window. 

View -> Standard Locations 
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This feature has not been implemented yet. 
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View -> Error Log 

Memory ... 

Stail(1 .. ;'l"d L(-::-l.t!·,n~: ... 

Erl'A L-:q 

Runtime Information c> 

Listing c> 

Notes ... 

The View -> Error Log command, as shown at the left, displays memory, 
register parity, shared register, and logical address translation (LAT) table 
errors logged in the status registers. Use this command to track the 
occurrence of these errors. This command displays the MME 
Memory/Register Parity Error Log window: 

19 MME Memory/Register Parity Error Log 

(Clear) ~ File: usr/elog:i!. 

Memorv Errors - Entries 0, Errors 0 = 
NUM TYPE DESTINATION SECT BANK MODULE SYNDROME LOC/PHY COUNT ~ 

No Errors Logged. 

E3 Register Paritv Errors - Entries 0, Errors 0 

~ NUM TYPE CHIP LOC/PHY COUNT 

No Errors Logged. 
• 

Shared Register Errors - Entries 0, Errors 0 E3 
NUM TYPE . CLUSTER LOC/PHY COUNT ~ No Errors Logged. · LAT Errors - Entries 0, Errors 0 E3 
NUM TYPE LOC/PHY COUNT ~ No Errors Logged. 

• = 

The (Clear) button clears all logged errors from the display. The ( Print v) 

button sends a copy of the error log to the printer (choose Print -> To 
Printer) or to the file specified in the File field (choose Print -> To File). 

Memory Error Information 

HDM-xxx-O 
December 21, 1994 

The MME Memory/Register Parity Error Log window displays the following 
memory error information: 

Label 

NUM 

TYPE 

Description 

Entry number in the table 

Type of error that occurred (correctable or 
uncorrectable) 
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Label 

DESTINATION 

SECT 

BANK 

MODULE 

SYNDROME 

LOG/PHY 

COUNT 

GRAY T90 Series MME Interface Reference 

Description 

Destination of the memory read error (cache read, 
V register read, S register read, A register read, 
T register read, B register read, fetch read, 110 read, 
exchange read, 110 write, processor write, 
reconfigure, or memory error) 

Section where the error occurred 

Bank where the error occurred 

Module where the error occurred 

Syndrome 

Logical/physical CPU number 

Number of errors for this entry 

Register Parity Error Information 

The MME Memory/Register Parity Error Log window displays the following 
register parity error information: 

Label 

NUM 
TYPE 
CHIP 
LOG/PHY 

COUNT 

Description 

Entry number in the table 
Type of error that occurred 
Chip number where the error occurred 
Logical/physical CPU number 
Number of errors for this entry 

Shared Register Error Information 
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The MME Memory/Register Parity Error Log window displays the following 
shared register error information: 

Label 

NUM 
TYPE 

CLUSTER 

LOG/PHY 

COUNT 

Description 

Entry number in the table 
Type of error that occurred 
Cluster where the error occurred 
Logical/physical CPU number 
Number of errors for this entry 
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LAT Error Information 

The MME Memory/Register Parity Error Log window displays the following 
LAT error information: 

Label 

NUM 

TYPE 

LOG/PHY 

COUNT 

Description 

Entry number in the table 
Type of error that occurred 
Logical/physical CPU number 
Number of errors for this entry 

View -> Memory Map 

This feature has not been implemented yet. 

View -> Runtime Information -> Current 

Stancf~fd L(-:ati·}ll:i. ... 

Error log ... 

listing 

Notes ... 

HDM-xxx-O 
December 21, 1994 

The View -> Runtime Information -> Current command, as shown at the left, 
displays the runtime information display for the current control point: 

!9 Runtime Information Displav - 00 vhc.t 
MAIN ERROR DIACINFO PARI\METERS CONTENTS HELP EXCHANCE 

Pass 000000000 
VHISP CHANNEL COMPREHENSIVE TEST Error 000000000 
._------------------------------- Section 000000000 

Condition 000000000 
Sub-Cond 000000000 

Fetch/Exchange Activity Count 00000000000 
Vector Port Activity Count 00000000000 

Channels Running: 
------------------
20 21 22 23 24 25 26 27 30 31 32 33 34 35 36 37 
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 

MAIN - Run time display. 

Use this window to get updated information from the control point as the 
control point executes. Table 3 describes the runtime information 
categories you can view for control points. 
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On color displays this window uses the following colors: black indicates 
the text is mainframe memory data, blue indicates the text is window text, 
and green indicates you can click on the text to switch to a different 
display. On monochrome displays, bold text indicates you can click on 
the text to switch to a different display. 

Table 3. Control Point Runtime Information Categories 

Category 

MAIN 

ERROR 

DIAGINFO 

PARAMETERS 

CONTENTS 

HELP 

EXCHANGE 

88 

Description 

This display shows general information about the control point. This 
display typically includes the pass count, error count, current section, 
current condition, current subcondition, and control-paint-specific 
information. 

This display shows any control-paint-specific error information. 

This display shows information from the standard locations, including 
the difference of the actual and expected values, the actual value, 
the expected value, the error count, the pass count, the error return 
address, the failing data address, the failing element mask, the 
section under test, the condition under test, the subcondition under 
test, the condition loop count, and the subcondition loop count. 

This display shows any control-paint-specific parameters. 

This display shows the location of several standard locations, the 
code block, the data area, and the block storage segment. 

This display shows help information, if any is available. 

This display shows information from the deadstart exchange 
package, starting exchange package, interrupt exchange package, 
working exchange packages, current exchange packages, and trap 
exchange packages. 
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View -> Runtime Information -> Controller (Environment 2 Only) 

Error Log ... 

LIsting 

Notes ... 

Category 

MAIN 

ERROR 

HDM-xxx-O 
December 21, 1994 

The View -> Runtime Information -> Controller command, as shown at the 
left, displays the runtime information display for the controller: 

!9 Runtime Information Display - Controller 
MAIN ERROR DIACINFO PARAMETERS CONTENTS HELP EXCHANCE 
VHISP LOSP CLUSTERS LIMITS 

<ALL > Pass Error SUT CUT P-reg IF Base 
CPU 00 000000000 000000000 000 000 OOOOOOOOOOa 000000 00000000000000 
CPU 01 000000000 000000000 000 000 OOOOOOOOOOa 000000 00000000000000 
CPU 02 000000000 000000000 000 000 OOOOOOOOOOa 000000 00000000000000 
CPU 03 000000000 000000000 000 000 OOOOOOOOOOa 000000 00000000000000 

MAIN - Run time display. 

Use this window to get updated information from the controller while the 
control points execute in environment 2. Table 4 describes the runtime 
information categories you can view for the controller. 

On color displays this window uses the following colors: black indicates 
the text is mainframe memory data, blue indicates the text is window text, 
and green indicates you can click on the text to switch to a different 
display. On monochrome displays, bold text indicates you can click on 
the text to switch to a different display. 

Table 4. Controller Runtime Information Categories 

Description 

This display shows general CPU information. This display contains 
the information used to update the MME base window (pass count, 
error count, section under test, condition under test, P register value, 
interrupt flags, and base address). 

This display shows the hartBEAT and idleSTAT parameters and 
interrupt flags for all CPUs. For more information about these 
parameters, refer to the online listing of the controller or to the 
GRAY T90 Series MME User Guide, publication number HDM-xxx-O. 
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Table 4. Controller Runtime Information Categories (continued) 

Category Description 

DIAGINFO This display shows the pass count, error count, P register value, 
interrupt flags, mmeCIFM parameter, and dcCIFM parameter for 
each CPU. For more information about these parameters, refer to 
the online listing of the controller or to the GRAY T90 Series MME 
User Guide, publication number HDM-xxx-O. 

VHISP This display shows the VHISP reservation table. 

LOSP This display shows the LOSP reservation table. 

CLUSTERS This display shows the cluster reservation table. 

LIMITS This display shows the control point base and limit values for each 
CPU that is running control point code. 

PARAMETERS This display shows the MWS-to-CPU and CPU-to-MWS request and 
response parameters. 

CONTENTS This display shows the location of several standard locations, the 
code block, and the block storage segment. 

EXCHANGE This display shows information from the controller's deadstart 
exchange package, starting exchange package, interrupt exchange 
package, working exchange packages, trap exchange packages, 
and buffer exchange packages. This display also shows the trap 
exchange address (XA) and trapSTAT parameter. For more 
information about these parameters, refer to the online listing of the 
controller or to the GRAY T90 Series MME User Guide, publication 
number HDM-xxx-O. 

View -> Listing -> Current 

Stalld.;.rrll(-:3t!·)I1~ ... 

Error Log ... 
H",rfl·)f':o" t.1ap .. , 

Runtime Information t> 

Notes ... 
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The View -> Listing -> Current command, as shown at the left, displays the 
listing for the current section in the Sections scroll box. Use this command 
to learn more about the current·section; the listing describes what is stored 
in memory and what the section is testing. This command displays the 
listing in a separate window. 
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® re lId iag/cach.t/lst/cachOO.t.l.Z 

(Find Forward) (Find Backward) Pattern: * (STDlOC) ~ (CODE v) ~ ~ 

lCAl Version 2 - 9.0ed 04 (06/23/94) mmefrm400 ~~ 
10. ... 
11. 
12.************************************************************************ • 
13.* 

HDM-xxx-O 
December 21, 1994 

14.* Cray Research. Inc. 
15.* Unpublished proprietary Information - All Rights Reserved. 
16.* 
17.************************************************************************ 
18. 
19. 
20.************************************************************************ 
21.* 
22.* Name 
23.* 

: cachOO.t 

24.* Title : Cache test 

Status 

25.* Section : Enable/disable test 
26.* 
27.* 
28.* 
29.* 
30.* 
31.* 
32.* 
33.* 

Revision : TRI a.3 
Mainframe: T32T 
level • Quick test 
Date : 07/18/94 
Ti me : 09: 31 : 28 
Target : CRAV TS 

34.* Program uses WAIT/RESUME. 
>35.* 
36.* 

Type 
Env. 

You can manipulate the listing as follows: 

: Pre-Release 

: Diagnostic 
: ENVl A7=CPU 

• To search forward from the current location in the window for a data 
pattern, enter the pattern in the Pattern field and click on (Find Forward). 

• To search backward from the current location in the window for a 
data pattern, enter the pattern in the Pattern field and click on 
(Find Backward) • 

• To split the window to view multiple areas of the listing, press the 
MENU mouse button over the scroll bar and choose Split View. 
Choose Join Views to restore the window to the original view. 

• To make the window a full-size display, double click in the window 
header. This enables you to see more of the listing at one time. 
Double click in the window header to return the window to normal 
size. 

• To view the standard locations, parameters, initialized data (IDATA), 
or uninitialized data (UDATA); click on the corresponding button 
« STDlOC), ( PARAM ), (IDATA), or ( UDATA»). 

• To view the standard code, diagnostic main code, or subroutines, 
choose CODE -> STDCODE, CODE-> MAIN, or CODE -> CODESUB, 
respectively. 
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View -> Listing -> Controller 

Error Log". 

Runtime Information c> 

Notes ... 

The View -> Listing -> Controller command, as shown at the left, displays 
the listing for the diagnostic controller. Use this command to learn more 
about the diagnostic controller. This command displays the listing in a 
separate window. 

Refer again to the "View Listing -> Current" subsection for an example of 
the listing window and a description of manipulating the listing. 

View -> Listing -> Other 

Error Log ... 

Runtime Information to 

Notes .•. 
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The View -> Listing -> Other command, as shown at the left, displays the 
listing for the control point section you specify. Use this command to get 
detailed information about a control point section. This command 
displays the MME View Listing Setup window: 

19 MME View Listing Setup 

Dir: @) reIO.O/diag/*, 

Files: Sectio ns: 

asb.t/ 
asf.t/ 
bsr.t/ 
btv.t/ 
ed.t/ 
emp.t/ 
emtt/ 
csr.t/ 
cttt/ 
eptt/ 
etem.t/ 
fbt.t/ 
fpb.t/ 
I fpt.t/ 
latt/ 

fptOO.t.I.Z 
fptOl.t.I.Z 
fpt02.t.I.Z 
fpt03.t.I.Z 
fpt04.t.I.Z 
fpt05.t.I.Z 
fpt06.t.I.Z 

~----~= ~----~= 

7 files found 

Each section is an individual file, so you must specify the control point 
and then pick one section. To do this, perform the following steps. 
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1. In the Dir field, specify the directory in which to search for the listing 
file; enter the directory in the Dir field or choose it from the Dir @) . 
The following options are available: 

Directory Description 

Release Listings for diagnostic tests included in the 
current offline diagnostic release (choose 
the appropriate revision level) 

User Listings saved or modified by the user 

Alpha Listings for prereleased diagnostic tests 
(choose the appropriate revision level) 

Utility -> Release Listings for control point utilities included 
in the current offline diagnostic release 
(choose the appropriate revision level) 

Utility -> Alpha Listings for prereleased control point 
utilities (choose the appropriate revision 
level) 

2. Click on the control point in the Files scroll box. The Sections scroll 
box displays the section listings available. 

3. Click on the section in the Sections scroll box for which you want to 
see the listing. 

4. Click on (View ... ). MME displays the listing. 

Refer again to the "View Listing -> Current" subsection for an example of 
the listing window and a description of manipulating the listing. 
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Error log ... 

Runtime Information I> 

Listing I> 
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The View -> Notes command, as shown at the left, displays the MME 
release notes in a separate window. Use this window to read about any 
changes to MME for the current offline diagnostic release. 

Edit -> Delete Control Point -> Selected 

The Edit -> Delete Control Point -> Selected command, as shown at the left, 
deletes the current control point selected in the Control Points scroll box. 
Use this command to delete a control point you are no longer using. 

Edit -> Delete Control Point -> All 

The Edit -> Delete Control Point -> All command, as shown at the left, 
deletes all loaded control points. Use this command when you are done 
using all control points. 

Edit -> Assign CPU(s) 

This feature has not been implemented yet. 

Edit -> Deassign CPU(s) 

This feature has not been implemented yet. 

Properties -> Environment -> ENV2 (Environment 1 Only) 

dlt v 

Partition 

Resource Allocation ... 

94 

The Properties -> Environment -> ENV2 command, as shown at the left, 
switches MME to environment 2. Use this command to switch to 
multiple-control-point testing. This command is available in environment 
1 only. 
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Properties -> Environment -> ENV1 (Environment 2 Only) 

Resource Allocation .•. 

filJfI S;::~.;.m ... 

The Properties -> Environment -> ENV1 command, as shown at the left, 
switches MME to environment 1. Use this command to switch to 
single-control-point testing. This command is available in environment 2 
only. 

Properties -> Environment -> ENVO 

The Properties -> Environment -> ENVO command, as shown at the left, 
switches MME to environment O. Use this command to switch to MWS 
based testing. Refer to the "Environment 0" section earlier in this 
document for more information about environment o. 

Properties -> Partition 

Resour<e Allocation." 

HDM-xxx-O 
December 21, 1994 

The Properties -> Partition command, as shown at the left, selects the 
logical partition in which MME will run. Use this command to select the 
partition you want to troubleshoot. MME scans the current configuration 
for available partitions and allows you to select only partitions that allow 
maintenance or concurrent maintenance. MME displays the available 
partitions in a menu attached to the Properties -> Partition menu command. 
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Properties -> Resource Allocation 

The Properties -> Resource Allocation command, as shown at the left, 
changes the way MME performs. Use this command to change the 
memory allocation, the CPU automatic assignment option and CPU 
modes; the CPU to memory delays; or the section swap interval. This 
command displays the MME Resource Allocation window; choose the 
category you want to modify from the Category @) . 

Changing Memory Allocation (Environment 2 Only) 
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To change the memory allocation in environment 2, choose Memory 
Allocation from the Category @). The MME Resource Allocation window 
changes to: 

!9 MME Resource Allocation 

Catagory: ~ Memory Allocation 

Allocation Mode: 

I Bottom Up I Top Down I Random II Partition I 
Partition Count: _4 __ EI3 
Partition Size: 00000000340 

The Memory Allocation category is valid for environment 2 only. Memory 
allocation defines how control point sections are loaded into memory 
(refer to Figure 7), whether memory is partitioned, the number of memory 
partitions, and the size of memory partitions. Memory allocation changes 
affect only the control points that are loaded after the changes are made. 
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Figure 7. Memory Allocation in Environment 2 
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You can specify the allocation mode by clicking on I Bottom Up I, I Top Down I, or 
I Random I. You can also configure memory into partitions that cause all 
control points to use the same amount of memory; to do this, click on 
I Partition I. When you partition memory, the number of control points you 
may load is limited to the number of partitions available. 

Partitions are defmed by count and size. The easiest way to define 
partitions is to enter the desired number of partitions in the Partition Count 

field. MME automatically calculates the size of the partitions. You may 
also defme partitions by entering the desired partition size in the Partition 
Size field. MME automatically calculates the number of partitions. The 
default partition count is the number of CPUs MME uses. 

HDM-xxx-O 
December 21, 1994 
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MME uses the following formulas to calculate the partition size and 
partition count; the diagnostic_controller_size is 1000008 words. 

• Partition_size = (mainframe_memory_size minus 
diagnostic _controller_size) divided by partition_count 

• Partition_count = (mainframe_memory_size minus 
diagnostic_controller_size) divided by partition_size 

NOTE: If you use these formulas to determine a partition count or size, 
ensure that you use all octal values. 

Changing the Auto Assignment, CPU Allocation, or CPU Control Options 

98 

To change the CPU assignment option and CPU modes, choose CPU 
Allocation/Control from the Category @). The MME Resource Allocation 

window changes to: 

t9 MME Resource Allocation 

catagorv: @) CPU Allocation/Control 

Auto Assignment: I Disabled I Enabled I 
CPU Mode: 

I/O CPU 

Cache D Isab Ie 

IRP Disable 

IUM Disabled 

ICM Disabled 

SBC/DBD Disabled 

SEC/DED Disabled 

PCI: 00000004000 

Perform the following procedure to manipulate this window: 

1. Specify the Auto Assignment option. Click on I Disabled I or I Enabled I to 
specify whether MME automatically assigns the first available CPU 
to a control point when the control point is loaded. 
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2. 

3. 

4. 

Click on the CPU Mode allocation option you want to change: 

Mode Description 

Ilia CPU Specifies a CPU to read and write memory 

I Cache Disable Disables scalar cache 

IIRP Disable Disables interrupt on register parity error 
(lRP) for a CPU by clearing the IRP flag 
in the starting exchange package for the 
CPU if the flag is set 

IIUM Disabled Disables interrupt on uncorrectable 
memory error (IUM) for a CPU by 
clearing the IUM flag in the starting 
exchange package for the CPU if the flag 
is set 

IICM Disabled Disables Interrupt on correctable memory 
error (I CM) for a CPU by clearing the 
ICM flag in the starting exchange package 
for the CPU if the flag is set 

I SBC/DBD Disabled Disables single-byte correction! 
double-byte detection (SBCDBD) 

I SEC/DED Disabled Disable single-error correction! 
double-error detection (SECDED) 

Click on the CPU(s) that you want to set for the selected mode. 
Only one CPU can be selected as the 110 CPU. The other modes can 
be set for one or more CPU(s) at a time. Use the (Toggle) button to 
toggle the CPU selections, except in 1110 CPU I mode. 

In environment 2 only, in the PCI field, enter the number you want to 
store in the PCITIME standard location. This value specifies how 
often the CPU checks the controller communication port to 
determine if MME has a function for the CPU to perform. 
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Changing the CPU to Memory Delay 
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To change the CPU to memory delays, choose CPU/Memory Delay from 
the Category @). The MME Resource Allocation window changes to: 

19 MME Resource Allocation 

Catagory: ® CPU/Memory Delay 

Set Delay For: I Ali CPUs I Single CPU I 
Delay (CP): 

CJO: 

CJ1: 

CJ2: 0 4 16 

C13: 0 4 16 

CJ4: 0 4 16 

CJ5: 0 4 16 

CJ6: 0 4 16 

CJ7: Lii J 4 16 

(setAII 0 CP ) (set Ali 16 CP) 

(setAli4 CP ) (SetA1i63 CP) 

63 

63 

63 

63 

63 

Perform the following procedure to manipulate this window: 

1. Specify the CPUs for which you want to set the delay (click on 
I All CPUs I to set the delay for all CPUs or I Single CPU I and a CPU to set the 
delay for one CPU). 

2. Specify the delay in clock periods (CPs) for each of the ports (CJO 
through CJ7; CJ refers to the option type), or click (SetAIl 0 CP ), 

(Set AII4 CP ), C Set All 16 CP), or C Set All 63 CP) to set the delay for all ports to 
the same value. 
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Changing the Section Swap Interval and Enabling or Displaying the Maximum Pass Option 
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To change the section swap interval and enable or disable the maximum 
pass option, choose Control Point Properties from the Category @). The 
MME Resource Allocation window changes to: 

~ MME Resource Allocation 

Catagorv: @) Control Point Properties 

Swap Interval: ~ D 0 D 
(msec) 

Maximum Pass: I Disabled I Enabled I 

The section swap interval value specifies how often MME checks the pass 
and error counts for each section to determine whether the section should 
be swapped. To change this interval, enter a new value in the field or 
move the slider to select a value. 

The maximum pass option specifies whether MME should stop executing 
a control point section when the pass count for the section reaches the 
maximum pass value. Click on the appropriate setting to enable or disable 
the option. 
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Changing the Error Logger Access Setting and Setting the Debug Level 
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To change the error logger access setting and set the debug level, choose 
Miscellaneous from the Category @). The MME Resource Allocation window 
changes to: 

!9 MME Resource Allocation 

Catagorv: ® M isce lIaneous 

Error logger Access: 

I Nonexclusive I Exclusive I 
Debug level: _o_~ 

The error logger access setting specifies whether MME has exclusive 
access to the error channel. By default, MME has exclusive access to the 
error logger channel: when a control point requests MME to log errors 
from the error channel, MME restricts access to the error channel so the 
error logging software doesn't also log these known errors. The Error 
Logger Access settings enable you to specify whether MME has exclusive 
access to the error channel. Click on the appropriate setting. 

The debug level specifies the amount of output that MME returns to the 
standard output window from which you started MME. Set the value to 0, 
1, or 2, where 0 causes MME to display the least information and 2 causes 
MME to display the most information. Enter the number in the Debug 

Level field and press return, or click on the arrows to change the number in 
the field. 

Cray Research Proprietary 
Preliminary Information 

HDM-xxx-O 
December 21, 1994 

) 

) 



) 

GRAY T90 Series MME Interface Reference Environments 1 and 2 

Properties -> Run System (Environment 2 Only) 

Uti 

Resource Allocation ... 
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The Properties -> Run System command, as shown at the left, enables you 
to enable and disable the run system and set the run system parameters. 

The run system is an environment 2 operation mode that swaps CPU s 
among any eligible control points. This creates an operating system type 
of environment, where the control points simulate jobs. For a control 
point to be eligible, the control point must satisfy the following 
conditions: 

• The control point must rotate under the run system. This property is 
defined by the programmer and communicated to MME through the 
section information. (Refer to the CRAY T90 Series MME 
Diagnostic Tests and Utilities document, publication number 
HDM-xxx-O, to determine which control points rotate under the run 
system.) 

• The control point must have only one CPU assigned to it. 

This command displays the MME Run System window: 

19 MME Run System 

Run System: 

I Disabled I Enabled I 
Mode: 

I Swap Pair I Swap Group I 
Interval:.3...-- 0 {}::== 60 

(seconds) 

Perform the following procedure to manipulate this window: 

1. Click on Run System: I Enabled I or I Disabled I to enable or disable the run 
system. 
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You can enable the run system at any time. MME checks the current 
loaded control points for eligible control points. If MME fmds two ~) 

or more eligible control points that have not detected errors, MME 
begins to swap the CPUs. 

If MME cannot fmd at least two eligible control points without 
errors, MME idles the run system. The run system remains enabled 
and waits until at least two eligible control points without errors are 
available. 

If a loaded control point does not rotate under the run system or is 
assigned more than one CPU, MME does not affect it. 

2. Specify the mode you want to use. Click on Mode: I SwaD Pair I to swap 
CPU s for a pair of control points at each swap interval. Click on 
Mode: I Swap Group I to swap CPUs for all control points at each swap 
interval. 

3. Specify the interval (in seconds) you want to pass before MME 
swaps the CPUs. Enter the value in the Interval field or move the 
slider. An interval of 0 causes MME to swap CPUs as fast as 
possible. 

This feature has not been implemented yet. 

This feature has not been implemented yet. 

The Utilities -> Find command, as shown at the left, searches mainframe 
memory for a data pattern. Use this command to locate all occurrences of 
a data pattern within a block of memory. This command displays the MME 
Find Utility window. 
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!.9 MME Find Utility 

Base: = 
I A bsol ute I Re lative I ~ Search Boundary: 

I Byte I Paree I I Halfword I Word I 
Pattern/Mask Size: 

I Word I 
Pattern/Mask Format: 

I Byte I Parcel I Halfword I Word I 
Pattern: 
000000 000000 000000 000000. 

Mask: 
177777 177777 177777 177777 

Address: 00000000000000 

length: 00000000000000 

limit: 00000000000000 

( Start ) ('T.);itlr;;j(j') 

= 

The left side of the window contains the settings that specify the pattern to 
search for and the memory block to search. The right side contains a 
scroll box that displays memory locations with the matching data pattern. 
The scroll box displays up to 256 entries; if more than 256 matches are 
found, the message 256 matches, additional occurrences known to exist is 
displayed in the lower-left comer of the window. To view the additional 
occurrences, click on the ( Continue) button. 

Perform the following procedure to manipulate this window: 

1. Specify the Base to use. For environment 1, Base should usually be 
set to I Absolute I because only one control point is loaded. 

Click on I Absolute I to use memory addresses based at O. Click on I Relative I 
to use memory addresses relative to the base address of the current 
control point section. 

2. Specify the Search Boundary to use. The search boundary indicates 
the stride used for checking memory. 

Click on I Byte I to check memory in byte increments, click on I Parcel I to 
check memory in parcel increments, click on I Halfword I to check 
memory in half word increments, or click on I Word I to check memory 
in word increments. 
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3. Specify the Pattern/Mask Size. The size indicates the size of the data 
pattern for which this utility searches and the mask it uses. 

The settings available depend on the Search Boundary setting. Click 
on ~, 1 parcell, 1 Halfword I, or 1 \IIord 1 to select the pattern and mask size. 

4. Specify the Pattern/Mask Format. The format indicates the type of 
data pattern for which this utility searches and the mask it uses. 

The settings available depend on the Pattern/Mask Size setting. Click 
on 1 Byte I, 1 parcell, 1 Halfword I, or 1 \IIord 1 to select the pattern and mask format. 

5. Specify the data pattern you want to search for in the Pattern field. 

6. Specify the mask you want to use in the Mask field. The mask 
specifies which bits to compare. If a bit in the mask is set to 0, the 
bit position is not compared; if a bit in the mask is set to 1, the bit 
position is compared. 

7. Specify the memory block to search (performing any two of the 
following actions automatically updates the third field): 

• Enter the first address of the memory block in the Starting 
Address field and press return. 

• Enter the length of the memory block in the Length field and 
press return. 

• Enter the last address of the data block in the Limit field and 
press return. 

8. Click on ( Start) to start the search. The ( Start) button changes to 
(Stop ), and MME updates the MME Find Utility window. 
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~ MME Find Utility 

Base: 00000000000100 000000 000000 000000 000000 = 
I Absolute I Relative I 00000000000101 000000 000000 000000 000000 ~ 00000000000102 000000 000000 000000 000000 
Search Boundary: 00000000000103 000000 000000 000000 000000 

00000000000104 000000 000000 000000 000000 I Byte I Parcel I Halfword I Word I 00000000000105 000000 000000 000000 000000 
00000000000106 000000 000000 000000 000000 

Pattern/Mask Size: 00000000000107 000000 000000 000000 000000 

I Word I 00000000000110 000000 000000 000000 000000 
00000000000111 000000 000000 000000 000000 
00000000000112 000000 000000 000000 000000 

Pattern/Mask Format: 00000000000113 000000 000000 000000 000000 

I Byte I Parcel I Halfword I Word I 00000000000114 000000 000000 000000 000000 
00000000000115 000000 000000 000000 000000 

Pattern: 00000000000116 000000 000000 000000 000000 
00000000000117 000000 000000 000000 000000 

000000 000000 000000 000000. 00000000000120 000000 000000 000000 000000 
Mask: 00000000000121 000000 000000 000000 000000 

00000000000122 000000 000000 000000 000000 
177777 177777 1 77777 177777 00000000000123 000000 000000 000000 000000 

00000000000124 000000 000000 000000 000000 
Address: 00000000000010, 00000000000125 000000 000000 000000 000000 

Length: 00000000100000, 00000000000126 000000 000000 000000 000000 
00000000000127 000000 000000 000000 000000 

Limit: 00000000100010, 00000000000130 000000 000000 000000 000000 
00000000000131 000000 000000 000000 000000 

( Stop ) ( Continue) 00000000000132 000000 000000 000000 000000 
00000000000133 000000 000000 000000 000000 Cl 

256 matches, ad d itional occurances know n to ex ist 

Click on (Stop) to stop searching for the pattern; if more than 256 
occurrences exist, click on (Continue) to see the next set of entries. 

Utilities -> Copy/Move 

This feature has not been implemented yet. 

Utilities -> 18 Dump 

This feature has not been implemented yet. 

Utilities -> Configuration 

Find ... 

m D:Jrr:~: ... 

Log ic M on itor ... 

Command Buffer ... 

HDM-xxx-O 
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The Utilities -> Configuration command, as shown at the left, starts the 
System Configuration Environment (SCE), which you use to configure the 
mainframe. For more information about SCE, refer to the System 
Configuration Environment document, publication number HDM-xxx-O. 
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Utilities -> Logic Monitor 

=::!-:-ar ... 

Find ... 

Config uration ... 

Command Buffer ... 

The Utilities -> Logic Monitor command, as shown at the left, starts the 
Logic Monitor Environment (LME). For more information about LME, 
refer to the CRAY T90 Series LME User Guide document, publication 
number HDM-xxx-O. 

Utilities -> Command Buffer 

Find ... 

Config uration .. . 

logic Monitor .. . 

The Utilities -> Command Buffer command, as shown at the left, starts the 
Command Buffer Parser (CBP) application with the CRAY T90 series 
CBP runtime. module. For more information about the CRAYT90 series 
CBP runtime module, refer to the CRAY T90 Series CBP Runtime Module 
document, publication number HDM-xxx-O. 

Reset -> Channel ') 

... The Reset -> Channel command, as shown at the left, resets the FY driver. 

Server 

Config uration 

I/O (Quad 0) 

I/O (Quad 1) 

I/O (Quad 2) 

I/O (Quad 3) 

Shared 

Reset -> Server 

Channel 

\er"er 

Config uration 

I/O (Quad 0) 

I/O (Quad 1) 

I/O (Quad 2) 

I/O (Quad 3) 

Shared 

108 

The Reset -> Sever command, as shown at the left, resets the server. This 
halts all control points, reloads the controller (environment 2 only), and 
reloads the control points. 

NOTE: The control point reload function done by the Reset -> Server 
command does not remove any global or local changes you have 
made to the control points. If you want to reload control points 
and remove any global or local changes, click on ( Reload). 
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Reset -> Configuration 

Channel 

Server 

I/O (Quad 0) 

I/O (Quad 1) 

I/O (Quad 2) 

I/O (Quad 3) 

Shared 

The Reset -> Configuration command, as shown at the left, causes SCE to 
reapply the configuration. 

NOTE: This command does not work if any partitions have an OS 
owner. For more information about partition ownership, refer to 
the System Configuration Environment document, publication 
number HDM-xxx-O. 

Reset -> 1/0 (Quad 0) 

Channel 

Server 

Configuration 

.'.I .... @' .. _ 
I/O (Quad 1) 

I/O (Quad 2) 

I/O (Quad 3) 

Shared 

The Reset -> I/O (Quad 0) command, as shown at the left, toggles 
Master Clear for 110 quadrant O. 

Reset -> 1/0 (Quad 1) 

Channel 

Server 

Configuration 

I/O (Quad 0) 

I/O (Quad 2) 

I/O (Quad 3) 

Shared 
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The Reset -> 1/0 (Quad 1) command, as shown at the left, toggles 
Master Clear for 110 quadrant 1. 
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Reset -> I/O (Quad 2) 

Channel 

Server 

Conflg uratlon 

I/o (Quad 0) 

I/O (Quad 1) 

.' .. e .... mw 
I/O (Quad 3) 

Shared 

The Reset -> I/O (Quad 2) command, as shown at the left, toggles 
Master Clear for I/O quadrant 2. 

Reset -> 1/0 (Quad 3) 

Channel 

Server 

Config uration 

I/O (Quad 0) 

I/O (Quad 1) 

I/O (Quad 2) 

4",e"i1'6_ 

Shared 

Reset -> Shared 

Channel 

Server 

Con fig uration 

I/O (Quad 0) 

I/O (Quad 1) 

I/O (Quad 2) 

I/O (Quad 3) 

110 

The Reset -> I/O (Quad 3) command, as shown at the left, toggles 
Master Clear for I/O quadrant 3. 

The Reset -> Shared command, as shown at the left, toggles Master Clear 
for the shared module. 
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Figure 8. Environment 1 Menu Quick Reference 
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Save 
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